"Injection Failed" error message details

"Injection Failed" error message details

Hi,

I am getting an Error Message "Injection Failed. See Log for details" when i provide a benchmark  executable file in Intel GPA Monitor other than gpasample application. Only 64 bit benchmarks installed under /program files/ are executed to get profile parameters. but all the apps installed under /program files(x86) are popping the error message indicated.

When i checked the logs, i am gettiing following info:

Class: CLASS_SHIM

Code: SHIM_INJECTION_FAILED

Message: Failed to get load libraray export

File:...\inject_Utils.cpp

Line:1072

Tried to solve by enabling Auto-Detect in "preferences " icon but it didnt work.

Best Regards 

Shashank.L

12 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Hello,

Thanks for using Intel GPA; sorry that you are running into this issue.

First of all, please right-click on the Intel GPA Monitor in the notification tray and copy the "About..." info here. I'll need this information to help identify your specific system configuration.

Reading your posting, I think you are saying that all 64-bit apps seem to run OK (that is, Intel GPA is able to attach to them and display metrics), but any 32-bit apps have the issue you identified. Is this true? Also, does the problem occur only with apps that you have built, or with any 32-bit apps?

In parallel with gathering this info, here are a couple of things to try:

  • It's possible that some libraries needed by Intel GPA are missing or "locked". I'm wondering if you have recently installed any Windows updates, but haven't yet rebooted your system. So please try a reboot and let me know if the problem still occurs.
  • Similar to the previous item, please check that you have all Windows patches installed, especially if you haven't performed an update recently. Then reboot and try again and let me know what happens.

Hopefully with some additional information from you and trying a couple of the items I've suggested we can get you up and running quickly.

Regards,

Neal

Nill

Hello,

Thanks for the info about your configuration and which apps seem to have the problem.

Can you let me know whether the problem still occurs after a reboot and/or after installing Windows patches?

thanks!

Neal

Hello,

I performed windows update and rebooted the system but still i am observing same error.

Best Regards
Shashank.L

Hello,

I performed windows update and rebooted the system but still i am observing same error.

Best Regards
Shashank.L

Hello,

Thanks for doing the update/reboot of your system, as this ensures that all is at a known state.

I did talk to the development team, and they are asking that you send me a copy of C:\Windows\SysWOW64\kernel32.dll. The error "Failed to get load library export" occurs when Intel GPA is accessing this DLL -- there may be something about this particular file and/or your configuration that causes this issue.

So please let me know if there's a way we can get this file from you.

Regards,

Neal

Hello,

I am have shared the file in the attachments. Please refer to it.

Best Regards
Shashank.L

Hello,

I've downloaded the file... I'll have the team take a look at it.

Regards,

Neal

Hello,

If you have a chance, please let me know whether you have an existing NDA with Intel.

Thanks!

Neal

ps-> I sent you a private msg on this, but hadn't heard back, so I thought I would post this here.

Hello,
Hi,

Yes..I have an NDA with Intel..

Best Regards
Shashank.L

Hello,

I sent you a "private message" regarding this defect to the email account you have registered with Intel -- have you received this email? The bottom line is we have a patch we would like you to test.

Regards,

Neal

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!