error #30008: Unable to create lock file

error #30008: Unable to create lock file

Hi All,

I am using Intel Composer XE 2013 with Visual Studio 2010 SP1 and when I reach step: "Build Using PGO and run" I gat a strange error message. I think it is in connection with Intel C++ Compiler.

I created a very simple console project(attached the source) and the error message in the release_pg directory is below. What can be the problem here?

 

Regards,

Zsolt

Build started 2013.01.03. 14:43:18.      1>Project "c:\Users\Zsolt\documents\visual studio 2010\Projects\tesztcppconsole\tesztcppconsole\tesztcppconsole.vcxproj" on node 2 (build target(s)).      1>InitializeBuildStatus:          Creating "Release_PG\tesztcppconsole.unsuccessfulbuild" because "AlwaysCreate" was specified.        MessageBuildingWithCompiler:          Building with Intel(R) C++ Compiler XE 13.0        ClCompile:          ***** ClCompile (Win32 - Intel C++)          All outputs are up-to-date.          C:\Program Files\Intel\Composer XE 2013\bin\ia32\icl.exe /c /Qvc10 /Qlocation,link,"$(VCInstallDir)\bin" /Zi /nologo /W3 /O2 /Oi /Qipo /Qftz- /D WIN32 /D NDEBUG /D _CONSOLE /D _UNICODE /D UNICODE /EHsc /MD /GS /Gy /fp:fast /QxHost /Zc:wchar_t /Zc:forScope /Qprof-use /Qprof-dir "c:\Users\Zsolt\documents\visual studio 2010\Projects\tesztcppconsole\tesztcppconsole\Release_PG\\" /Fo"Release_PG\\" /Fd"Release_PG\vc100.pdb" /Gd /TP tesztcppconsole.cpp          tesztcppconsole.cpp          error #30008: Unable to create lock file, c:\Users\Zsolt\documents\visual studio 2010\Projects\tesztcppconsole\tesztcppconsole\Release_PG" -diag_enable_disable_vector E:level3\pgopti.dpi.lock.      1>C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\PlatformToolsets\Intel C++ Compiler XE 13.0\Microsoft.Cpp.Win32.Intel C++ Compiler XE 13.0.targets(272,5): error MSB6006: "icl.exe" exited with code 1.      1>Done Building Project "c:\Users\Zsolt\documents\visual studio 2010\Projects\tesztcppconsole\tesztcppconsole\tesztcppconsole.vcxproj" (build target(s)) -- FAILED.

Build FAILED.

Time Elapsed 00:00:00.11

AnexoTamanho
Download tesztcppconsole.zip684 bytes
18 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

>>...error #30008: Unable to create lock file...

It looks like an Access Rights related problem for release_pg directory but I could be wrong. I would simply try to manually create a file in the folder.

I also did a quick web-search for MSB6006 error and I see that it is too generic.

引文:

Sergey Kostrov 写道:

>>...error #30008: Unable to create lock file...

It looks like an Access Rights related problem for release_pg directory but I could be wrong. I would simply try to manually create a file in the folder.

In which directory do you mean? I created a file pgopti.dpi.lock in C:\Users\Zsolt\Documents\Visual Studio 2010\Projects\tesztcppconsole\tesztcppconsole\Release_PG. But the message is the same.

I also checked the access rights and everybody has full control to this release_pg library.

>>...In which directory do you mean?

..\release_pg

>>...I also checked the access rights and everybody has full control to this release_pg library.

This is exactly what I suggested to verify. Thanks.

>>...error #30008: Unable to create lock file...

I think Intel C++ software developers should look at source codes where a processing for error #30008 is done. At the moment I can't suggest anything else.

Hi Zsolt

I am able to reproduce the same problem when I use the PGO workflow in Intel C++ Compiler 13.0 with VS2010 SP1. As I investigate further on this issue, I would like suggest you a work around. PGO workflow is a one-step solution which triggers each phase one of the other in sequence automatically rather than manually trigerring them.

Phase 1: Instrumentation of code.
Phase 2: Running the instrumented binary
Phase 3: Profile based optimization build

The work around is to trigger each phase manually from VS2010 by following the below steps in sequence:

1. Right click on project > Properties > Configuration Properties > General > Intel Specific (on the right panel) > Profile-Guided Build Options and select "Phase 1: Instrument for optimization (Qprof-gen)".
2. Now with this settings, build the project which will generate the instrumented binary.
3. Now execute the instrumented binary by select Debug > Start without Debugging.
4. After execution, right click on the project > Properties > Configuration Properties > General > Intel Specific (on the right panel) > Profile-Guided Build Options and select "Phase 3: Optimize with Profile Data (Qprof-use)". This build is the one which was failing in the workflow. I was able to generate the .dpi file and the optimized executable using this manual procedure.

Please let me know if you face any issue while following the above steps. Thanks for bringing this issue to our notice. Happy new year!!!

Thanks and Regards
Anoop

Hi Anoop,

Thanks. Your suggestion worked.

Happy new year to you also:).

Regards,
Zsolt

>>...I also did a quick web-search for MSB6006 error and I see that it is too generic.

Hi everybody,

This is a short follow up regarding MSB6006 error. I reproduced it today in a very simple test-case compiled with Visual Studio 2010 Express Edition:

#include "thread"
#include "iostream"

void main( void )
{
auto hello_world = [] ()
{
std::cout << "Hello world" << std::endl;
};

hello_world();
}

Here is an output:

...
C:\Program Files\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\Microsoft.Cpp.Win32.Targets(147,5): error MSB6006: "CL.exe" exited with code 2.
C:\WuTemp\LambdaTestApp\LambdaTestApp.cpp(5): fatal error C1083: Cannot open include file: 'thread': No such file or directory
...

Note: "thread" header file is not included in Visual Studio 2010 Express Edition.

Hi Zsolt,

Thanks for reporting the issue! This is a bug in icl. Currently it's assigned to the appropriate engineer and will be fixed in one of the updates.
As a workaround, try to avoid spaces in paths. You may use non default Profile Directory path. Open PGO dialog and change Profile Directory from $(IntDir) to "c:\temp\profile".

Regards,
Vadim G.

>>... try to avoid spaces in paths...

Do you mean like spaces in visual studio 2010 folder name?
...
error #30008: Unable to create lock file, c:\Users\Zsolt\documents\visual studio 2010
...

Yes

>>>>>>... try to avoid spaces in paths...
>>>>
>>>>Do you mean like spaces in visual studio 2010 folder name?
>>>>...
>>>>error #30008: Unable to create lock file, c:\Users\Zsolt\documents\visual studio 2010
>>>>...
>>
>>Yes

As a workaround it could work and I expect a better testing in the future.

Simply to note, on Windows platforms long names with spaces are widelly used since 1995.

引文:

VADIM G. (Intel) 写道:

Hi Zsolt,

Thanks for reporting the issue! This is a bug in icl. Currently it's assigned to the appropriate engineer and will be fixed in one of the updates.
As a workaround, try to avoid spaces in paths. You may use non default Profile Directory path. Open PGO dialog and change Profile Directory from $(IntDir) to "c:\temp\profile".

Regards,
Vadim G.

Thanks Vadim for the work around.

Regards
Anoop

Hi Zsolt

We believe the issue fixed now. I will let you know when this is pushed to production for customers. Again thanks for reporting this issue.

Regards
Anoop

Hi Zsolt,

This issue is fixed. Please use the latest version of the Intel C++ Compiler.

Thanks and Regards
Anoop

引文:

Sergey Kostrov 写道:

>>...error #30008: Unable to create lock file...

It looks like an Access Rights related problem for release_pg directory but I could be wrong. I would simply try to manually create a file in the folder.

It looks more like compiler generated error.

Greetings,

a quick Google search gave me that there is issue "DPD200239855" in Intel internal tracker about this.

It looks like it was resolved in 2013, March, by Update 3: https://software.intel.com/en-us/articles/intel-composer-xe-2013-compilers-fixes-list

Best

--
With best regards,
VooDooMan
-
If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.

Or was not (fully)?

--
With best regards,
VooDooMan
-
If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!