Why my Vtune 2013 do not have bandwidth viewponit when measuring Core i7 CPU

Why my Vtune 2013 do not have bandwidth viewponit when measuring Core i7 CPU

imagem de C J.

Hi, all

There is a problem with Vtune troubled me a few days as specific as bellows. I will be very grateful if someone can help me to solve this problem.

The tool version is Intel Vtune amplifier xe 2013  update2 evaluation version (noncommercial license), which was download from intel official web site.The purpose is to use Vtune to measure the required bandwidth of my application. My CPU is Intel Core i7 2600, whose architeture is sandy bridge. My  OS is redhat enterprise linux 6.2. The Vtune mode used is GUI.

The problem is: when I choose analysis type, I choose "sandy bridge / ivy bridge" -> "General Exploration" and ticked the "Analyze memory bandwidth". After finished anaylsis, it displayed "Analysis is completed" and "Finalization completed successfully". But in the "Summay", id displayed  "Elapsed time: 0.000s", and the viewpoint button is only one option to choose, which is "Task Time", and not my wanted "bandwidth". as the Vtune Help document says, there would be a "bandwidth" option.

Then I shoosed the "bandwidth" type, get the same result. 

I want to know, if  my evaluation version or my CPU cannot support harware event-based sampling collection, or there is something must be set but I igored.   

Is there someone knows, thanks!

4 posts / 0 new
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de Peter Wang (Intel)

Some things were wrong - displayed "Elapsed time: 0.000s", did you specify target application?

I recommend to use latest U3, I ensure that the tool supports bandwidth analysis on Sandbridge processors.

Please check all vtune drivers work:
# lsmod | grep sep
# lsmod | grep pax
# lsmod | grep vtsspp
If they are not available, please go vtune_amplifier/sepdk/src, to build/install drivers.

Check if nmi_watchdog_timer is disbaled.
# cat /proc/sys/kernel/nmi_watchdog
0

Then try command line, first. You can view result by using amplxe-gui.
# amplxe-cl -collect snb-bandwidth -- /bin/ls

imagem de C J.

Quote:

Peter Wang (Intel) wrote:

Some things were wrong - displayed "Elapsed time: 0.000s", did you specify target application?

I recommend to use latest U3, I ensure that the tool supports bandwidth analysis on Sandbridge processors.

Please check all vtune drivers work:
# lsmod | grep sep
# lsmod | grep pax
# lsmod | grep vtsspp
If they are not available, please go vtune_amplifier/sepdk/src, to build/install drivers.

Check if nmi_watchdog_timer is disbaled.
# cat /proc/sys/kernel/nmi_watchdog
0

Then try command line, first. You can view result by using amplxe-gui.
# amplxe-cl -collect snb-bandwidth -- /bin/ls

Mr Wang, thanks very much for your help! Your valuable suggestion have indeed solverd my problem!

In my test, I choosed one target application, and checked all vtune drivers include sep, pax, vtsspp are working well.

Then I checked if nmi_watchdog_timer is disbaled.
# cat /proc/sys/kernel/nmi_watchdog
1
The result showed that my nmi_watchdog was not disabled. That's the reason!

After input the command:

# amplxe-cl -collect snb-bandwidth -- /bin/ls

It also output info which remind me to turn off the nim_watchdog.

So I found this link which tells us how to disable nmi_watchdog. http://software.intel.com/en-us/articles/disable-nmi-watchdog-when-using-pmu-event-based-sampling

Two solutions:

1.     Add argument “nmi_watchdog=0” in /boot/grub/grub.conf , then reboot system

2.     Disable NMI_Watchdog, at running time

# echo 0 > /proc/sys/kernel/nmi_watchdog

"

After finished setting by the second way, I can measure the bandwidth correctely!

But a new problem is coming: In the computer with Intel CPU Core i7-2600, sometimes when measuring the bandwidth, the system will black the screen and shut down  suddenly!

But in another computer, which is a server with Intel Xeon CPU E5-2650, the system is always working well during the bandwidth testing.

I think maybe due to that the former CPU is a desk-top one which is designed for home usage and not suitable for computing. So it could not support hardware-based sampling completely.

Is there any other speculation?

 

imagem de Peter Wang (Intel)

I'm glad to see that the problem has been solved.

Faça login para deixar um comentário.