imsl: cannot open include file "link_fnl..."

imsl: cannot open include file "link_fnl..."

I have followed the instructions to install and use IMSL:

http://software.intel.com/en-us/articles/installing-and-using-the-imsl-l...

And get error #5102: Cannot open include file "lnk:fnl_static.h". The directions said to recheck your steps and I did. Can anyone give some advice? I am using VS 2008, Intel Visual Fortran 11.1.070, Window 7, 64 bit, IMSL 6.0.0. To test, I took a sample Fortran program, d_trig_tforms_bvp.f90, which I got to compile and run, and simply added these lines as the directions indicated:

program d_tt_example_bvp
use mkl_dfti
use mkl_trig_transforms
INCLUDE 'link_fnl_static.h'
!DEC$ OBJCOMMENT LIB:'libiomp5md.lib'

9 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Does the folder C:\Program Files (x86)\VNI\imsl\fnl600\intel64\include\dll exist?  What exactly is the contents of the "Include files" list for x64?

Steve - Intel Developer Support

My path is slightly different, instead of ...\intel64\include\dll it is ...\IA64\include\dll. It has 2038 .mod files. Thanks.

Citação:

instead of ...\intel64\include\dll it is ...\IA64\include\dll

That is unusual. Do you really have the Itanium version of IMSL installed, as "ia64" signifies? That version will not work with x86 or x64 processors.

How could I tell? "Inventory Control" installed it on my laptop so I could ask them if there are other options on the install. I don't even know what Itanium is, but just read on wiki. From what I read, it is doubtful I have that kind of processor. The laptop is an HP Compaq 8000 Elite CMT PC, and processor is: Intel Core 2 quad CPU, Q5550. Should I ask inventory to reinstall with a different option? Thanks!

I have never heard of laptops with Itanium CPUs -- these processors consume over 100 W, are priced over $500!, and are used for servers, HPC clusters, and so forth.

You should uninstall the IA64 version of IMSL, and install either (or both, if you like) the IA32 or Intel64/AMD64 version instead.

mecej4 has part of the right answer - your IT department installed the wrong IMSL. But I would have expected the compiler to at least open the .h file, and then complain that the modules were for the wrong platform. Perhaps because you followed the instructions in the article, which would not find the IA-64 files, you got the initial error. In that case, installing the correct IMSL should resolve the problem.

Steve - Intel Developer Support

In response, my IT dept gave me these files below. Do any of them look like the correct install files? Thanks!

w_cprof_p_11.1.070.exe
w_cprof_p_11.1.072_ia32.exe
w_cprofimsl_p_11.1.062_ia32.exe
w_cprofimsl_p_11.1.062_ia64.exe
w_mkl_10.3.3.175.exe

No. You need w_cprofimsl_p_11.1.062_intel64.exe

Steve - Intel Developer Support

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!