cmake error for ipp-sample.7.1.1.013

cmake error for ipp-sample.7.1.1.013

imagem de rudy B.

Hi, 

I followed exactly how to setup the Main Samples. (w_ipp-samples_p_7.1.1.013)

http://software.intel.com/en-us/articles/code-samples-for-intel-integrat...

I installed perl and cmake properly, as instruced.

And, when I typed  "perl builder.pl", I got the follwoing, which is all okay so far:

Usage: perl build.pl --cmake=SAMPLE,ARCH,GENERATOR,LINKAGE,THREADING,CONFIG [--clean] [--build] [--msdk] [--comp=native/intel]
Required variants:
SAMPLE | ARCH | GENERATOR | LINKAGE | THREADING | CONFIG
advanced-usage | | | | |
audio-video-codecs | | | | |
computer-vision | | vc2012 | | |
data-compression | | vc2010 | | |
image-codecs | | vc2008 | | |
image-processing | ia32 | nmake | s =static | st =single | debug
language-interface | intel64 | make | d =dynamic | mt =multi | release
signal-processing | | eclipse | | |
speech-codecs | | xcode | | |
string-processing | | | | |
uic | | | | |

Optional flags:

--clean - clean build directory before projects generation / build
--build - try to build projects before generation
--comp - try to use custom compiler, native(=gcc/cl.exe) or intel(=icc/icl.exe). Need to call environment!

Examples:

perl build.pl --cmake=audio-video-codecs,ia32,vc2010,s,st,release [ only generate projects ]
perl build.pl --cmake=uic,intel64,make,s,mt,debug --build [ generate and then build ]
perl build.pl --cmake=uic,intel64,make,d,mt,debug --build --clean [ generate, clean and build ]

But, when I tried to generate any of the projects, it keeps failing. And, no matter what <SAMPLE> I try, it fails.

for example, when I tried to build with UIC (just like below), I keep getting the following error:

C:\Program Files (x86)\Intel\Composer XE 2013\ipp\ipp-samples.7.1.1.013\builder>perl build.pl --cmake=uic,intel64,vc2010,d,mt,debug

Not searching for unused variables given on the command line.
CMake Error: The source directory "C:/Program Files (x86)/Intel/Composer XE 2013/ipp/ipp-samples.7.1.1.013/__cmake/uic.intel64.vc2
010.d.mt/2013/ipp/ipp-samples.7.1.1.013/sources/uic" does not exist.
Specify --help for usage, or press the help button on the CMake GUI.

I am not sure why it is looking for such directory. I am not sure, but somehow it looks for a directly that doesn't exist.

Any idea what is going on? 

Many thanks in advance, 

--Rudy

5 posts / 0 new
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de Gennady Fedorov (Intel)

in that case: do you see really the UIC sample installed on your system?

imagem de rudy B.

It is not just UIC. I get the same error message with other samples too (e.g audio-video-codecs, ...). 

I have a feeling something is not right with Cmake? Do i need anything else too run the Cmake? (e.g. maybe "make", or something else?)

imagem de Sergey Khlystov (Intel)

Hi,

I think, you need to move the samples out of "Program Files". First, because if it's Windows 7, writing to "Program Files" requires elevated permissions. Second, build script fails on directories with spaces in the name. We must have fixed this, but I don't remember if this fix was released or not. So, better not to experiment. Move the samples directory to plain "C:\work" or so.

Regards,
Sergey 

Regards, Sergey
imagem de rudy B.

Thanks,

that solved it....

cmake didn't like directories with spaces....

--Rudy

Faça login para deixar um comentário.