error data type

error data type

imagem de diana g.

hello, the program give me en error on the subroutine

SUBROUTINE tteta (ttx,tty)
use ifqwin

INTEGER(2) line,ttx,tty
TYPE (xycoord) xy
CALL moveto(INT2(ttx+2),INT2(tty),xy)
line=lineto(ttx,tty+4)
line=lineto(ttx+7,tty+4)
line=lineto(ttx+5,tty)
line=lineto(ttx+3,tty)
CALL moveto(INT2(ttx),INT2(tty+5),xy)
line=lineto(ttx+2,tty+9)
line=lineto(ttx+5,tty+9)
line=lineto(ttx+7,tty+5)
END SUBROUTINE tteta

the error is:

warning #6075: The data type of the actual argument does not match the definition

where is the problem???

17 posts / 0 new
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de Tim Prince

Is this with warn-interfaces (the default in GUI mode)?  It would indicate an argument doesn't match your caller, or what is specified in ifqwin.

imagem de Steve Lionel (Intel)

In this case, all of the routines being called are defined in module IFQWIN. The arguments are all declared to be INTEGER(2),  but when you say something like tty+4, the 4 is "default integer" (integer(4)), so the expression becomes integer(4), and that's a mismatch.  To fix this, add the suffix _2 to all of the integer constants, for example, tty+4_2.  This specifies that the 4 (in this case) is to be integer(2).

Steve
imagem de diana g.

ok perfect! problem number one solve! thank yuoi! 

now I have another question, I have to do a resource file .fd and I followed the 6 step, but the program give me the error:

error PRJ0019: A tool returned an error code from "Generating Fortran include file..." Project

I read the topic at this link http://software.intel.com/en-us/forums/topic/291937 but I haven't found a solution yet!

 

imagem de Steve Lionel (Intel)

Ah, that would be the "deftofd" tool. Would you please ZIP the buildlog.htm from the Debug folder and attach it to a reply here? If you would also include the .vfproj file, that would be helpful.

Steve
imagem de diana g.

here it is! 

Anexos: 

AnexoTamanho
Download program.zip11.25 KB
imagem de Steve Lionel (Intel)

Something very strange there. The error is that it is trying to process rett.h but your project says rett2.h. The latter exists, the former doesn't.

Please do a build > Rebuild and see if that helps. If not, please attach a zip of the new buildlog.htm

Steve
imagem de diana g.

I recreate the project but the error was the same! I rebuild and:

imagem de diana g.

sorry I forgot this file resource.h  in the zip file

Anexos: 

AnexoTamanho
Download g-aree.zip11.29 KB
imagem de Steve Lionel (Intel)

Diana,

You did not quite properly follow the instructions for adding the resource file to the project. It looks to me as if you started to do this, then renamed one of the files, as I can't otherwise figure out how you got the project in the state it's in. The resource.h file that is created by the dialog editor needs to be added to the project and then a custom build step defined for it. You had a custom build step attached to figure.rc.

I have attached a corrected .vfproj file, but I find that the resource.h and figure.rc files you provided are out of sync (the .rc is looking for an IDC_EDIT1 value that the .h doesn't define), and the .bmp is ,missing, but I think this should get you going again. Note that in the custom build step for resource.h I have the output file labeled figure.fd as that's what your code uses. The instructions are on page 81 of Using Intel Visual Fortran to Create and Build Windows Applications.

Anexos: 

AnexoTamanho
Download g-aree.zip920 bytes
Steve
imagem de diana g.

thank you Mr. Lionel you are my angel!!!!! I forgot to add the .h file and as you said I renamed the file after the building, then I tried to use the "deftofd" on the .rc file not on the .h file.

Now I add the resource.fd file in a subroutine and I call this subroutine trought a menu button 

external initrett

....

bret=appendmenuqq(2,$menuenabled,'Rettangolo'C,initrett)

....and the subroutine is

subroutine initrett
use ifqwin
use iflogm
type (dialog) dlg
real  b,h,xo,yo,alfa
logical(4) bret
integer(4) iret
character(25)  dato
include 'resource.fd'
bret=dlginit(idd_dialog1,dlg)

bret=dlgset(dlg,idc_edit2,'0')
bret=dlgset(dlg,idc_edit3,'0')
bret=dlgset(dlg,idc_edit4,'0')
bret=dlgset(dlg,idc_edit5,'0')
bret=dlgset(dlg,idc_edit6,'0')
bret=dlgset(dlg,idc_radio1,.true.)
bret=dlgset(dlg,idc_radio1,.false.)

iret=dlgmodal(dlg)
call dlguninit(dlg)
end subroutine initrett

the program start, but when I click on the "Rettangolo" menu button the program tell me:

Unhandled exception in 0x7782E8A1 (ntdll.dll) in g-aree.exe: 0xC0000005: Access violation when writing path 0x00150FFC.

imagem de Steve Lionel (Intel)

Would you please attach a ZIP of the whole project, including everything needed to build it? I'll take a look.

Steve
imagem de diana g.

I don't understand what is wrong now...I'm a disaster...

Anexos: 

AnexoTamanho
Download g-aree.zip1.18 MB
imagem de Steve Lionel (Intel)

Hmm - I can't get this to fail. I pull up the Rettangolo option, it displays a new dialog. I type some things in the box and click OK, it goes away. I am not sure what it is supposed to do. If you run this in the debugger, can you see where in the progam it stopped when the error occurred?

Steve
imagem de diana g.

what I have to do to run it from in the debugger??? I dont understand...sorry for my ignorance...

imagem de mecej4

Quote:

what I have to do to run it from in the debugger?

Choose the win32/Debug or X64/Debug configuration in Visual Studio.

I would suggest that, if you are going to run your program under the symbolic debugger, you turn off the /check options. I compiled your sources from the command line with the /Zi option, and the program was built with no error messages. The resulting EXE ran fine in the debugger up to a point -- I don't know what the program is supposed to do, whether the menu choices actually result in actions or the underlying source code is just a skeleton at this stage.

imagem de diana g.

I read other topic to find something like my problem as:

http://software.intel.com/en-us/forums/topic/273908

http://software.intel.com/en-us/forums/topic/277220

but I didn't found a solution. I know the problem is in the line where I call the callback function that create the dialog box but I don't how to solve it

Faça login para deixar um comentário.