Disable Ultrabook Touchpad

Disable Ultrabook Touchpad

Is there a way to disable the touchpad on the Ultrabook? Thanks.

23 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de Rumnha

Here are the instructions to disable touchpad if you synaptics drivers installed - http://blogs.msdn.com/b/scicoria/archive/2013/01/29/disable-swipe-on-syn...

Thanks, Rumnha
imagem de Ural (Intel)

Assuming you are using Windows 8, here are the steps
open Search Charm > Enter "Mouse" in search box
Go to settings section. You will get "change mouse settings" option. Select that
If you open that window, you will get option to change settings of Touch Pad.

Ural
imagem de Rumnha

In my Intel SDP, I did not find settings for Touch Pad as @Ural said.

But I could disable my touch pad after installing Synaptic's drivers.

Mouse > change mouse settings. Please refer the attached image.

Anexos: 

AnexoTamanho
Download touchpad.png17.75 KB
Thanks, Rumnha
imagem de Ural (Intel)

hi Rumnha,

If you follow the attached flow, you will be able to disable the touchpad.

Ural

Anexos: 

AnexoTamanho
Download disabletouch.png49.93 KB
Ural

Ural,

I too, don't have a Touchpad tab on my mouse driver to disable it.

Rumnha,

Do you have the URL to download the proper Synaptic drivers for the Intel SDP?

Thank you both!

Sam

Anexos: 

AnexoTamanho
Download no-touchpad-tab.png24.8 KB
imagem de daflippers

Hi Sam,

I see exactly as Ural described on the Intel PUB-RD running Windows 8 Pro.  In device manager the touchpad shows as an Alps Pointing-device manufactured by Alps Electric.  You could uninstall the driver which would be a brute force way to stop it working.

 

David 

David, 

Under what category in Device Manager do you see the Alps Pointing Device (see attached screenshot).

Thanks,

Sam

Anexos: 

AnexoTamanho
Download device-manager.png60.71 KB
imagem de daflippers

Hi Sam,

On mine it is in Mice and other pointing devices, see attached.

 

David

Anexos: 

AnexoTamanho
Download alps.jpg110.88 KB
imagem de daflippers

Of course if the reason for disabling the touchpad is because of erroneous actions when typing *and* you have the touchpad configuration tool - probably available via hidden icon in the taskbar then you can adjust TouchGuard TM. at the bottom - see attached.

David 

Anexos: 

AnexoTamanho
Download touchguard.jpg37.1 KB

Thanks, David,

I'm obviously missing a driver, since I have neither the Touchpad tab under mouse settings, nor any Alps pointing device in Device Manager. I'll try to locate and install the Synaptics driver and report back my results.

Hi Rumnha,

I see quite a number of OEMs listed on the Synaptics site: http://www.synaptics.com/resources/drivers/oem_support, but not Intel. Which driver did you download?

Thanks,

Sam

imagem de Rumnha

@Sam: I downloaded the drivers from their direct link: synaptics.com/resources/drivers for windows 8 (113.9 MB). I guess you should not worry about OEM support, this should just work fine for you. I did not try Alps drivers but you could: eightforums.com/drivers-hardware/10569-windows-8-alps-touchpad-driver.html (I'm not sure if they are official or will work correctly).

@David and @Ural, you guys are right as from your screenshots, I can see you have Alps drivers installed. The reason I could not see the settings on my ultrabook is that I did not have them installed.

So one could go and install Alps or Synaptics drivers to work with touchpad settings. I hope this make sense.

Thanks, Rumnha
imagem de daflippers

Hi Sam/Rumnha,

Did you check out Intel Premier Support for the driver?

David

imagem de PONRAM

I think checking the follwoing link may help with you http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc...

imagem de PONRAM

To disable the TouchPad:

  1. Click Start , enter mouse in the search field, and then select Mouse from the search results.
  2. On the Device Settings tab of the Mouse Properties screen, click the Disable button to turn off the TouchPad.

imagem de daflippers

Hi Ponram,

I see you have made a huge number of posts across Intel forums and are trying to help but I believe this refers to an Intel PUB-RD running Windows 8. The drivers are available from Intel Premier Support.  The link you gave was for HP Laptop running Vista or Windows 7.

David

imagem de Rumnha

Yes, David. You are right, It is indeed in the driver package that comes with PUB-RD additionally one can obtain it from Premier support. Thanks for pointing out that. It is just our basic instinct, when we see a problem we tend to go to Google;)

Thanks, Rumnha
imagem de Rumnha

Yes, David. You are right, It is indeed in the driver package that comes with PUB-RD additionally one can obtain it from Premier support. Thanks for pointing out that. It is just our basic instinct, when we see a problem we tend to go to Google;)

Thanks, Rumnha
imagem de daflippers

Hi Rumnha,

Glad to be of help, have you resolved the issue now?

David

Hi David,

I have same issue and search PUB-RD in HP TS but can't find it.

imagem de JudLup Luna

Hi, on keypad some times the manufacturer make a shortcut key for disable this.

JudLup Luna
imagem de daflippers

Hi Lloyd,

Sorry i missed your post.

PUB-RD refers to an Intel Ultrabook released to developers and now no longer supported by Intel Premier support.  If you have one of these then you will need the drivers for the PUB-RD.  If not then you need to get the driver from your Ultrabook manufacturer.

David

imagem de daflippers

Hi Lloyd,

Sorry i missed your post.

PUB-RD refers to an Intel Ultrabook released to developers and now no longer supported by Intel Premier support.  If you have one of these then you will need the drivers for the PUB-RD.  If not then you need to get the driver from your Ultrabook manufacturer.

David

Faça login para deixar um comentário.