Low Latency Software Decode is Breaking Up...

Low Latency Software Decode is Breaking Up...

imagem de Victor D.

When I decode an H.264 720p streams using sample_decode application from 2012 (the original sample that decodes and displays on the screen) the resulting video is all broken up, but only when using low latency mode.  Hardware decode works fine, non-low-latency software mode works fine, but the video is all broken up when decoding in low latency mode, which is the mode I need along with sofware decode.

An example video file is attached, as well as the compiled sample_decode.exe (unmodified built sample_decode project).

Thanks for looking into this,

-Victor

2 posts / 0 new
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de camkego

H.264 material decoded in low latency mode needs to have been encoded with a certain set of H.264 parameters, for example no B-frames.

Your problem might be related trying to decode regular H.264 material without the right parameters set.

I would stick to using low latency decoding only with material that you have encoded using the Intel Media SDK encoder in low latency mode.

Some more information can be found here: http://software.intel.com/en-us/articles/video-conferencing-features-of-...

Regards

Cameron

--

Cameron Elliott
Lime Video Software  206-367-1053
www.limevideo.com
Digital Video SDKs for C# - .NET for Windows - Mono for Linux

Faça login para deixar um comentário.