Complete failure of build process with now warnings/errors generated

Complete failure of build process with now warnings/errors generated

imagem de John K.

Hi

I seem to be experiencing a complete failure of the build process but there is no output at all...

I am running MSVS 9.0 service pack 1 and Composer XE 2013 build 198 on Win 7.

An application I have uses the mkl libraries and that works OK. The problem seems limited to the fortran compiler... ifort is available in my path I get output as expected if I execute ifort /help. I get failures to build at both command line and in VS.

This is the output from a build of your example project, matrix_vector_multiplication_f

========== Build: 0 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========

All I get in the debug directory is a file called CCovLog.html that contains:

1>------ Build started: Project: matrix_vector_multiplication_f, Configuration: Debug Win32 ------

1>

1>matrix_vector_multiplication_f - 0 error(s), 0 warning(s)

There are no other files produced. I see similar problems in our software build.

Where do I begin to look for the problem?

Thanks

John

6 posts / 0 new
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.
imagem de Steve Lionel (Intel)
Steve
imagem de John K.

Thanks. That took care of that one very quickly. Now I get:

1>warning #31001: The dll (mspdb80.dll or mspdb100.dll) for reading and writing the pdb could not be found on your path. This is usually a configuration error.Compilation will continue using /Z7 instead of /Zi, but expect asimilar error when you link your program.

I am pretty sure that I have followed the instructions posted on this in another thread...

Thanks

John

imagem de Steve Lionel (Intel)

Which instructions did you follow?

Steve
imagem de John K.

These from a previous thread entitled: Error #10037: could not find 'lib'

The workaround/solution for these problems is to modify the "Executables:" path in VS 2008 as follows:

1.) Select "Tools->Options"

2.) Expand "Intel Composer XE"

3.) Expand "Visual Fortran"

4.) Select "Compilers"

5.) For 32-bit:
     a.) Under "Platform:", select "Win32"
     b.) Select "..." for "Executables:"
     c.) Add the following:
         "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin"
         under
         "$(VCInstallDir)BIN"
     d.) Select "OK"

imagem de John K.

My previous replies seemed to just disappear.

The changes I made were as per forum article:

Error #10037: could not find 'lib'

and the changes I made were:

1.) Select "Tools->Options"

2.) Expand "Intel Composer XE"

3.) Expand "Visual Fortran"

4.) Select "Compilers"

5.) For 32-bit:
     a.) Under "Platform:", select "Win32"
     b.) Select "..." for "Executables:"
     c.) Add the following:
         "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin"
         under
         "$(VCInstallDir)BIN"
     d.) Select "OK"

Thanks for the help so far.

John

Faça login para deixar um comentário.