Warning: Cannot locate file *.ko

Warning: Cannot locate file *.ko

Hi, 

I am still getting warnings for some *.ko libraries as follows. 

Warning: Cannot locate file `sep3_8.ko'.
Warning: Cannot locate file `ide_cd.ko'.
Warning: Cannot locate file `dm_mod.ko'.

According to documentation these are the driver blobs Intel included, they do not contain the "debug symbols" internally and we did attempt to recompile one and force it to have debug symbols, but those last three I could not find "source code" to do that operation...

Looks like they are kernel modules that are definitely from Intel Vtune. 

How did I get the debug symbols for these components? 

regards,

Reshmi

I have already posted this here. But, since I didnt get a reply there, I am reposting this. 

4 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Hi Reshmi:

You don't!  You should have very few samples within VTune Amplifier XE modules and you aren't going to try to tune those modules, so just ignore the "warning" messages and continue with your work on your own modules. :)

Regards, MrAnderson

Thankd for your reply! 

Reshmi 

Hi Mr. Anderson,

I was getting warning messages for pthread & C libraries. And, it looks like it was somehow messing with the measurements. I was getting a very high value of CPI (around 5.0) with the newer version of VTune. 

If the warnings are about collecting debug info from the library files? why will it effect the measurements. (Please note that I was using pthread to parallelize my C code.) 

Thats why I had posted this again here. 

regards,

Reshmi

Faça login para deixar um comentário.