Dell Venue 7 support

Dell Venue 7 support


Have a Dell Venue 7 (Intel Z2560 based) and want to use it as a hardware device to test my applications. Unfortunately, the current Intel USB driver (from 4/2013, well before Venue 7 launched) doesn't recognize the Venue 7 at all. 

Is there any way to work around this, or do I need to use an ARM device to test my applications? 



20 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.


unfortunately I don't have this device to try it out. 
There are a couple of things you can check or try out:

  • USB debugging enabled?
  • Do you see the device in the device manager with a question mark?

I will check in the meantime if we have an update available to publish. 


Perhaps I have similar issue but with Dell Venue 8.

Installed latest BM from today on a Windows 7 64-bit machine. Using JDK 1.7 update 45.

Dell Venue 8 shows up in Device Manager as a Portable Devices --> Dell Venue 3830.

Based on BM readme, I detached the Dell, uninstalled the media device driver, installed the USB driver from BM and reattached the Dell. Still, its showing up as a media device.

I can start the dev env and see the x86 based AVD but I'd like to attach to the real device.

On the Dell, the USB attach mode is shown as storage.

Ideas for debugging this further?

@ Alexander

Yes, USB debugging is on. No, I cannot install the drivers manually as on my system when I try to do so via the Device Manager, it says no drivers were found (even when I do point it to the right directory). This method works on my old Google Nexus 7, but does not on my Venue 7.




@jay07920 Can you send me an email to my Intel email address? 

@aeassa I'm still checking if we have newer USB drivers that we can release. Have you contacted the Dell support already?

@ Alexander 

Have contacted Dell, but no luck. They don't have a driver but they pointed me to the Intel drivers. 


aeassa wrote:

Have contacted Dell, but no luck. They don't have a driver but they pointed me to the Intel drivers. 

I'm still trying to get some additional feedback internally. It's interesting that Dell pointed you back to the drivers we offer for download. 


            got the same issue with my Dell Venue 7 , I am not able to update the driver for Android under Other Device as mentioned above.

             Is there any update to this ?



Here the exact same problem with Dell Venue 7 driver for Android.

Is there any progress at this issue ? 



I have a Dell Venue 8 3830 to use for development, and I too cannot get the device to connect in the correct way (same results as above users).

Any updates?



For anyone still trying to get a Dell Venue 7 or 8 to work, for this purpose, check out this post on Stack Overflow (worked for me with a Venue 7):

Also, if you're having trouble downloading the 1.1.5 driver from Intel (access denied, or agreement not found errors):

Robert F., 

This worked BEAUTIFULLY! Thank you! 

Going to buy a few more Venue 7/8 tablets for the team :-)

my device is stuck in download mode, just displays a usb logo on the screen and detects as CloverviewPlus Device, how can i get the firmware files and tools needed to reflash this device, dell does not provide any official restore on there site, from reading on older medfield devices that showed this the i beleive i need to reflash the firmware and need the ifwi files.

Hi, i got some really annoying glitches in dell venue 8 3g with 4.4.2

Most of them are probably connected with update 4.3 to 4.4.2, that totally messes up some apps. Most common glitches are described in thread

Unfortunately there is no support of dell with this problem, they even didn't respond the community for help request. After sending my device to dell's support center i got the screen repairder, but no shanges in messy 4.4.2 kitkat.

Today i got the information, that they are not responsible for system as it is not their production. so i don't know where i could get 4.3 system image to downgrade my device to last stable version. we, the community of dell's xda threat got only 4.4.2 dumps for venue 8 3G.

Could anyone help us to get android 4.3 version so we can get our devices working?

Thanks in advance.


Hi LK82,

unfortunately we can't help you here. You need to ask for support and warranty at the company you bought the device.

Browsing through the thread you provided it looks like Dell is trying to help people and solves issues on an individual base. Have you tried contacting the Dell support directly?

Thanks Alex

I am having the same issue, I have a Dell Venue 8 it failed to detect the device at xFSTK downloader, anyone here already found the solution?

Hi Yee,

    Could you let me know you host OS info? Is it a Windows 7 OS or Windows 8 OS?




Hi Yang,

I had found the solution for this, I manually update the driver at device manager to Intel Android ADB Interface, it works now. I am using Windows 8. 

Mooi Yee

Hi Yee,

     Thank you very much for the update. Not sure if the issue is general on the Windows 8 system. It would be great if you can share the detailed steps of your solutions so it can also benefit the others.

 Thank you.




I have a problem with my Dell Venue 7 .It worked well for a month then suddenly turned off ,when I try to start it only Dell trademark with a statement "Supported by Android" appear flashing on the screen and then nothing .Nobody can fix the problem but I was told that it is a problem with the software which is not found in my place. Is there a step I can do myself to fix the problem ,eg downloading, ...??? 

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!