Installation problem (Linux)

Installation problem (Linux)

Hello all,

I'm pretty new to Linux and OpenCL. Really needs some help here.

I got --- Linux RedHat   (on Amazon EC2)

I was following --- Intel OpenCL sdk release notes 

I download  "intel_sdk_for_ocl_applications_2014_4.4.0.117_x64.tgz"  and there's only two .rpm file inside.

In other words, There's no such "opencl-base", "opencl-intel-cpu", "opencl-intel-mic" rpm files.  Where can I get them?

Then, I tried to do
# ./install-cpu.sh

It turns out an dependency error:

error: Failed dependencies:
	opencl-1.2-base >= 1:4.4.0.117 is needed by opencl-1.2-devel-1:4.4.0.117-1.x86_64
	opencl-1.2-base >= 1:4.4.0.117 is needed by opencl-1.2-intel-devel-1:4.4.0.117-1.x86_64
	opencl-1.2-intel-cpu >= 1:4.4.0.117 is needed by opencl-1.2-intel-devel-1:4.4.0.117-1.x86_64
	lsb-core-amd64 >= 4.0 is needed by opencl-1.2-intel-devel-1:4.4.0.117-1.x86_64
	libOpenCL.so.1()(64bit) is needed by opencl-1.2-intel-devel-1:4.4.0.117-1.x86_64
	libOpenCL.so.1(OPENCL_1.0)(64bit) is needed by opencl-1.2-intel-devel-1:4.4.0.117-1.x86_64
	libOpenCL.so.1(OPENCL_1.2)(64bit) is needed by opencl-1.2-intel-devel-1:4.4.0.117-1.x86_64

I tried to fix "install-cpu.sh" with the command "rpm -ivh --nodeps --force ......".  This Does eliminate the error, but I don't think that is successfully installed.

I also tried to download "opencl_runtime_14.1_x64_4.4.0.117.tgz". This package contained "open-1.2-base", but it still shows 

error: Failed dependencies:
	lsb-core-amd64 >= 4.0 is needed by opencl-1.2-base-1:4.4.0.117-1.x86_64
	lsb-core-amd64 >= 4.0 is needed by opencl-1.2-intel-cpu-1:4.4.0.117-1.x86_64

 

One last question, how am I able to verify the installation is successful? Is there any simply test that I can run?

Sorry for the naive questions, and thank you for any help. 

 

 

 

3 posts / novo 0
Último post
Para obter mais informações sobre otimizações de compiladores, consulte Aviso sobre otimizações.

Thanks for your question.  This is a great opportunity to improve on the installation guide in the release notes.

OpenCL is distributed in two parts.  You will need the driver/runtime package and the SDK. 

First install the runtime package
 

$tar -xvzf opencl_runtime_14.1_x64_4.4.0.117.tgz
$cd opencl_runtime_14.1_x64_4.4.0.117
#(Optional: check signatures with
#$ rpm --checksig *.rpm)
$./install-cpu.sh (run as root)

 

Then install the SDK package
 

$tar -xvzf intel_sdk_for_ocl_applications_2014_4.4.0.134_x64.tgz
$cd  intel_sdk_for_ocl_applications_2014_4.4.0.134_x64
#(Optional: check signatures
$# rpm --checksig *.rpm)
$./install-cpu.sh (run as root)

 

The OpenCL samples from the website need a bit of porting to work in Linux.
As a quick start you can get the CapsBasic example from the Beignet project: https://github.com/vpereira/CapsBasic-beignet

The Makefile needs to be changed slightly.  Here is the command to compile:
 

$ g++ capsbasic.cpp -lOpenCL -ocapsbasic -I/usr/local/include -L/usr/local/lib

You should now be able to run the example:

$./capsbasic

Output should look like:

Number of available platforms: 1
Platform names:
    [0] Intel(R) OpenCL [Selected]
Number of devices available for each type:
    CL_DEVICE_TYPE_CPU: 1
    CL_DEVICE_TYPE_GPU: 0
    CL_DEVICE_TYPE_ACCELERATOR: 0

...

Jeffery:   Thank you for the quick response.

When I tried 

$cd opencl_runtime_14.1_x64_4.4.0.117
$./install-cpu.sh 

It still shows dependency error:

error: Failed dependencies:
	lsb-core-amd64 >= 4.0 is needed by opencl-1.2-base-1:4.4.0.117-1.x86_64
	lsb-core-amd64 >= 4.0 is needed by opencl-1.2-intel-cpu-1:4.4.0.117-1.x86_64

Where can I get this "lsb-core-amd64" ?

Thanks !

Deixar um comentário

Faça login para adicionar um comentário. Não é membro? Inscreva-se hoje mesmo!