Intel® Parallel Amplifier

Communication with sampling driver failed

I am trying to do General Exploration analysis, and the following error appears almost immediately after trying to attach to the process,

"Communication with sampling driver failed".

I'm running on Windows 7, on a Intel Xeon CPU E5-2680 (2 processors). Doing the Basic Hotspot Analysis went fine. Any ideas - or things I could try?

 

Cheers,

-J

 

 

amplxe: Warning: Cannot locate debugging symbols for file `xxx'.

Run vtune on host, and there are warnings "amplxe: Warning: Cannot locate debugging symbols for file `/lib64/libc-2.12.so' " and ".amplxe: Warning: Cannot locate debugging symbols for file `/usr/bin/ssh' "

The program run on xeon phi mic.

Does the warnnings have infulence to the result? why this happen as the xxx.so is just there?

 

VTune: Increase sampling frequency to profile Linux Kernel Driver

I am trying to profile a Linux kernel driver and I would like to find out how much CPUcycles/time spent in certain functions. My goal is not to identify the Hotspots in the system but to profile a particular driver function. I have loaded the kernel debug symbols as explained in this article. I can see Kernel functions under [vmlinux] but I can't see the functions that I'm interested in. I think the reason for that is my functions are much faster than the sampling rate.

Finding hotspot tutorial related issue

 

As per the Tutorial: Finding Hotspot, I could Build application and create new project, Run Basic Hotspots Analysis, Interpret Result Data. But while trying to Analyze Code and edit the most hotspot region of the code, I was unable to open the editor from Open Source File Editor icon. It was showing "Cannot Open the external text file editor for this file."

I had also given $ "export EDITOR=gedit"  command in the terminal before running amplexe-gui. Kindly help me with the issue and suggest me how to get access to the editor.

Thank You.

 

 

Call-stack data collection stalls when KVM based VM is running on the Host

Hi there,

I am facing a problem while doing a system-wide callstack analysis using vtune_2015 Update 2 on an ubuntu 14.04 server.

If I start a VM(KVM based) and then do "/opt/intel/vtune_amplifier_xe/bin64/amplxe-cl -collect advanced-hotspots -knob collection-detail=stack-sampling --duration 20 -result-dir ~/intel/amplxe/projects/a/b", on the HOST, the profiling starts. Once the profiling is done amplxe always gets stuck displaying the below message

"amplxe: Executing actions  8 % Loading 'system-wide.perf' file"

License File related issue

Sir,

Thank you so much for, I have received the licence file you sent me to my mail as per my request. As I am new to this field I don't know how to open the .lic package you sent me. I dint find much details regarding this in the release notes. Moreover I would like to know where I should copy the the .lic file in order to set the path in the terminal while trying to do activation of the software.

Regards,
Athira

Intel® Parallel Studio XE 2016 Beta webinar this Wednesday!

On Wednesday, April 15 at 9AM Pacific we present: What’s New in the Intel® Parallel Studio XE 2016 Beta.

Join the technical experts at Intel as they provide you with details on the new features in the Intel® Parallel Studio XE 2016 Beta releases that access the newest Intel multicore and manycore coprocessors.

Assine o Intel® Parallel Amplifier