Otimização

Missing Interactive Debugging "Debug This" Context Menu Item

Hello,

I'm trying to attach my debugger to see a data race in the act, but I can't find the context menu item "Debug This Problem" explained in the documentation "About Investigating Problems Using Interactive Debugging" ( https://software.intel.com/en-us/node/528095 ):

Error unsupported while session init with 4 monitors.

Hi,

I've problem with MFXVideoSession initialization. Currently I have 4 monitors connected to external GPU and Intel display connected as "Try to connect anyway on: VGA" (when there are 3 monitors, quick sync HW works).

Example code looks like this:

 mfxVersion version = { 1, 0 }; // doesn't matter which version

 MFXVideoSession session;

 mfxStatus sts = session.Init( MFX_IMPL_AUTO_ANY, &version );
 session.Close();

sts is MFX_ERR_UNSUPPORTED.

My HW spec is HD4600 and Media SDK 2013 R2. 

pin-2.14-71313 and WinSock library

Hi,
I have a problem trying to start my pintool built with WinSock library (ws2_32.lib) - it immediately exits with message "Failure to open DLL file WS2_32.dll".
I've prepared a simple pintool to illistrate the problem:

//----------------------------------------------------------
#include "pin.H"

namespace WINDOWS
{
#include <Ws2tcpip.h>
void *p = WSAStartup;
};

int main(int argc, char *argv[])
{
if (PIN_Init(argc, argv)) return 1;
PIN_StartProgram();
return 0;
}

Package update on the target is required

Hi,
I am trying to remotely collect data on my target machine using the VTune Amplifier. The passwordless connection is already set up. When I try to connect to the remote machine, this is the message I get:

Detected VTune Amplifier build #367959 on the target system at ..path/to/vtune/installation... with the build #393444 on the host. Package update on the target is required. Amplifier cannot detect remote machine configuration.

MFX_ERR_INCOMPATIBLE_VIDEO_PARAM with MPEG2 Encoding and low Bitrate

I experience an error:

  MFX_ERR_INCOMPATIBLE_VIDEO_PARAM

while calling <MFXVideoENCODE_Init> if mfx.TargetKbps is below a certain value. Settings are appropriate for regular DVD Video PAL, MPEG2.

Values for TargetKbps above 0x0120 (means ca. 4500 MBit/sec Video) give MFX_ERROR_NONE, values below result in the error code above.

Is this a bug or do I have change other settings as well?

Ivy Bridge, counting cycles stalled due to LLC cache load misses?

Hi,

On Ivy Bridge there are the following counters:

  • CYCLE_ACTIVITY.CYCLES_L1D_PENDING
  • CYCLE_ACTIVITY.CYCLES_L2_PENDING
  • CYCLE_ACTIVITY.CYCLES_LDM_PENDING

but no CYCLE_ACTIVITY.CYCLES_LLC_PENDING. I have performed some profiling and my results suggest you cannot just subtract the first two counters from the third counter, to get the LLC value. There are three counters for the number of times there is a cache miss, but I want to know the effect of stalling.

Assine o Otimização