Havok

Character bouncing over slight bumps and down slopes

Hello, I've been trying to get rid of my character bouncing over slight bumps and not coming to rest - it comes to rest like a heavy bouncing ball. It also happens down slopes - instead of just sliding down a slope, it bounces down it. I've tried setting the restitution, angular and linear damping, friction, and gravity values and it helped but the problem is still there. I also thought setting the rigidBody's restitution would have stopped the bouncing, but it didn't disappear completely.

We need licenses for Havok Vision SDK for RealSense App Challenge 2014

I, Iaroslav Burlii, a lead programmer of the Spiribit.com Company. I am a member of the Intel RealSense App Challenge 2014, tracks "Ambassador". I prepare the Mechanics project where there is a necessity in the Havok Physics and the Havok Vision SDK.

Havok Physics was downloaded from http://www.havok.com/havok-sales (Free PC Download of Havok Physics & Animation). The bridge Havok Physics + Ogre3D has been already implemented, but I plan to replace Ogre3D to Havok Vision SDK concerning the Mechanics project.

We need licenses for Havok Vision SDK for RealSense App Challenge 2014

I, Iaroslav Burlii, a lead programmer of the Spiribit.com Company. I am a member of the Intel RealSense App Challenge 2014, tracks "Ambassador". I prepare the Mechanics project where there is a necessity in the Havok Physics and the Havok Vision SDK.

Havok Physics was downloaded from http://www.havok.com/havok-sales (Free PC Download of Havok Physics & Animation). The bridge Havok Physics + Ogre3D has been already implemented, but I plan to replace Ogre3D to Havok Vision SDK concerning the Mechanics project.

Raycasting not always works with shifted world

I have an endless world, so i shift rigidbodies silently as in your SlidingWorldDemo, call shiftAllObjects() before that too. I have a huge heightmap for the terrain, and i use generated terrain data (a simple 2d float array) for the hkpSampledHeightFieldShape. The broadphase size is +-2000.f, the heightmap size is +-8192.f. Everything works fine inside the +-2000.f area, around the origo. But if i try to castRay() outside of 2000.f area, the ray misses the heightmap, but works for everything else.

Missing headers for version 2013

Hi guys, I'm getting missing header errors for hkPhysicsClasses.h saying these files can't be found in hkPhysicsClasses.h-

#include <Physics/Internal/Classes/hknpInternalClasses.h>

#include <Physics/Physics/Classes/hknpPhysicsClasses.h>

 

I didn't find these in my havok folder so are these in fact missing from the Havok downloads?

Welding causes Visual debugger to not respond?

Hellio. I've tried to send my mopp code through the welding utility which seems to work, but when I try to visualize it in the debugger, the debugger freezes for a really long time and is basically unusable. If I turn off the welding in my code, the debugger works as normal. What could be wrong? Thank you for any help with this, I'm trying to get rid of the character "bouncing" over edges. I can also see that my program is basically stalling at the time stepping for havok -

small clarification on source code comments regarding shape keys

Hi Havok Team,

Right now I have a custom hkpBvTreeShape returning shape keys that point to triangles. I would ideally like to generate and discard these tris on the fly. However, I was reading the comments below for hkpShapeContainer and am now unsure whether Havok will react well to that (the highlighted sections seem somewhat contradictory?).

I can't load my custom shaderlib for a custom postprocess

I creat a shaderlib called dis.shaderlib in Shader Editor Layout.

It's located in my project folder. I add a pixel shader on it . also it has been compiled.

in my program :  BOOL bResult = Vision::Shaders.LoadShaderLibrary("C:\\svn\\Assets\\distortion.ShaderLib", SHADERLIBFLAG_NONE) != NULL;

Assine o Havok