Installing Intel Cluster Studio

Installing Intel Cluster Studio

Аватар пользователя Szymon Murawski

Hi.
I try to install Intel Cluster Studio For Linux and I'm stuck with installing license server. I downloaded 64bit version of Intel LIcense Server, but when i try to ./Instal_INTEL an error is produced:
./Install_INTEL: 43: Syntax error: "(" unexpected
I'm using ubuntu 10.10

Thanks for all help

6 сообщений / 0 новое
Последнее сообщение
Пожалуйста, обратитесь к странице Уведомление об оптимизации для более подробной информации относительно производительности и оптимизации в программных продуктах компании Intel.
Аватар пользователя Annalee (Intel)

Hello Szymon,

I am looking into this issue and will get back to you shortly with more information.

Regards,
Annalee
Intel Developer Support

Аватар пользователя andres-more (Intel)

If I recall correctly, Ubuntu uses the dash shell by default. Dash is not fully compatible with bash or sh, as those scripts are assuming. https://wiki.ubuntu.com/DashAsBinSh

Аватар пользователя Annalee (Intel)

As Andres noted, the issue is that Ubuntu uses dash, and dash does not support some bash extensions which are used in the install script.

The KB article FLEXlm license manager 2.0 installer may fail using dashexplains how to work around this issue.

Аватар пользователя Szymon Murawski

That did the trick, thank you very much:)

Although i came across some more problems i succesfully installed whole FLEXlm license manager (and Intel Cluster Studio). Here is what problems i've encountered and how to solve them step by step:

1. In case of an error ./Install_INTEL: 43: Syntax error: "(" unexpected simply change dash to bash by commands:
# rm /bin/sh
# ln -s /bin/bash /bin/sh

2. Later, if your getting an error *** Error: installed software will not run; package might be for the wrong platform, or corrupted do the following:
Check if you have LSB up and running:
$ lsb_release
If not, then execute:
# ln -s /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

3. When you run lmgrd you can encounter the following error Can't make directory /usr/tmp/.flexlm, errno: 2(No such file or directory). Just create a symlink there:
#ln -s /tmp /usr/tmp

That is all, hope someone will find it helpful.

Аватар пользователя Janusz Wollerstrand

Excellent, I needed help with all the 3 steps above. Now it works. In step 1. I simple replaced #!/bin/sh by #!/bin/bash, it worked as well. Many thanks/dziekuje

Зарегистрируйтесь, чтобы оставить комментарий.