Floating point exception(core dumped), fortran 9.1.047

Floating point exception(core dumped), fortran 9.1.047

Аватар пользователя blecha

I would like to install Intel C++ Compiler Professional Edition for Linux andIntel Fortran Compiler Professional Edition for Linux on my Ubutu 7.10, x84_64 system. I need to install version 9.1 as it is the required version by Abaqus 6.7. However, just after entering the serial number, I get the following error:

./install.sh: line 306: 8674 Floating point exception(core dumped) $install_prog

I also tried to install using the license file recieved by mail, but I got an error:

Invalid license file

After reading the various post on this forum, I understood that similar problems were uncountered with fortran compiler version 10.1 and was fixed by release 10.1.011. What about version 9.1.047? Is a new release foreseen? Or is there another way to fix the problem.

Thanks for your help.

Luc




5 сообщений / 0 новое
Последнее сообщение
Пожалуйста, обратитесь к странице Уведомление об оптимизации для более подробной информации относительно производительности и оптимизации в программных продуктах компании Intel.
Аватар пользователя Ronald W Green (Intel)

Luc,

Unfortunately, no, the supported distros for 9.1 are pretty much set in stone at this point. There will not be Ubuntu 7.10 support for compilers 9.1 at anytime in the future.

Intel moves our current version (10.1 in this case) forward with new distro support. Our previous supported version, 9.1, will get bug fixes but we will not expand the supported OSes for it.

9.1 is currently up to version 9.1.052 and should work fine with Abaqus BUT, again, this version is unsupported on Ubuntu 7.10.

So if you need to develop for Abaqus, your best bet is to find a workstation with a supported OS for your compiler. You should check with Simula, but my guess is that they also do not support Ubuntu 7.10.


ron

Аватар пользователя flyyks@gmail.com

hi

i think i have met the same problem.

i want to know if the last version could support some programs which need version 8 or 9.

thanks

Аватар пользователя Steve Lionel (Intel)

Yes - any correct program that works with ifort 8 or 9 should work with 10.1.

Steve
Аватар пользователя Tim Prince

In the case of Abaqus, the software vendor provides object files for most of the application, which are compiled with a specified compiler version. They specify that a similar compiler version should be used when re-linking. In most cases, ifort 10.1 will link successfully with objects built by 9.1. I encountered trouble once when I tried to use ifort 10.1 to link ifort 8.1 objects.
If you are rebuilding entirely from source code, ifort 10.1 should work well with source which has been tested with 8.1 or 9.1.

Зарегистрируйтесь, чтобы оставить комментарий.