AVX code can be run on early Windows OS of Win7+SP1 or Win Server 2008R2 ?

AVX code can be run on early Windows OS of Win7+SP1 or Win Server 2008R2 ?

Аватар пользователя denbianh

Hello experts,

Per AVX official specification, for Windows seems AVX only support Win7+SP1 or Win Server 2008R2. Whetheris it exactly true? DoesAVXsupport on Win XPif running machine is Sandy Bridge architecture built-in?

I am falling in love with AVX. :-) It is much appreciate you can answer this.

Thanks in advance.
Denbianh

4 posts / 0 новое
Последнее сообщение
Пожалуйста, обратитесь к странице Уведомление об оптимизации для более подробной информации относительно производительности и оптимизации в программных продуктах компании Intel.
Аватар пользователя Brijender Bharti (Intel)

As you mentioned, AVX is supported only after Win7 SP1. WinXP does not have AVX support. It may be a question/request to Microsoft to add the support.

Аватар пользователя denbianh

Brijender, thanks for your clarification.

Аватар пользователя alizay

Yes i am agree with you Microsoft should add AVX support.

thanks

Зарегистрируйтесь, чтобы оставить комментарий.