VTUNE build error on SLES11

VTUNE build error on SLES11

Аватар пользователя thayalan

Hi guys,

I am currently using the SGI Altix 4700 system running on Itanium 2 and the OS is SLES11. The proble m is that vtune does not support the SLES11 kernel hence I need to build the driver for this platform. I followed the HO WTO-BUILD-VTUNE-DRIVER manual and executed the following:

./build-driver

and the following is the error message:

checking for template makefile ... Makefile.in
checking for kernel h eaders ... /lib/modules/2.6.27.19-5-default/source/include
checking if C compiler is working ... yes
checking if C compiler supports anonymous structs and unions ... yes
checking architecture ... ia64
checking kernel ver sion ... 2.6.27.19-5-default
checking whether kernel modules can be built ... yes
checking if UP or SMP ... SM P
checking whether to use PERFMON ... no
**
** ERROR: Unable to detect legacy Perfmon2 kernel interface**
** The kernel headers in /lib/modules/2.6.27.19-5-default/source
** do not contain required configura tion to support sampling.
**
** Please see VDK doc/HOWTO-BUILD-VTUNE-DRIVER for help in
** preparing a k ernel environment suitable for building the
** sampling driver.
**
** For details on the specific failur e, please see configure log file,
** /opt/intel/vtune/vdk/src/build_driver_log.txt .
**

I found that perfmon2 is installed in the system, so could someone hint me what could be the culprit here.

Thanks.

4 posts / 0 новое
Последнее сообщение
Пожалуйста, обратитесь к странице Уведомление об оптимизации для более подробной информации относительно производительности и оптимизации в программных продуктах компании Intel.
Аватар пользователя Konstantin Lupach (Intel)

Hi thayalan, would you please point the name and version for product you are using?

In case you are using Vtune analyzer you should better write to the dedicated forum supported by engineers who know well VTune and its roadmap.

In case you got this error when using VDK from PTU 3.2U1 then this is expected. SLES11 is unsupported by this version of PTU.

Аватар пользователя thayalan

Hi,

First of all apologies for posting this question in the wrong forum, it is my first posting and I didnt realise about it. Anyways, I am using the Vtune Version: 9.1 Build: 9.1 Update7-401. Based on the Release Note it apparently support SLES11. Thanks for the reply, I will try to post it in the VTune forum.

Cheers.

Аватар пользователя Konstantin Lupach (Intel)

Hi, having this information even I can answer:)

I read release notes and can see that theymention

SuSE* Linux* Enterprise Server (SLES) 11.0kernel 2.6.27.19-5

However, this OS is supported only for IA32/Intel64 and not supported for IPF.

Engineers whowork onit told me there is a chance it will be supported in the future VTune releases.

Stay tuned for product updates.

K

P.S. SLES 11 contains perfmon3

Зарегистрируйтесь, чтобы оставить комментарий.