switching from IFORT_COMPILER12 to IFORT_COMPILER13

switching from IFORT_COMPILER12 to IFORT_COMPILER13

Аватар пользователя morgan.lecallet

Hello I have just installed the latest version of the Intel Fortran compiler for  windows (w_fcompxe_novsshell_2013.1.119).

I am using visual studio 2010.

I used to use the Intel compiler with imsl (xe composer 2012) and the projects were configured accordingly.

I encountered some errors when linking to mkl and  ifport.lib.

I had a look at my projects setting and they all seem to useto the following path: $(IFORT_COMPILER12).

Is there any way I can replace $(IFORT_COMPILER12) by $ (IFORT_COMPILER13) automatically or do I need to edit all my projects or this is not the right way ?

 

Note that that the 2013 version is the only version installed on the computer I use,  as you probably have guessed.

Thanks and best regards

12 сообщений / 0 новое
Последнее сообщение
Пожалуйста, обратитесь к странице Уведомление об оптимизации для более подробной информации относительно производительности и оптимизации в программных продуктах компании Intel.
Аватар пользователя mecej4

An easy way that does not require a knowledge of the inner working of Visual Studio is the following. Set the environment variable IFORT_COMPILER12 equal to the value of IFORT_COMPILER13.

Presumably, the former is now empty or points to a non-existent directory, and the latter is correctly pointing to the directory containing the new installation. Use the System->Advanced->Environment control panel, and locate (if present) or add IFORT_COMPILER12. Set its value to %IFORT_COMPILER13%.

Аватар пользователя morgan.lecallet

mecej4 thank you it seems to have worked.
Is there another solution to involving editing the environment variables?
Particularly when it will come to upgrade to IFORT_COMPILER14 or a more up to date version.
.

Аватар пользователя Steve Lionel (Intel)

You could use a text editor to edit the .vfproj files, replacing the occurrences.

I am curious as to where you are using these variables. Typically you would not use them in a Fortran project. Do you have C++ projects where they are used?

Steve
Аватар пользователя morgan.lecallet

Steve,
The Fortran projects i am working with are some legacy project that have been through at least 3 upgrades: digital compag fortran(VC6) ->intel fortran(vs2005)-> intel fortran(vs2008)-> intel fortran xe with imsl 2012(vs2010)->intel xe 2013(vs2010)
I have attached some extract of the c++ and fortran project files.
I wonder if it is not related to the fact that in vs2008 we had to specify the complier path inside visual studio and it is now done at project level
The work around worked but I wanted to know if I had to set up my projects differently to not repeat this process for the next update or on the other team’s member’ computer.
For example to I need to specify the additional include libraries ?
Thanks and kind regards

Вложения: 

ВложениеРазмер
Скачать fortran-complier12.zip1.08 КБ
Аватар пользователя Steve Lionel (Intel)

You shouldn't need those additional include or library directories in the Fortran projects, as they're defined by default. For a C++ project that links with Fortran code you will need to add the Fortran library location as an additional library directory, though not includes.

What I recommend instead is to add the Fortran library folder to the C++ defaults, rather than on a per-project basis. See Configuring Visual Studio for Mixed-Language Applications.

Steve
Аватар пользователя morgan.lecallet

Thank you.
I am looking into cleaning my fortran project file.
I always seem to need to add the path to mkl in the additional include directory.
I have attached a sample project which does not compile on my machine unless I add $(IFORT_COMPILER13)mkl\include\ia32 or $(IFORT_COMPILER12)mkl\include\ia32 after the variable tweak aforementioned.
Do I need to check my installation ?
I will update you about the c++ project.

Вложения: 

ВложениеРазмер
Скачать dll1.zip757.24 КБ
Аватар пользователя Steve Lionel (Intel)

Ah, I see the problem. Not your fault... The installation adds the mkl\include folder to the list of default include directories but omits the \ia32 subfolder. You could fix this by going into Tools > Options > Intel Composer XE > Visual Fortran > Compilers, clicking on the ... button next to Include FIles and adding \ia32 to the mkl\include line. Click on the x64 tab and put in \intel64 there as well.

If you do this you won't have to make changes to individual projects.

I thought this had been resolved a long time ago, but apparently not. I'll raise this with the development team.

Steve
Аватар пользователя morgan.lecallet

Thank you very much indeed I have learnt a lot.
It now seems to work with your recommendation.For the fortran project for the 64 bit tab I had to add \intel64\lp64

Аватар пользователя Steve Lionel (Intel)

As the article indicates, you have to replace "vv" with 11, 12 or 13 as appropriate.

Steve
Аватар пользователя morgan.lecallet

Thank you, I edited the post to prevent confusion.

Аватар пользователя Steve Lionel (Intel)

The appropriate MKL folder for the.mod files is supposed to get added automatically - but it isn't. I'm discussing this with the developers.

Steve

Зарегистрируйтесь, чтобы оставить комментарий.