Vast unwanted output from mpirun task

Vast unwanted output from mpirun task

Аватар пользователя L. D. Marks

I am getting way too many lines of what seems to be debug output from relatively simple mpirun with default options which I cannot seem to get rid of. This is not a problem with the code, it still runs fine. I assume that there is some environmental variable or similar variable which for some reason is turned on -- any suggestions?

Parts of the output which appear to be relevant are:

mpiexec options:
----------------
Base path: /opt/intel/impi/4.1.0.024/intel64/bin/
Launcher: ssh
Debug level: 1
Enable X: -1

...

_=/opt/intel/impi/4.1.0.024/intel64/bin/mpiexec.hydra

Hydra internal environment:
---------------------------
MPICH_ENABLE_CKPOINT=1
GFORTRAN_UNBUFFERED_PRECONNECTED=y

Proxy information:
*********************
[1] proxy: node01 (8 cores)
Exec list: /opt/Wien2k_12n/lapw0_mpi (8 processes);

==================================================================================================

[mpiexec@head.cluster] Timeout set to -1 (-1 means infinite)
[mpiexec@head.cluster] Got a control port string of head.cluster:54798

Proxy launch args: /opt/intel/impi/4.1.0.024/intel64/bin/pmi_proxy --control-port head.cluster:54798 --debug --pmi-connect lazy-cache
--pmi-aggregate -s 0 --rmk slurm --launcher ssh --demux poll --pgid 0 --enable-stdin 1 --retries 10 --proxy-id

......

Launch arguments: /usr/bin/ssh -x -q node01 /opt/intel/impi/4.1.0.024/intel64/bin/pmi_proxy --control-port
head.cluster:54798 --debug --pmi-connect lazy-cache --pmi-aggregate -s 0 --rmk slurm --launcher ssh --demux poll --pgid 0 --enable-stdin 1
--retries 10 --proxy-id 0
[mpiexec@head.cluster] STDIN will be redirected to 1 fd(s): 7
[proxy:0:0@node01.cluster] Start PMI_proxy 0
[proxy:0:0@node01.cluster] STDIN will be redirected to 1 fd(s): 9
[proxy:0:0@node01.cluster] got pmi command (from 7): init
pmi_version=1 pmi_subversion=1

.....and many more pmi_version lines that I do not want.

3 posts / 0 новое
Последнее сообщение
Пожалуйста, обратитесь к странице Уведомление об оптимизации для более подробной информации относительно производительности и оптимизации в программных продуктах компании Intel.
Аватар пользователя James Tullos (Intel)

Hi,

There are two ways to get that output.  Either use the -verbose argument to mpirun or set I_MPI_HYDRA_DEBUG=1 (or enable, yes, or on).  Check for and remove whichever of these is giving that output.  If I_MPI_HYDRA_DEBUG is being set and you cannot unset it, set it to 0 to disable this output.

Sincerely,
James Tullos
Technical Consulting Engineer
Intel® Cluster Tools

Аватар пользователя L. D. Marks

Oops, I had an incorrect PATH set, so -v was being set by mistake. Sorry about that.

Зарегистрируйтесь, чтобы оставить комментарий.