Intel® Parallel Amplifier

VTune 2015 for Xeon Phi

Hi all,

I met a problem when try to proflie our xeon phi code with VTune 2015 (shown in the Figure below) :

 

 

Following the instruction, I find that all values of "Card number" in project properties dialog have been pre-initailized and that's a parameter we can't change manually. 

Then I followed the steps as shown in the discussion below:

System wide Hardware Event-based Sampling (EBS) analysis is not available on the system

Hi,

I am trying to install Intel ParallelStudio 2015 on Ubuntu 14.04 without root (only installed for a single user). I get the following error message during installation:

Missing optional prerequisites
-- System wide Hardware Event-based Sampling (EBS) analysis is not available on
the system.

Here's the output from cat /proc/cpuinfo for the first processor

Free license issue with XE Vtune Amplifier XE 2015 demo

Hello,

I am trying to test out Vtune to see if its capable of extracting the information I need, in the way I need so I downlaoded the demo. I have some C code that I created an .EXE to test. When I start the analysis it runs but gets to a point and says I do not have a valid license. The data collection process is completed and when finalizing results I get an error saying cannot find a valid license. 0x4000001f. If I look in the folder:

C:\Program Files (x86)\Common Files\Intel\Licenses

amplxe:Error :System error 0x5

When I run VTune hotspots Collect, Igot the following error:

amplxe-cl -collect hotspots -no-auto-finalize -r F:\def C:\TGPtest\setup\tgp_daemon.exe 

amplxe:Error :System error 0x5: CreateProcess:Access denied 

amplex:Using result path 'F:\def' 

amplxe:Executing action 0% done

OS:WIN7 x64 Pro

Compiler: VTune Amplifier XE 2013

Licensing issue with amplxe-cl

I am able to use the VTune GUI without issue, and am also able to collect using amplxe-cl from the command line.  What I cannot do is generate a report from the command line.  amplxe-cl -report hotspots -r <results dir> produces:

amplxe: Error: 0x4000001f (No valid license) -- Cannot connect to the license server. Make sure your license daemon process is running, the used port@host or license file is correct, and the port or hostname in the license file has not been changed.

[vmlinux] [no call stack information]

Hi,

Currently, I'm using Advanced Hotspots to analyze the executable file resulting from compiling C source code.

However, from the analysis, it showed that most the time was spent in [vmlinux]. And, there is no call stack information displayed when I double click the function [vmlinux] in the Summary window. I'd made link named "vmlinux" to vmlinux-3.13.0-48-generic, which is the debug-info needed.

FYI, my OS is Ubuntu 14.04.2 LTS Trusty Tahr.

 

Apart from that, I encounter 2 warnings when I run the analysis:

VTune 2015 collection failed

Hi,

We are trying to optimize performance using  the VTune Amplifier 2015, it always returns collection failed.

The target machine is RHEL 6.3 with Linux kernel 2.6.32

We use in the trial mode

amplxe-cl -collect hotspots -duration 10 -target-pid 13649

The following is the error output:

amplxe: Collection detached.

amplxe: Fatal error: Unknown critical error

amplxe: Collection failed.

amplxe: Internal Error 

met some problem using advanced-hotspots

Hi all,

We met some problem using advanced-hotspots.

amplxe-cl -collect advanced-hotspots -r max_test_2_11 -duration 30 --target-pid 6859
 amplxe: Error: Cannot enable Hardware Event-based Sampling: problem with the driver (sep*/sepdrv*). Check that the driver is running and the driver group is in the current user group list. See "Building and Managing the Sampling Driver" help topic for further details.

Maybe some driver is missing. We are OK without Hardware Event-based Sampling.

Package update on the target is required

Hi,
I am trying to remotely collect data on my target machine using the VTune Amplifier. The passwordless connection is already set up. When I try to connect to the remote machine, this is the message I get:

Detected VTune Amplifier build #367959 on the target system at ..path/to/vtune/installation... with the build #393444 on the host. Package update on the target is required. Amplifier cannot detect remote machine configuration.

Ivy Bridge, counting cycles stalled due to LLC cache load misses?

Hi,

On Ivy Bridge there are the following counters:

  • CYCLE_ACTIVITY.CYCLES_L1D_PENDING
  • CYCLE_ACTIVITY.CYCLES_L2_PENDING
  • CYCLE_ACTIVITY.CYCLES_LDM_PENDING

but no CYCLE_ACTIVITY.CYCLES_LLC_PENDING. I have performed some profiling and my results suggest you cannot just subtract the first two counters from the third counter, to get the LLC value. There are three counters for the number of times there is a cache miss, but I want to know the effect of stalling.

Подписаться на Intel® Parallel Amplifier