Intel® Cluster Ready

Intel MPI Library Troubleshooting Guide

The latest versions of the Intel MPI Library User's Guides have added an expanded Troubleshooting section.  It provides the following information:

  • General Intel MPI Library troubleshooting practices
  • Typical MPI failures with corresponding output messages and behavior when a failure occurs
  • Recommendations on potential root causes and solutions

Here are direct links to these new sections:

Bug in mpi_f08-module with IMPI- on Linux-cluster

Dear developers of IMPI


I observed a bug when using the mpi_f08-module with IMPI- & intel-16.0.0

when running a Fortran program with 2 MPI-procs on a LINUX-cluster.

Data are not correctly transmitted by MPI_GATHER and by MPI_BCAST.



a) MPI_GATHER: The following bug occurred only with mpi_f08-module, whereas with mpi-module it worked


A simplified code snippet looks like that:


integer , parameter :: mxhostlen=128

character(len=mxhostlen) :: HOST_NAME

Code hangs when variables value increases


I have the latest intel mpi 5.1, together with the fortran compiler in my own ubuntu linux. I tried to run my code but it hangs. It was working fine in different clusters before.

I realised the problem lies with mpi_bcast. I wrote a very simple program:

program mpi_bcast_test

implicit none

include 'mpif.h'

integer :: no_vertices,no_surfaces,size,myid,ierr,status

integer, allocatable :: tmp_mpi_data1(:)

traceanalyzer summary sheet output

I believe this is the right forum to ask about traceanalyzer, please let me know otherwise.

According to itac_9.1/doc/ITA_User_and_Reference_Guide/index.htm => Command Line Interface:

# -------------------
"The application summary sheet consists of a three-line header:
<# processes>:<# processes per node>
: \

The header is followed by these sets of lines, for each of the top ten functions, sorted by descending total time:
# -------------------

Error while running mpitune utility

Hi, we have 8 nodes cluster with each node having xeon 8cores. all the clusters are connected using mellanox infiniband. I have installed intel cluster studio xe 2015. i have been using mpiicc and mpirun for a while. Now i wanted to use mpitune utility using hostfile hosts







i tried to call mpitune from my current directory by

mpitune -hf hosts -odr /home/srinivasan/

mpitune stops by giving this output

How to submit jobs in Microsoft HPC 2012 Pack?

Dear all,

I have a cluster contains 10 calculation nodes named N01~N10, in N01 the Windows server 2012 and Microsoft HPC 2012 Pack installed and in other nodes the Windows 7 64bit and Microsoft HPC 2012 Pack installed. I created a domain in N01 and added all other nodes to this domain. In HPC 2012, I also set N01 as the head node and added all other nodes to the head node. In 'node management' I can find that all N01~N10 are online.

Try to Install Intel Cluster Studio 2016 on Centos 7 Skript isnt working

Hi all,

I am trying to install an Intel-Cluster-Studio 2016 on my Centos7 installation. But the problem starts right on, when I am trying to execute the installation script. line 331: [: /tmp/intel.pset binary operator expected

Is there a solution for this?


Thanks in advance

most sincerely


Подписаться на Intel® Cluster Ready