OpenCL*

Critical Update to Intel(R) INDE OpenCL Code Builder

A new update of OpenCL Code Builder (ver. 5.2) was released in Intel INDE Update 2. You can download it directly from https://registrationcenter.intel.com/download.aspx?ProductID=2376.

The new update includes critical bug fixes for Windows 10 and Visual Studio 2015:

  • Build failures with Intel OpenCL Offline Compiler on Windows 10

  • Empty Code Builder project generation failure with Jump start kit on Visual studio 2015

OpenCL™ Code Analyzer in Intel® INDE Update 2

The new OpenCL™ Code Anlayzer, a feature of Intel® INDE OpenCL™ Code Builder, adds performance analysis capabilities integrated in your Microsoft Visual Studio* OpenCL development environment.

With this new feature, previously in preview, the OpenCL Code Builder now supports each state of the OpenCL code development, enables you to carry on performance optimizations in each step of the development from build, to debug, and to tuning and get the best out of Intel® Graphics Compute capabilities.

Intel provides new Integrated OpenCL development experience

OpenCL support at Intel is now going mainstream with full integration into Intel’s portfolio of software development suites. The Intel® SDK for OpenCL™ Applications features are now integrated into various development tools under a new name of OpenCL™ Code Builder.

The different solutions are tailored to the target development environments:

Unhandled exception IntelOpenCLProfiler.dll

Hi,

I have just installed OpenCL Code builder on top of Visual 2013 and followed the user manual steps to run the OCL Kernel development and Application analysis. However, I have trouble debugging with OpenCL API debugger : when debugging the template project in CPU-mode, it stops at this line in FindOpenCLPlatform function of OpenCLProjectCodeBuilder.cpp  :

    err = clGetPlatformIDs(0, NULL, &numPlatforms);

with the following message :

OpenCL driver / INDE issue on Win10

I have a HP Z230 PC with an integrated Intel HD 4600 GPU.

On this PC with Windows 7 64bit, my OpenCL program runs correctly. After upgrading to Windows 10 64bit, the call to clSetKernelArg fails and returns CL_INVALID_ARG_SIZE. No code changes on my side.

On windows 10, the driver version is 10.18.15.4256. I tried to upgrade to the newest driver version (15.40.4.64.4256). The installation seems to succeed, but installs version 10.18.15.4256 again.

Multiple Map/Unmap buffer

According to OpenCL 1.2 spec:

​clEnqueueMapBuffer and clEnqueueMapImage increment the mapped count of the memory object. The initial mapped count value of a memory object is zero. Multiple calls to clEnqueueMapBuffer or clEnqueueMapImage on the same memory object will increment this mapped count by appropriate number of calls. clEnqueueUnmapMemObject decrements the mapped count of the memory object.​

Подписаться на OpenCL*