Python Windows mkl_intel_thread.dll bug?

Python Windows mkl_intel_thread.dll bug?

Intel Python Distribution 2.7 v1.0.0tp1

import numpy as np
x = np.array([3, 5])
np.dot(x,x)

Gives the expected result, but

import numpy as np
x = np.array([3., 5.])
np.dot(x,x)

gives: Intel MKL FATAL ERROR: Cannot load mkl_intel_thread.dll

 

5 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hello Anthony,

thank you for your report. We are looking into it and I will get back at as soon as possible.

Ricardo

 

 

Yes, seems to be path issue. I did not instruct the installer to edit my path. Thanks.

 

 

Hi,

I'm having the same issue.
Is there any update?

Thanks.

Hello Min-Jung,

What OS and Python version are you using?
We tried to reproduced your error for 2.7 on both Linux and Windows and everything worked fine.
Could you verify if mkl_intel_thread.dll in your <python_home>/DLLs directory?
If it exists, please try adding that directory to your PATH and repeat your test.

Please let me know if this solves your problem.

Thank you.

I have the same problem with the latest conda 5.0.1-4.1 (I've tried them all) and python 3.6-3.4, and the path is set correctly, and the file exists.  Seems like this isn't a path issue anyway if sample code works with integers right? 

 

发表评论

登录添加评论。还不是成员?立即加入