Conda Installation raises AssertionErrors (MatchSpec)

Conda Installation raises AssertionErrors (MatchSpec)

Hi,

I have tried following instructions provided in the documentation (https://software.intel.com/sites/default/files/managed/9d/09/Conda-Guide...(R)-Distribution-for-Python-2017.pdf), however, after creating a new conda environment and activating it

conda config --add channels intel
conda create -n intelpython python=3
activate intelpython

trying to install intelpython3_core raises assertion errors (it does not seem to be package-related, since the packages mentioned change from run to run):

conda install intelpython3_core
AssertionError: pytz-2015.4-intel_py2.7_1.tar.bz2 MatchSpec('nose 1.3.7 intel_py
2.7_1')

Some infos on the conda-installation:

platform : win-64
conda version : 3.7.0
conda-build version : 1.8.2
python version : 3.4.1.final.0
requests version : 2.4.1

Is there a way to fix/work around this problem? Thanks!

4 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项
Best Reply

I tried python2 & 3 and it is working for me. Can you try updating your conda? This is what I have.

 

             platform : win-64
        conda version : 4.0.6
  conda-build version : 1.11.0
       python version : 2.7.11.final.0
     requests version : 2.9.1

 

Hi Robert,

Thanks, updating conda seems to have solved the issue, with 4.0.6 it also worked for me. Could you tell me whether it is at all possible to profile python code without elevated user rights on windows?

Thanks,

Paul

Quote:

Paul M. wrote:

Could you tell me whether it is at all possible to profile python code without elevated user rights on windows?

Hi Paul,

We've recently released Python profiling support in Intel® VTune™ Amplifier 2017 Beta, see https://software.intel.com/en-us/python-profiling

It would obviously require elevated rights to install the software, but afterwards you will be able to profile your Python code without administrative rights using Basic Hotspots analysis. Please check documentation available after installation for more (unfortunately online documentation is available for 2016 release only, 2017 is in Beta status now).

 

Thanks,

Vasilij

发表评论

登录添加评论。还不是成员?立即加入