Error for Intel media AVC encoder

Error for Intel media AVC encoder

Hi, Experts.

 I had use the Intel media encoder on Windows. It works well. Recently, I want to improve the encode quality, so I modified the min QP from 26 to 12 by setting m_extCO2.MinQPP. But if I wrong the encoder for a long time, the encoded bit stream decoded by decoder (including intel decoder or other decoder)may have some while line or pot as the attach image. At the same time, the syntax of bit steam is right. It seems some data process accumulated error in Intel encoder. 

Follow is the system and sdk info:
 

he following versions of Media SDK API are supported by platform/driver
[opportunistic detection of MSDK API > 1.19]:
        Version Target  Supported       Dec     Enc
        1.0     HW      Yes             X       X
        1.0     SW      Yes             X       X
        1.1     HW      Yes             X       X
        1.1     SW      Yes             X       X
        1.2     HW      Yes             X       X
        1.2     SW      Yes             X       X
        1.3     HW      Yes             X       X
        1.3     SW      Yes             X       X
        1.4     HW      Yes             X       X
        1.4     SW      Yes             X       X
        1.5     HW      Yes             X       X
        1.5     SW      Yes             X       X
        1.6     HW      Yes             X       X
        1.6     SW      Yes             X       X
        1.7     HW      Yes             X       X
        1.7     SW      Yes             X       X
        1.8     HW      Yes             X       X
        1.8     SW      Yes             X       X
        1.9     HW      Yes             X       X
        1.9     SW      Yes             X       X
        1.10    HW      Yes             X       X
        1.10    SW      Yes             X       X
        1.11    HW      Yes             X       X
        1.11    SW      Yes             X       X
        1.12    HW      Yes             X       X
        1.12    SW      Yes             X       X
        1.13    HW      Yes             X       X
        1.13    SW      Yes             X       X
        1.14    HW      Yes             X       X
        1.14    SW      Yes             X       X
        1.15    HW      Yes             X       X
        1.15    SW      Yes             X       X
        1.16    HW      Yes             X       X
        1.16    SW      Yes             X       X
        1.17    HW      Yes             X       X
        1.17    SW      Yes             X       X
        1.18    HW      Yes             X       X
        1.18    SW      Yes             X       X
        1.19    HW      Yes             X       X
        1.19    SW      Yes             X       X
        1.20    HW      Yes             X       X
        1.20    SW      Yes             X       X
        1.21    SW      Yes             X       X
        1.22    SW      Yes             X       X
        1.23    SW      Yes             X       X
Graphics Devices:
        Name                                         Version             State
        Intel(R) HD Graphics 6000                    20.19.15.4835       Active
System info:
        CPU:    Intel(R) Core(TM) i5-5250U CPU @ 1.60GHz
        OS:     Microsoft Windows 10 ???
        Arch:   64 ?
Installed Media SDK packages (be patient...processing takes some time):
        Intel(R) Media SDK 2017 R1
        Intel(R) Media Server Studio 2016 R2 - Video Quality Caliper
        Intel(R) Media Samples 6.0.0.49
        Intel(R) Media SDK 2016
        Intel(R) Media SDK 2016 R2
        Intel(R) Media SDK Samples 2016
        Intel(R) Media Server Studio 2017 R2 – Software Development Kit
Installed Media SDK DirectShow filters:
  Intel(R) Media SDK H.264 Encoder {71183C45-F4FA-4B10-9E04-F9040CB19139}
  Intel(R) Media SDK H.264 Encoder :
    F:\MSDK_Samples_Deprecated_Windows\samples\_build\Win32\Release\h264_enc_filter.dll
  Intel(R) Media SDK H.264 Decoder {CCCE52FD-02CB-482C-AC81-1E55EF1D61EE}
  Intel(R) Media SDK H.264 Decoder :
    F:\MSDK_Samples_Deprecated_Windows\samples\_build\Win32\Release\h264_dec_filter.dll
Installed Intel Media Foundation Transforms:
        Intel(R) Hardware M-JPEG Decoder MFT : {00C69F81-0524-48C0-A353-4DD9D54F9A6E}
        Intel(R) Hardware VP8 Sync Decoder MFT : {451E3CB7-2622-4BA5-8E1D-44B3C41D0924}
        Intel(R) Hardware VP8 Decoder MFT : {6D856398-834E-4A89-8EE5-071BB3F58BE4}

 

 

 

附件大小
下载image/jpeg white line.jpg148.94 KB
6 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Thanks Gang,

Could you provide some information on how to reproduce it? When you say "a long time", how long was that?

The other thing you might try is to change the input video to see if this is content related.

From your information, you seems installed a lot of version, which version of MSDK are you finally using?

Mark Liu

It's more than 30 minutes to reproduce it and it is not always reproduced. All the decoder did not report any error when received the bitstream. And if there is one I frame, the white line will be disappear.
I think it's content related, it is more easy to reproduce when the content contains keyboard or holder with black, white or grey colors.
I used Intel(R)_Media_SDK_2016.0.2.  

Hi Gang,

It is very hard for us to find the solution if you can't reproduce it, let me know if you have progress on this or if you have any clue so we can do it.

Mark

It's always to reproduce, if change the QP to a small value during encoding and no IDR except the first one during test.  But reproducing it will cost about 30 or more minutes. I guess it caused by change QP during encoding, or the QP is too small. 

 

引文:

Liu, Mark (Intel) 写道:

Hi Gang,

It is very hard for us to find the solution if you can't reproduce it, let me know if you have progress on this or if you have any clue so we can do it.

Mark

Hi Gang,

Could you try this with our latest release, I doubt this might be fixed in our latest release.

Mark

发表评论

登录添加评论。还不是成员?立即加入