Create Package always failed

Create Package always failed

 

Dear,

whenever i try to create the package i got this message:

"warnings and error messages included in the config.xml file ( inside the exported cordova build package) "

Building app in the previous version of intel XDK was successful, but when the building option retired i tried to create the package with no success.

Please advise if i am doing something wrong.


<?xml version='1.0' encoding='UTF-8'?>
<widget xmlns="http://www.w3.org/ns/widgets" xmlns:intelxdk="http://xdk.intel.com/ns/v1" id="com.tatco.esp8266" version="2.0" ios-CFBundleVersion="2.0">
<!--This file is generated by the Intel XDK. Do not edit this file as your edits will be lost.           -->
<!--To change the contents of this file, see the documentation on the intelxdk.config.additions.xml file.-->
<intelxdk:version value="1.1"/>
<intelxdk:cordova-cli version="6.2.0"/>
<name>ESP8266 Kit</name>
<description>ESP8266 Kit</description>
<author>TATCO</author>
<content src="index.html"/>
<access origin="*"/>
<allow-intent href="*"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-29x29@1x.png" width="29" height="29"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-29x29@2x.png" width="58" height="58"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-29x29@3x.png" width="87" height="87"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-60x60@1x.png" width="60" height="60"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-60x60@2x.png" width="120" height="120"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-60x60@3x.png" width="180" height="180"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-76x76@1x.png" width="76" height="76"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-76x76@2x.png" width="152" height="152"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-40x40@1x.png" width="40" height="40"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-40x40@2x.png" width="80" height="80"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-57x57@1x.png" width="57" height="57"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-57x57@2x.png" width="114" height="114"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-72x72@1x.png" width="72" height="72"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-72x72@2x.png" width="144" height="144"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-Small-50x50@1x.png" width="50" height="50"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-Small-50x50@2x.png" width="100" height="100"/>
<icon platform="ios" src="package-assets/icon/ios/AppIcon.appiconset/Icon-App-83.5x83.5@2x.png" width="167" height="167"/>
<splash platform="ios" src="package-assets/splash/iphone/Default@1x.png" width="320" height="480" orientation="portrait"/>
<splash platform="ios" src="package-assets/splash/iphone/Default@2x.png" width="640" height="960" orientation="portrait"/>
<splash platform="ios" src="package-assets/splash/iphone/Default-568h@2x.png" width="640" height="1136" orientation="portrait"/>
<splash platform="ios" src="package-assets/splash/iphone/Default-667h@2x.png" width="750" height="1334" orientation="portrait"/>
<splash platform="ios" src="package-assets/splash/iphone/Default-Portrait.png" width="768" height="1024" orientation="portrait"/>
<splash platform="ios" src="package-assets/splash/iphone/Default-Portrait-736h@3x.png" width="1242" height="2208" orientation="portrait"/>
<splash platform="ios" src="package-assets/splash/iphone/Default-Portrait@2x.png" width="1536" height="2048" orientation="portrait"/>
<intelxdk:plugin intelxdk:name="StatusBar" intelxdk:value="cordova-plugin-statusbar" intelxdk:version="2.1.3" intelxdk:checksum="c0146fbc" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="Device" intelxdk:value="cordova-plugin-device" intelxdk:version="1.1.2" intelxdk:checksum="2373ccea" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="Splashscreen" intelxdk:value="cordova-plugin-splashscreen" intelxdk:version="3.2.2" intelxdk:checksum="47137083" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="Notification" intelxdk:value="cordova-plugin-dialogs" intelxdk:version="1.2.1" intelxdk:checksum="2948bc11" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="OneSignal Push Notifications PGB Compat" intelxdk:value="onesignal-cordova-plugin-pgb-compat" intelxdk:version="2.0.10" intelxdk:checksum="b0b029a" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="Google Play Services for Android" intelxdk:value="com.google.playservices" intelxdk:version="26.0.0" intelxdk:checksum="60a0ab2a" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="Android Support v4" intelxdk:value="cordova-android-support-v4" intelxdk:version="4.0.0" intelxdk:checksum="fc2e2350" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="AppRate" intelxdk:value="cordova-plugin-apprate" intelxdk:version="1.3.0" intelxdk:checksum="255d1efa" intelxdk:type="file"/>
<intelxdk:plugin intelxdk:name="Globalization" intelxdk:value="cordova-plugin-globalization" intelxdk:version="1.0.3" intelxdk:checksum="8290055f" intelxdk:type="file"/>
<preference name="ios-configuration" value="adhoc"/>
<preference name="deployment-target" value="8.0"/>
<intelxdk:provisioning intelxdk:src="package-assets/cer/ESP8266_Kit.mobileprovision" intelxdk:type="adhoc"/>
<!--creationInfo:{"src":"jsapp/template-blank-cordova-project-lite/sample.zip","projectTypeName":"com.intel.xdk.projecttype.jsapp"}-->
<preference name="debuggable" value="false"/>
<preference name="DisallowOverscroll" value="true"/>
<platform name="ios">
    <!-- below requires the splash screen plugin -->
    <!-- docs: https://github.com/apache/cordova-plugin-splashscreen -->
    <preference name="AutoHideSplashScreen" value="true"/>
    <preference name="FadeSplashScreen" value="false"/>
    <preference name="FadeSplashScreenDuration" value="2"/>
    <preference name="ShowSplashScreenSpinner" value="false"/>
    <preference name="SplashScreenDelay" value="0"/>

    <!-- below requires the status bar plugin -->
    <!-- docs: https://github.com/apache/cordova-plugin-statusbar -->
    <!-- see http://devgirl.org/2014/07/31/phonegap-developers-guid -->
    <preference name="StatusBarOverlaysWebView" value="false"/>
    <preference name="StatusBarBackgroundColor" value="#000000"/>
    <preference name="StatusBarStyle" value="lightcontent"/>
</platform>
<platform name="android">
    <!-- below requires the splash screen plugin -->
    <!-- docs: https://github.com/apache/cordova-plugin-splashscreen -->
    <preference name="SplashMaintainAspectRatio" value="false"/>
    <preference name="SplashScreenDelay" value="0"/>
</platform>
<intelxdk:crosswalk xmlns:intelxdk="http://xdk.intel.com/ns/v1" xwalk-command-line="--disable-pull-to-refresh-effect"/>
<intelxdk:crosswalk xmlns:intelxdk="http://xdk.intel.com/ns/v1" xwalk-command-line="--ignore-gpu-blacklist"/></widget>

 

 

15 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

This looks like an intelxdk.config.*.xml file, not the config.xml file that is included in the ZIP file you export. Are you getting a ZIP file? Does that ZIP file contain a config.xml file? Did you check the error/warning messages that were added to that config.xml file (the one inside the ZIP file is the one that contains any warning and error messages). Just because you get that message does not mean you have an unusable project, please check the contents of the config.xml file that is generated for any error/warning comments for details.

Hi Paul,

I couldn't get or export the zip file, it always failed and give me this message.

Please advise

Hi, i have the same problem,

i'm trying to create Cordova Build package.
but i have the same warning message:
"warnings and error messages included in the config.xml file ( inside the exported cordova build package) "
and if i try to upload in Phonegap Build  their system reply with "Malformed Config.xml"

I read that this last version 3987 (mine is an OS X version) fix the bug of config.xml about whitelist 

is there other problem to fix it?
could you please help me to fix my config.xml for build a valid zip file to upload in phone gap account

this is my config.xml file inside xdk Zip package:
 

<?xml version="1.0" encoding="UTF-8" ?>
<widget xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0" xmlns:cdv="http://cordova.apache.org/ns/1.0" xmlns:android="http://schemas.android.com/apk/res/android" ios-CFBundleVersion="0.0.1" version="1.1.4" id="it.appleandberry.app"  >
<!-- This file was generated by the Intel XDK Cordova Package Build tool. -->
<name>AppleAndBerry</name>
<description>Apple&Berry is an App for Productivity and Research Variety of Apple Fruits.</description>
<author>P&P Techonology</author>
<content src="index.html"/>
<preference name="android-build-tool" value="gradle" />
<platform name="ios" >
    <access origin="http://appleandberry.it/"/>
</platform>
<preference name="phonegap-version" value="cli-6.2.0" />
<preference name="xwalkMultipleApk" value="false" />
<plugin name="cordova-plugin-camera" spec="2.2.0"/>
<plugin name="cordova-plugin-file" spec="4.2.0"/>
<plugin name="cordova-plugin-media" spec="2.3.0"/>
<plugin name="phonegap-plugin-barcodescanner" spec="4.1.0"/>
<plugin name="cordova-plugin-compat" spec="1.0.0"/>
<plugin name="cordova-plugin-device-orientation" spec="1.0.3"/>
<plugin name="cordova-plugin-whitelist" spec="1.2.2"/>
<platform name="ios" >
    <preference name="deployment-target" value="9.0"/>
    <preference name="ios-configuration" value="production"/>
    <preference name="Orientation" value="portrait"/>
</platform>
<icon platform="ios" src="package-assets/A&B-29.png" width="29" height="29"/>
<icon platform="ios" src="package-assets/A&B-58.png" width="58" height="58"/>
<icon platform="ios" src="package-assets/A&B-87.png" width="87" height="87"/>
<icon platform="ios" src="package-assets/A&B-60.png" width="60" height="60"/>
<icon platform="ios" src="package-assets/A&B-120.png" width="120" height="120"/>
<icon platform="ios" src="package-assets/A&B-180.png" width="180" height="180"/>
<icon platform="ios" src="package-assets/A&B-76.png" width="76" height="76"/>
<icon platform="ios" src="package-assets/A&B-152.png" width="152" height="152"/>
<icon platform="ios" src="package-assets/A&B-40.png" width="40" height="40"/>
<icon platform="ios" src="package-assets/A&B-80.png" width="80" height="80"/>
<icon platform="ios" src="package-assets/A&B-57.png" width="57" height="57"/>
<icon platform="ios" src="package-assets/A&B-114.png" width="114" height="114"/>
<icon platform="ios" src="package-assets/A&B-72.png" width="72" height="72"/>
<icon platform="ios" src="package-assets/A&B-144.png" width="144" height="144"/>
<icon platform="ios" src="package-assets/A&B-50.png" width="50" height="50"/>
<icon platform="ios" src="package-assets/A&B-100.png" width="100" height="100"/>
<icon platform="ios" src="package-assets/A&B-187.png" width="187" height="187"/>
<config-file platform="android" parent="/manifest/application" mode="merge"> 
    <activity android:launchMode="singleTop" />
</config-file>
</widget> 

thx

 

Cita:

rabee a. escribió:

Hi Paul,

I couldn't get or export the zip file, it always failed and give me this message.

Please advise

Could you provide more details regarding the message? There is nothing in your post regarding the message. Provide some screenshots or a ZIP of a sample project that causes this problem.

Cita:

mauro m. escribió:

Hi, i have the same problem,

i'm trying to create Cordova Build package.
but i have the same warning message:
"warnings and error messages included in the config.xml file ( inside the exported cordova build package) "
and if i try to upload in Phonegap Build  their system reply with "Malformed Config.xml"

I read that this last version 3987 (mine is an OS X version) fix the bug of config.xml about whitelist 

is there other problem to fix it?
could you please help me to fix my config.xml for build a valid zip file to upload in phone gap account

My guess is the '&' characters in your description, author field or the folder names for your icons might be causing trouble -- probably the icon folder names. I don't see anything in particular is that is "wrong" with your config.xml, but I'm guessing PGB might be having trouble with that character.

Cita:

Paul F. (Intel) escribió:

Quote:

My guess is the '&' characters in your description, author field or the folder names for your icons might be causing trouble -- probably the icon folder names. I don't see anything in particular is that is "wrong" with your config.xml, but I'm guessing PGB might be having trouble with that character.

Thx Paul i try immediately

 

Ok Paul Works ;-)

thx!!!

just two notes:

LAUNCH ICONS iOS 187x187
i create package after that i change alla "&" symbol in description and file names.

but new version of intel XDK ask me a icon for android 167x167 px that i create BUT in Zip package there is also a 187x187 that you can't upload in because as you can see (screenshot1.png)  there isn't in the last XDK framework

i made a screenshot also of preview version of XDK icons setting (screenshot2.png)   

This is the part of config.xml generated

</platform>
<icon platform="ios" src="package-assets/AB-187.png" width="187" height="187"/>
<icon platform="ios" src="package-assets/AB-29.png" width="29" height="29"/>
<icon platform="ios" src="package-assets/AB-58.png" width="58" height="58"/>
<icon platform="ios" src="package-assets/AB-87.png" width="87" height="87"/>
<icon platform="ios" src="package-assets/AB-60.png" width="60" height="60"/>
<icon platform="ios" src="package-assets/AB-120.png" width="120" height="120"/>
<icon platform="ios" src="package-assets/AB-180.png" width="180" height="180"/>
<icon platform="ios" src="package-assets/AB-76.png" width="76" height="76"/>
<icon platform="ios" src="package-assets/AB-152.png" width="152" height="152"/>
<icon platform="ios" src="package-assets/AB-40.png" width="40" height="40"/>
<icon platform="ios" src="package-assets/AB-80.png" width="80" height="80"/>
<icon platform="ios" src="package-assets/AB-57.png" width="57" height="57"/>
<icon platform="ios" src="package-assets/AB-114.png" width="114" height="114"/>
<icon platform="ios" src="package-assets/AB-72.png" width="72" height="72"/>
<icon platform="ios" src="package-assets/AB-144.png" width="144" height="144"/>
<icon platform="ios" src="package-assets/AB-50.png" width="50" height="50"/>
<icon platform="ios" src="package-assets/AB-100.png" width="100" height="100"/>
<icon platform="ios" src="package-assets/AB-167.png" width="167" height="167"/>
<config-file platform="android" parent="/manifest/application" mode="merge"> 

i don't know if is important or there is something to fix it in framework.

second notes:

VERSION ON PHONEGAP

When i upload  zip file in phone gap build site their diagnostic upload system suggest that my app have a old reference number of PhoneGap version.

they suggest to update to last one (you can see screenshot3.png)

in config.xml i had this version
<preference name="phonegap-version" value="cli-6.2.0" />

i just modify as
<preference name="phonegap-version" value="cli-6.5.0" />

Thx again paul

mauro

 

附件: 

附件大小
下载image/png screenshot1.png117.02 KB
下载image/png screenshot2.png128.81 KB
下载image/png screenshot3.png122.85 KB

引文:

mauro m. 写道:

LAUNCH ICONS iOS 187x187

i create package after that i change alla "&" symbol in description and file names.

but new version of intel XDK ask me a icon for android 167x167 px that i create BUT in Zip package there is also a 187x187 that you can't upload in because as you can see (screenshot1.png)  there isn't in the last XDK framework

i made a screenshot also of preview version of XDK icons setting (screenshot2.png)   

This is the part of config.xml generated

</platform>
<icon platform="ios" src="package-assets/AB-187.png" width="187" height="187"/>
...stuff deleted...
<icon platform="ios" src="package-assets/AB-167.png" width="167" height="167"/>

i don't know if is important or there is something to fix it in framework.

The 187x187 pixel icon was a mistake; the 167x167 pixel icon is the correct one. The fact that it shows up in your config.xml file and is still part of the project is a bug in the XDK. That information is stored inside the <project-name>.xdk file in the root folder of your project. If you want to get rid of it you'd have to edit that file (when the XDK is closed) to remove that reference from the <project-name>.xdk file.

I do not believe it harms anything to have that extra icon in the project, it should just be ignored by the build system or, if it does get added to your built app, will likely just be ignored by the iPhone/iPad devices when the app is installed and runs.

引文:

mauro m. 写道:

second notes:

VERSION ON PHONEGAP

When i upload  zip file in phone gap build site their diagnostic upload system suggest that my app have a old reference number of PhoneGap version.

they suggest to update to last one (you can see screenshot3.png)

in config.xml i had this version
<preference name="phonegap-version" value="cli-6.2.0" />

i just modify as
<preference name="phonegap-version" value="cli-6.5.0" />

Regarding the PhoneGap Build version notice, please follow the "more info" link and read the FAQ provided by Adobe > http://docs.phonegap.com/phonegap-build/faq/#app-upgrade < for full details. You do not need to upgrade to the latest, it's just an informational message. The latest version of the XDK does allow you to select CLI 6.5.0 so it will export that version to the config.xml in your ZIP file. You should be aware that they will be retiring all versions of CLI older than 6.0, for security reasons > https://blog.phonegap.com/old-phonegap-versions-being-retired-from-phone... <

If you use the XDK to upgrade your CLI version it will also attempt to update any core Cordova plugins that you are currently using in your project.

Thx Paul!

I update and upload in Apple Store ;-)

about icons 187 x 187 bug I confirm that also if is list in config.xml there are no problem in uploading process for Apple.

i wrote this note so you can fix it the bug

Thx also about Phonegap Build version next upgrade of one of my app i'll check and upgrade it

Best Regards ant Thx

That message does not mean that the export was unsuccessful, it just means there are comments inside the exported config.xml file, which is inside the ZIP file that was exported.

"That message does not mean that the export was unsuccessful", thank Paul it is working now.

 

Hi Paul,

i'm trying to create an upgrade version of same APP in Android.

but when I charge it on Phonegap give me this Error

* What went wrong:
Execution failed for task ':compileReleaseJavaWithJavac'.
> Compilation failed; see the compiler error output for details.

Can you help me please to fix this error?
this is the entire log from phonegap and you can find config.xml file if need it

Build Date: 2017-09-23 19:47:50 +0000

Subproject Path: CordovaLib
Configuration on demand is an incubating feature.
null
org.xwalk:xwalk_core_library:19+
Incremental java compilation is an incubating feature.
:preBuild UP-TO-DATE
:preReleaseBuild UP-TO-DATE
:checkReleaseManifest
:preDebugBuild UP-TO-DATE
:CordovaLib:preBuild UP-TO-DATE
:CordovaLib:preDebugBuild UP-TO-DATE
:CordovaLib:checkDebugManifest
:CordovaLib:prepareDebugDependencies
:CordovaLib:compileDebugAidl
:CordovaLib:compileDebugNdk UP-TO-DATE
:CordovaLib:compileLint
:CordovaLib:copyDebugLint UP-TO-DATE
:CordovaLib:mergeDebugShaders
:CordovaLib:compileDebugShaders
:CordovaLib:generateDebugAssets
:CordovaLib:mergeDebugAssets
:CordovaLib:mergeDebugProguardFiles
:CordovaLib:packageDebugRenderscript UP-TO-DATE
:CordovaLib:compileDebugRenderscript
:CordovaLib:generateDebugResValues
:CordovaLib:generateDebugResources
:CordovaLib:packageDebugResources
:CordovaLib:processDebugManifest
:CordovaLib:generateDebugBuildConfig
:CordovaLib:processDebugResources
:CordovaLib:generateDebugSources
:CordovaLib:incrementalDebugJavaCompilationSafeguard
:CordovaLib:compileDebugJavaWithJavac
:CordovaLib:compileDebugJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
:CordovaLib:processDebugJavaRes UP-TO-DATE
:CordovaLib:transformResourcesWithMergeJavaResForDebug
:CordovaLib:transformClassesAndResourcesWithSyncLibJarsForDebug
:CordovaLib:mergeDebugJniLibFolders
:CordovaLib:transformNative_libsWithMergeJniLibsForDebug
:CordovaLib:transformNative_libsWithSyncJniLibsForDebug
:CordovaLib:bundleDebug
:CordovaLib:preReleaseBuild UP-TO-DATE
:CordovaLib:checkReleaseManifest
:CordovaLib:prepareReleaseDependencies
:CordovaLib:compileReleaseAidl
:CordovaLib:compileReleaseNdk UP-TO-DATE
:CordovaLib:copyReleaseLint UP-TO-DATE
:CordovaLib:mergeReleaseShaders
:CordovaLib:compileReleaseShaders
:CordovaLib:generateReleaseAssets
:CordovaLib:mergeReleaseAssets
:CordovaLib:mergeReleaseProguardFiles
:CordovaLib:packageReleaseRenderscript UP-TO-DATE
:CordovaLib:compileReleaseRenderscript
:CordovaLib:generateReleaseResValues
:CordovaLib:generateReleaseResources
:CordovaLib:packageReleaseResources
:CordovaLib:processReleaseManifest
:CordovaLib:generateReleaseBuildConfig
:CordovaLib:processReleaseResources
:CordovaLib:generateReleaseSources
:CordovaLib:incrementalReleaseJavaCompilationSafeguard
:CordovaLib:compileReleaseJavaWithJavac
:CordovaLib:compileReleaseJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
:CordovaLib:processReleaseJavaRes UP-TO-DATE
:CordovaLib:transformResourcesWithMergeJavaResForRelease
:CordovaLib:transformClassesAndResourcesWithSyncLibJarsForRelease
:CordovaLib:mergeReleaseJniLibFolders
:CordovaLib:transformNative_libsWithMergeJniLibsForRelease
:CordovaLib:transformNative_libsWithSyncJniLibsForRelease
:CordovaLib:bundleRelease
:prepareBarcodescannerLibrary
:prepareComAndroidSupportSupportCompat2600Alpha1Library
:prepareComAndroidSupportSupportCoreUi2600Alpha1Library
:prepareComAndroidSupportSupportCoreUtils2600Alpha1Library
:prepareComAndroidSupportSupportFragment2600Alpha1Library
:prepareComAndroidSupportSupportMediaCompat2600Alpha1Library
:prepareComAndroidSupportSupportV42600Alpha1Library
:prepareOrgXwalkXwalk_core_library19495145Library
:prepareProjectCordovaLibUnspecifiedReleaseLibrary
:prepareReleaseDependencies
:compileReleaseAidl
:compileReleaseRenderscript
:generateReleaseBuildConfig
:mergeReleaseShaders
:compileReleaseShaders
:generateReleaseAssets
:mergeReleaseAssets
:createXwalkCommandLineFileRelease
:generateReleaseResValues
:generateReleaseResources
:mergeReleaseResources
:processReleaseManifest
:processReleaseResources
:generateReleaseSources
:incrementalReleaseJavaCompilationSafeguard
:compileReleaseJavaWithJavac
:compileReleaseJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).
/project/src/org/crosswalk/engine/XWalkWebViewEngine.java:55: error: XWalkWebViewEngine is not abstract and does not override abstract method evaluateJavascript(String,ValueCallback<String>) in CordovaWebViewEngine
public class XWalkWebViewEngine implements CordovaWebViewEngine {
       ^
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /project/src/org/apache/cordova/file/AssetFilesystem.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
1 error
:compileReleaseJavaWithJavac FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileReleaseJavaWithJavac'.
> Compilation failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 6.188 secs
Error: /project/gradlew: Command failed with exit code 1 Error output:
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
/project/src/org/crosswalk/engine/XWalkWebViewEngine.java:55: error: XWalkWebViewEngine is not abstract and does not override abstract method evaluateJavascript(String,ValueCallback<String>) in CordovaWebViewEngine
public class XWalkWebViewEngine implements CordovaWebViewEngine {
       ^
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /project/src/org/apache/cordova/file/AssetFilesystem.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
1 error

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileReleaseJavaWithJavac'.
> Compilation failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    at ChildProcess.whenDone (/project/cordova/node_modules/cordova-common/src/superspawn.js:169:23)
    at emitTwo (events.js:106:13)
    at ChildProcess.emit (events.js:191:7)
    at maybeClose (internal/child_process.js:877:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)



*******************************************************

CONFIG.XML FILE 


<?xml version="1.0" encoding="UTF-8" ?>
<widget xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0" xmlns:cdv="http://cordova.apache.org/ns/1.0" xmlns:android="http://schemas.android.com/apk/res/android" android-versionCode="7" version="1.1.3" id="it.appleandberrydemo.app"  >
<!-- This file was generated by the Intel XDK Cordova Package Build tool. -->
<name>AppleAndBerry</name>
<description></description>
<author></author>
<content src="index.html"/>
<preference name="android-build-tool" value="gradle" />
<platform name="android" >
    <access origin="*"/>
    <access origin="http://95.11.183.193/"/>
</platform>
<preference name="phonegap-version" value="cli-6.5.0" />
<preference name="xwalkMultipleApk" value="false" />
<plugin name="cordova-plugin-crosswalk-webview" spec="1.8.0"/>
<plugin name="cordova-plugin-camera" spec="2.4.1">
<variable name="CAMERA_USAGE_DESCRIPTION" value=" "/>
<variable name="PHOTOLIBRARY_USAGE_DESCRIPTION" value=" "/>
</plugin>
<plugin name="cordova-plugin-file" spec="4.2.0"/>
<plugin name="cordova-plugin-media" spec="3.0.0">
<variable name="MICROPHONE_USAGE_DESCRIPTION" value=" "/>
</plugin>
<plugin name="phonegap-plugin-barcodescanner" spec="6.0.7">
<variable name="CAMERA_USAGE_DESCRIPTION" value=" "/>
</plugin>
<plugin name="cordova-plugin-compat" spec="1.0.0"/>
<plugin name="cordova-plugin-device-orientation" spec="1.0.6"/>
<plugin name="cordova-plugin-whitelist" spec="1.2.2"/>
<platform name="android" >
    <preference name="android-minSdkVersion" value="16"/>
    <preference name="android-targetSdkVersion" value="22"/>
    <preference name="android-installLocation" value="auto"/>
    <preference name="android-signed" value="true"/>
    <preference name="Orientation" value="portrait"/>
    <preference name="AndroidLaunchMode" value="singleTop"/>
</platform>
        <icon src="package-assets/AB-36_2.png" density="ldpi" width="36" height="36" />
        <icon src="package-assets/AB-48_2.png" density="mdpi" width="48" height="48" />
        <icon src="package-assets/AB-72_2.png" density="hdpi" width="72" height="72" />
        <icon src="package-assets/AB-96_2.png" density="xhdpi" width="96" height="96" />
        <icon src="package-assets/AB-144.png" density="xxhdpi" width="144" height="144" />
<config-file platform="android" parent="/manifest/application" mode="merge"> 
    <activity android:launchMode="singleTop" />
</config-file>
</widget>







 

Hi Paul,

solved!!!

sorry i find another old post about it and you suggest to uncheck "optimize crosswalk" option and now works!!!

thx

 

hi Paul,
me again sorry...
how i can build a Crosswalk for Android?

i mean the problem  is this :

<plugin name="cordova-plugin-crosswalk-webview" spec="1.8.0"/>

But i need to use my apps in different android version

so what is the solution... i didn't find yet a solution in old post about this theme

thx

I suspect the problem is the specific version of Crosswalk that you are using. At this point, the only "safe" version to use is Crosswalk 23, which is the latest (and last) version of Crosswalk (see XDK release notes for details > https://software.intel.com/en-us/xdk/docs/release-notes-information-inte... <).

In your config.xml file it is specifying CLI 6.5.0, which means you are all set to specify the last version of Crosswalk (version 23). Just go to the bottom of the settings and change the Crosswalk version to 23:

Notice also that the minimum Android API level must be set to 16, which corresponds to Android 4.1. With that version of Crosswalk, you cannot support Android 4.0, so your app will only load onto Android 4.1 or later if it is built with CW 23. If you want to support Android 4.0 you will have to use an older version of CW, such as CW 19, which will also require that you use an older version of CLI, probably CLI 5.x, but I do not recall precisely where that cutoff is.

I recommend you give up supporting Android 4.0 and use CW 23. Also, I recommend that you consider retiring your support for Android 4.x in a future release of your app and consider supporting only Android 5.0 and later. When you start supporting Android 5.0 and later, you can remove Crosswalk entirely from your app and just use the more capable built-in webview that is part of Android 5.0 and later.

发表评论

登录添加评论。还不是成员?立即加入