Intel kernel builder problem

Intel kernel builder problem

hi All,

I am new to open cl and have installed intel open cl sdk . After the installation, I have tried writing some open cl code  in the intel kernel builder program after checking all the parameters and environment variables.  The program is throwing the same error again  and again that is

Setting target instruction set architecture to: Default (Advanced Vector Extension (AVX)) OpenCL

Intel CPU device was found!

Device name: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz

Device version: OpenCL 1.2 (Build 82248)

Device vendor: Intel(R) Corporation

Device profile: FULL_PROFILE

Compilation started

1:2:9: fatal

error: 'CL/cl.h' file not found Compilation failed




any help would be of great use




4 帖子 / 0 全新

Hi Piyush,

Could you please post the kernel you're trying to compile with the Kernel Builder?

For me it looks like your kernel contains '#include CL/cl.h' line which is wrong - you should include this file in the host part of the program, while Kernel Builder compiles only the kernel part. For example, try to compile a dummy kernel:

__kernel void foo () { return; }



@ yuri..

Yes, I am writing the whole line as you are saying... I did not  knew that the kernel builder executes the kernel program only

thanks for the help



@ yuri

Can u tell me how to link the library files in visual studio as I am getting the LNK error : unresolved externals _someFuncName;

I did try to link it as project property->configurations->linker->input additional library and typed the complete path of the OpenCL64.lib

But still it is gibing the same error.......