install issue using Ubuntu 10.04

install issue using Ubuntu 10.04

While trying to install l_ccompxe_ia32_2011.9.293.tgz I got the follwing error:

The following required for installation commands are missing: g++.

There is no other install of Cilk in any of its versions on my harddrive.

I am using Unbuntu 10.04 and I am not sure what it means or how to fix it.

Please help.

Thanks in advance.

Newport-j

11 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hello Newport-j,
From what it looks like, the compiler is not able to find the builtin G++ compiler. Are you able to compile a normal C++ program in your machine? If possible, can you please send me the output for the following command?

which g++

Thanks,

Balaji V. Iyer.

Iam not sure what you mean.I am using the scripted install process.I am using ubuntu 10.04 with a clean install - no ubuntu updates. The pc that i wish to instal on is isolated and not on a network and probably never will be. The sequence on the install scriptis as follows:

--missin system commands

selected 1 - show detailed info about isse [default]

the message:

The following required for installation commands are missing:
g++.

Then it gives a choice and one of them is quiting theinstall. I take that choice. If I were to add which g++ after the statement about the missing g++, the sotware install would simply reply :

Incorrect input, please try gain.

I either need to know where ot put this command (whichg++) orI need another command.

Thanks in advance.

Newport_j

Hi Newport_j,
I am sorry if I wasn't clear. I was asking you to type "which g++" in your command prompt. If you could, pleasesend methe output

Thanks,

Balaji V. Iyer.

Ithink I understand now. I tried typing which g++ and got nothing at all. It seems to agree with the initial thread that says that g++ is missing. I tried typing which gcc (I know that I have gcc on my computer) and it gave me the directory that gcc was in. I tried it with g++ and asI said above and I got nothing. So g++ is not present in my installl which g++ outputs nothing.

What doI do next?

Newport_j

I tried typing g++ -v and got :

the program "g++" cannot be found in the follwing packages;

g++

Pentium builder.

I hope this added info helps.

Newport_j

Hello Newport_j,
Without knowing how youradmin rightsare set up in your system, I am afraid Iam not able to tell you specific commands. The best thing to do at this point is to contact your system administrator and ask the person to install G++ for you.

Thanks,

Balaji V. Iyer.

This is an isolated pc.I installed Ubuntu 10.04 on it last week. It is asI said not hooked up to any network and probably never will be.

There are no updates on the Ubuntu 10.04. This is just the install disk of ubuntu and nothing more.

Clearly g++ is not there. What package canI install that will put g++ on?

There no network admin here; There is no network.

Please tell me what package to install on Ubuntu 10.04 to put g++ on. I cannot believe this problem has not happened before.

Any help appreciated.

Newport_j

Start up the Synaptic Package Manager. If you're running the X-windows display, that should be System menu, under the Administration submenu.

Type "g++" into the "Quick search" field of the package manager. One of the ones displayed in the "Package" list should be "g++". Check it, (When you click on it, you'll choose "Mark for Installation" from the popup menu)

Click the big "Apply" button at the top of the package manager window.

You should also review the compiler release notes to make sure you've satisfied any other installation requirements.

- Barry

Ibelieve the package thatI am interested in is buiild-essential. Where can I download a version of that for Ubuntu 10.04. Again, this building and compiling pc is not connected to the internet. I will need to download the build-essential package from another pc (that is connected to the internet) and then burn it on a cd andmove to the pc, and then copy build-essentail to the hard drive and install it.

Is there a specific build-essential packagefor Ubuntu 10.04? Is there a debian build-essential package?

Newport_j

Hi yunkerj,

Please refer to the detailed article we have on this topic - http://software.intel.com/en-us/articles/using-intel-compilers-for-linux-with-ubuntu/. Basically, you will be using apt-get to get that package. If you still have problems after following the article here, then please let us know.

Brandon Hewitt
Technical Consulting Engineer

For 1:1 technical support: http://premier.intel.com

Software Product Support info: http://www.intel.com/software/support

发表评论

登录添加评论。还不是成员?立即加入