Intel flexlm license server/client issue

Intel flexlm license server/client issue

aksharb的头像

Hi,
we have intel flexlm license server running on machine licsvr.cluster.acb.in. While tried to access it from one of the machines on the same network, it gives following error. Same command when run from different machine runs without any error.
***************************
mpiicpc --version

Error: A license for CCompL is not available (-13,128).

License file(s) used were (in this order):
1. Trusted Storage
2. 28518@licsvr.cluster.acb.in
3. /opt/intel/Compiler/11.0/069/licenses
4. /opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.lic
5. /root/intel/licenses
6. /Users/Shared/Library/Application Support/Intel/Licenses

Please visit http://support.intel.com/support/performancetools/support.htm if you require technical assistance.

icpc: error #10052: could not checkout FLEXlm license
****************************
Tried INTEL_LM_DEBUG=1, we get ,

mpiicpc --version
INTEL_LMD: flex_set_platform: called, plat_name=
INTEL_LMD: flex_set_license_path: called, path=
INTEL_LMD: checkout: entered at start_time: 1310607788 (UTC) Thu Jul 14 01:43:08 2011
INTEL_LMD: checkout: build options:
INTEL_LMD: checkout: build date: 2008.1002
INTEL_LMD: checkout: build platform: Intel 64 architecture; Linux*
INTEL_LMD: checkout: checkout platform: i86_r (IA-32 architecture; Linux*)
INTEL_LMD: checkout: *Other brands and names are the property of their respective owners.
INTEL_LMD: checkout: FLEXlm version: 11.5
INTEL_LMD: checkout: source version: 1.74 $Id: flexlm.c,v 1.40.2.2 2008/07/14 17:47:10 mtoguchi Exp $
INTEL_LMD: checkout: FLEX_MAX_LICENSE_TRIES: 0
INTEL_LMD: checkout: FLEX_USE_NOWAIT_AND_SPIN: enabled
INTEL_LMD: checkout: FLEX_SPIN_SLEEP_SECONDS: 30
INTEL_LMD: checkout: heartbeats: 60 seconds (automatic)
INTEL_LMD: checkout: server retry: 60 seconds
INTEL_LMD: checkout: FLEX_CHECKOUT_FILTER: enabled
INTEL_LMD: checkout: FLEX_CLEAN_PATHS: disabled
INTEL_LMD: checkout: FLEX_CLOCK_ROLLBACK_CHECK: disabled
INTEL_LMD: checkout: FLEX_APP_SPECIFIC: disabled
INTEL_LMD: checkout: user options:
INTEL_LMD: checkout: feature name: CCompL
INTEL_LMD: checkout: opts: { FLEX_OPT_QUIET FLEX_OPT_QUIET_EXPIRE_EVAL }
INTEL_LMD: checkout: try_count: 0
INTEL_LMD: checkout: retry_interval: 30
INTEL_LMD: checkout: linger_time: 0
INTEL_LMD: checkout: environment:
INTEL_LMD: checkout: INTEL_LICENSE_FILE <28518@licsvr.cluster.acb.in:/opt/intel/Compiler/11.0/069/licenses:/opt/intel/licenses:/Users/Shared/Library/Application Support/Intel/Licenses>
INTEL_LMD: checkout: LM_LICENSE_FILE
INTEL_LMD: checkout: INTEL_LMD_DEBUG <1>
INTEL_LMD: checkout: license file(s) used were (in this order):
INTEL_LMD: 1. Trusted Storage
INTEL_LMD: 2. 28518@licsvr.cluster.acb.in
INTEL_LMD: 3. /opt/intel/Compiler/11.0/069/licenses
INTEL_LMD: 4. /opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.lic
INTEL_LMD: 5. /Users/Shared/Library/Application Support/Intel/Licenses
INTEL_LMD: 6. /opt/intel/Compiler/11.0/069/bin/intel64/*.lic
INTEL_LMD: checkout: linger_time set to 0 by default
INTEL_LMD: checkout: begin attempt(s) to checkout
INTEL_LMD: checkout: about to do checkout call
INTEL_LMD: checkoutfilter: called for feature: CCompL
INTEL_LMD: checkoutfilter: VENDOR_STRING:
INTEL_LMD: checkoutfilter: next VENDOR_STRING keyword: SUPPORT=
INTEL_LMD: checkoutfilter: ignore: keyword SUPPORT is disabled for filtering
INTEL_LMD: checkoutfilter: next VENDOR_STRING keyword: https://registrationcenter.intel.com
INTEL_LMD: checkoutfilter: ignore: keyword https://registrationcenter.intel.com is disabled for filtering
INTEL_LMD: checkoutfilter: returns ACCEPT
INTEL_LMD: checkout: checkout call returns rc -13

Error: A license for CCompL is not available (-13,128).

CCompL: No SERVER lines in license file.
Feature: CCompL
License path: 28518@licsvr.cluster.acb.inile
/opt/intel/Compiler/11.0/069/licensesile
/opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.licile
/Users/Shared/Library/Application Support/Intel/Licensesile
/opt/intel/Compiler/11.0/069/bin/intel64/*.licile

FLEXnet Licensing error:-13,128
For further information, refer to the FLEXnet Licensing documentation,
available at "www.macrovision.com".

License file(s) used were (in this order):
1. Trusted Storage
2. 28518@licsvr.cluster.acb.in
3. /opt/intel/Compiler/11.0/069/licenses
4. /opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.lic
5. /Users/Shared/Library/Application Support/Intel/Licenses
6. /opt/intel/Compiler/11.0/069/bin/intel64/*.lic

Please visit http://support.intel.com/support/performancetools/support.htm if you require technical assistance.

INTEL_LMD: checkout: returns NOT GRANTED / ERROR
INTEL_LMD: checkout: entered at start_time: 1310607788 (UTC) Thu Jul 14 01:43:08 2011
INTEL_LMD: checkout: build options:
INTEL_LMD: checkout: build date: 2008.1002
INTEL_LMD: checkout: build platform: Intel 64 architecture; Linux*
INTEL_LMD: checkout: checkout platform: i86_r (IA-32 architecture; Linux*)
INTEL_LMD: checkout: *Other brands and names are the property of their respective owners.
INTEL_LMD: checkout: FLEXlm version: 11.5
INTEL_LMD: checkout: source version: 1.74 $Id: flexlm.c,v 1.40.2.2 2008/07/14 17:47:10 mtoguchi Exp $
INTEL_LMD: checkout: FLEX_MAX_LICENSE_TRIES: 0
INTEL_LMD: checkout: FLEX_USE_NOWAIT_AND_SPIN: enabled
INTEL_LMD: checkout: FLEX_SPIN_SLEEP_SECONDS: 30
INTEL_LMD: checkout: heartbeats: 60 seconds (automatic)
INTEL_LMD: checkout: server retry: 60 seconds
INTEL_LMD: checkout: FLEX_CHECKOUT_FILTER: enabled
INTEL_LMD: checkout: FLEX_CLEAN_PATHS: disabled
INTEL_LMD: checkout: FLEX_CLOCK_ROLLBACK_CHECK: disabled
INTEL_LMD: checkout: FLEX_APP_SPECIFIC: disabled
INTEL_LMD: checkout: user options:
INTEL_LMD: checkout: feature name: CComp
INTEL_LMD: checkout: opts: { FLEX_OPT_QUIET FLEX_OPT_QUIET_EXPIRE_EVAL }
INTEL_LMD: checkout: try_count: 0
INTEL_LMD: checkout: retry_interval: 30
INTEL_LMD: checkout: linger_time: 0
INTEL_LMD: checkout: environment:
INTEL_LMD: checkout: INTEL_LICENSE_FILE <28518@llicsvr.cluster.acb.in:/opt/intel/Compiler/11.0/069/licenses:/opt/intel/licenses:/Users/Shared/Library/Application Support/Intel/Licenses>
INTEL_LMD: checkout: LM_LICENSE_FILE
INTEL_LMD: checkout: INTEL_LMD_DEBUG <1>
INTEL_LMD: checkout: license file(s) used were (in this order):
INTEL_LMD: 1. Trusted Storage
INTEL_LMD: 2. 28518@llicsvr.cluster.acb.in
INTEL_LMD: 3. /opt/intel/Compiler/11.0/069/licenses
INTEL_LMD: 4. /opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.lic
INTEL_LMD: 5. /Users/Shared/Library/Application Support/Intel/Licenses
INTEL_LMD: checkout: linger_time set to 0 by default
INTEL_LMD: checkout: begin attempt(s) to checkout
INTEL_LMD: checkout: about to do checkout call
INTEL_LMD: checkout: checkout call returns rc -5

Error: A license for CComp is not available (-5,357).

CComp: No such feature exists.
Feature: CComp
License path: 28518@licsvr.cluster.acb.in
/opt/intel/Compiler/11.0/069/licensesile
/opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.licile
/Users/Shared/Library/Application Support/Intel/Licensesile

FLEXnet Licensing error:-5,357
For further information, refer to the FLEXnet Licensing documentation,
available at "www.macrovision.com".

Make sure that a license file is being used that contains a license
for the requested feature. If your license requires a license server,
make sure that the server is using the right license file (usually,
this would be the same license file that is being used by this
application), and make sure that you have not changed the license
file since starting the server.

License file(s) used were (in this order):
1. Trusted Storage
2. 28518@llicsvr.cluster.acb.in
3. /opt/intel/Compiler/11.0/069/licenses
4. /opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.lic
5. /Users/Shared/Library/Application Support/Intel/Licenses

Please visit http://support.intel.com/support/performancetools/support.htm if you require technical assistance.

INTEL_LMD: checkout: returns NOT GRANTED / ERROR
INTEL_LMD: checkout: entered at start_time: 1310607788 (UTC) Thu Jul 14 01:43:08 2011
INTEL_LMD: checkout: build options:
INTEL_LMD: checkout: build date: 2008.1002
INTEL_LMD: checkout: build platform: Intel 64 architecture; Linux*
INTEL_LMD: checkout: checkout platform: i86_r (IA-32 architecture; Linux*)
INTEL_LMD: checkout: *Other brands and names are the property of their respective owners.
INTEL_LMD: checkout: FLEXlm version: 11.5
INTEL_LMD: checkout: source version: 1.74 $Id: flexlm.c,v 1.40.2.2 2008/07/14 17:47:10 mtoguchi Exp $
INTEL_LMD: checkout: FLEX_MAX_LICENSE_TRIES: 0
INTEL_LMD: checkout: FLEX_USE_NOWAIT_AND_SPIN: enabled
INTEL_LMD: checkout: FLEX_SPIN_SLEEP_SECONDS: 30
INTEL_LMD: checkout: heartbeats: 60 seconds (automatic)
INTEL_LMD: checkout: server retry: 60 seconds
INTEL_LMD: checkout: FLEX_CHECKOUT_FILTER: enabled
INTEL_LMD: checkout: FLEX_CLEAN_PATHS: disabled
INTEL_LMD: checkout: FLEX_CLOCK_ROLLBACK_CHECK: disabled
INTEL_LMD: checkout: FLEX_APP_SPECIFIC: disabled
INTEL_LMD: checkout: user options:
INTEL_LMD: checkout: feature name: CCompL
INTEL_LMD: checkout: opts: { FLEX_OPT_QUIET_EXPIRE_EVAL }
INTEL_LMD: checkout: try_count: 0
INTEL_LMD: checkout: retry_interval: 30
INTEL_LMD: checkout: linger_time: 0
INTEL_LMD: checkout: environment:
INTEL_LMD: checkout: INTEL_LICENSE_FILE <28518@llicsvr.cluster.acb.in:/opt/intel/Compiler/11.0/069/licenses:/opt/intel/licenses:/Users/Shared/Library/Application Support/Intel/Licenses>
INTEL_LMD: checkout: LM_LICENSE_FILE
INTEL_LMD: checkout: INTEL_LMD_DEBUG <1>
INTEL_LMD: checkout: license file(s) used were (in this order):
INTEL_LMD: 1. Trusted Storage
INTEL_LMD: 2. 28518@llicsvr.cluster.acb.in
INTEL_LMD: 3. /opt/intel/Compiler/11.0/069/licenses
INTEL_LMD: 4. /opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.lic
INTEL_LMD: 5. /Users/Shared/Library/Application Support/Intel/Licenses
INTEL_LMD: checkout: linger_time set to 0 by default
INTEL_LMD: checkout: begin attempt(s) to checkout
INTEL_LMD: checkout: about to do checkout call
INTEL_LMD: checkoutfilter: called for feature: CCompL
INTEL_LMD: checkoutfilter: VENDOR_STRING:
INTEL_LMD: checkoutfilter: next VENDOR_STRING keyword: SUPPORT=
INTEL_LMD: checkoutfilter: ignore: keyword SUPPORT is disabled for filtering
INTEL_LMD: checkoutfilter: next VENDOR_STRING keyword: https://registrationcenter.intel.com
INTEL_LMD: checkoutfilter: ignore: keyword https://registrationcenter.intel.com is disabled for filtering
INTEL_LMD: checkoutfilter: returns ACCEPT
INTEL_LMD: checkout: checkout call returns rc -13

Error: A license for CCompL is not available (-13,128).

CCompL: No SERVER lines in license file.
Feature: CCompL
License path: 28518@llicsvr.cluster.acb.inile
/opt/intel/Compiler/11.0/069/licensesile
/opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.licile
/Users/Shared/Library/Application Support/Intel/Licensesile

FLEXnet Licensing error:-13,128
For further information, refer to the FLEXnet Licensing documentation,
available at "www.macrovision.com".

License file(s) used were (in this order):
1. Trusted Storage
2. 28518@llicsvr.cluster.acb.in
3. /opt/intel/Compiler/11.0/069/licenses
4. /opt/intel/licenses/COM_L_CMPCT__F95L-2KLTCGFC.lic
5. /Users/Shared/Library/Application Support/Intel/Licenses

Please visit http://support.intel.com/support/performancetools/support.htm if you require technical assistance.

INTEL_LMD: checkout: returns NOT GRANTED / ERROR
icpc: error #10052: could not checkout FLEXlm license
INTEL_LMD: flex_return_license: called
INTEL_LMD: flex_return_license: considering feature name: CCompL
INTEL_LMD: flex_return_license: considering feature name: CComp
INTEL_LMD: flex_return_license: considering feature name: CCompL
INTEL_LMD: flex_free_job: called
INTEL_LMD: flex_free_job: lc_new_job was called
INTEL_LMD: flex_return_license: done

Kindly sugest on the same.

2 帖子 / 0 new
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项
Dmitry Kuzmin (Intel)的头像

Hello,

First of all I should mention that the issue is not related to MPI. mpiicc (mpiicpc) is just a wrapper for Intel compilers. So, you can check 'icc --version' or 'icpc --version'.
But please check which icc you are using. Run 'which icpc' on a node where mpiicpc works and on the node where it doesn't. Compare pathes.
If you are using the same compiler on both nodes then check value of the INTEL_LICENSE_FILE.
Find out the license file and set INTEL_LICENSE_FILE to this file on bad node and give it a try.

There are a couple of utilities which can help you to resolve this issue - please read this article (there is pdf file also).

Regards!
Dmitry

登陆并发表评论。