Cannot use heap profiler

Cannot use heap profiler

Hello,

I am trying to use the heap profiler from the GUI.
But it comes back with these messages:

Command: /pavo/gabrielem/ptu40_005_lin_intel64/eclipse/plugins/../../bin/vthprun /pavo/sadly_root/ptu_projects/tachyon_analyze_locks/Basic-Heap-Profiler-2011-06-21-16-30-32 --exact=yes -- /pavo/sadly_root/ptu_projects/tachyon/tachyon_analyze_locks dat/balls.dat
A:Source/pin/injector_nonmac/auxvector.cpp:CopyAux:244: unexpected AUX VEC type 25

################################################################################
## STACK TRACE
################################################################################
addr2line -C -f -e /pavo/gabrielem/ptu40_005_lin_intel64/bin/pinbin 0x7f7a60bbea80 0x7f7a60bbf1e3 0x7f7a60df5f81 0x7f7a60df6eb0 0x7f7a60df9229 0x7f7a60dfa924 0x7f7a60df3d5c 0x7f7a60df40d8 0x7f7a60de77ce 0x7f7a60df07f3 0x7f7a5ff06c4d 0x7f7a60bafdaa
sh: /pavo/gabrielem/ptu40_005_lin_intel64/bin/../lib/pinlib/libc.so.6: version `GLIBC_2.4' not found (required by sh)
sh: /pavo/gabrielem/ptu40_005_lin_intel64/bin/../lib/pinlib/libc.so.6: version `GLIBC_2.11' not found (required by sh)
Detach Service Count: 0
@CHARM-VERSION: $Id: version.cpp 18313 2008-03-30 23:51:30Z hgpatil $
@CHARM-BUILDER: BUILDER
@CHARM-COMPILER: gcc 3.4.6
@CHARM-TARGET: ia32e
@CHARM-CFLAGS: __OPTIMIZE__=1 __NO_INLINE__=__NO_INLINE__
C:Injector exited with signal 6
E:Wait for injector failed: No child processes
Scene contains 7386 bounded objects.

I tried both exact and fast collection, but got the same result.

What should I do to solve this problem?

Thanks
Gabriele

4 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Do you use one of systems mentioned in release notes?

It seems that I do.

uname -a gives: Linux pavo 2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 x86_64 GNU/Linux

From dmesg:

Linux version 2.6.32-22-generic (buildd@yellow) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #36-Ubuntu SMP Thu Jun 3 19:31:57 UTC 2010 (Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2)

CPU0: Intel Core i7 CPU 860 @ 2.80GHz stepping 05
(same up to CPU7)

So I think I am using a x86_64 Ubuntu 10.04 on a Nehalem i7 CPU ("System / About Ubuntu" from my Gnome menu said I am using Ubuntu 10.04.)

Thanks
Gabriele

Unfortunately no. Sorry. There is a chance to make it working only onsome old (for now) Linux distro.
The feature is unsupported for a long time that is why it has no new OS support.

Heap Profiler, exact Call Graph, Call Count problems and limitations
...

  • No Red Hat Fedora 10, Ubuntu 8.10 (and newer Linux systems) and Microsoft Windows 7 support.

发表评论

登录添加评论。还不是成员?立即加入