Spawning with IntelMPI v4.0

Spawning with IntelMPI v4.0

Hi,

I've downloaded the evaluation copy for Intel Cluster Toolkit Compiler Edition for Linux*.
I've installad C++/Fortran compliers and MPI library with the default operations.

I've compiled my test program that does an MPI_Comm_spawn_multiple succesfully, but when I try to run it gives me this error:

[cli_0]: Spawn is not implemented
[cli_0]: aborting job:
Fatal error in MPI_Comm_spawn_multiple: Other MPI error, error stack:
MPI_Comm_spawn_multiple(141)..: MPI_Comm_spawn_multiple(count=2, cmds=0xbfeb7980, argvs=(nil), maxprocs=0xbfeb7970, infos=0xbfeb7960, root=0, MPI_COMM_WORLD, intercomm=0xbfeb7ab8, errors=0xbfeb7750) failed
MPID_Comm_spawn_multiple(56)..:
MPIDI_Comm_spawn_multiple(193): PMI_Spawn_multiple returned -1
rank 0 in job 2 wgm-linux01_56731 caused collective abort of all ranks
exit status of rank 0: killed by signal 9

how can I enable the spawning features ?

Thank you,
Federico

3 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项
Intel Software Network Support的头像

I have moved this from the General Contest forum. Thanks for your
question. We'll see if we can find someone who can provide an answer.

==
Aubrey
W.
Intel Software Network Support

Hi Federico,

I've just rechecked spawn_multiple and it works fine with Intel MPI Library 4.0.

Make sure that you are using everything from version 4.0 including mpds. Looks like your mpd ring was run from 3.2.
Could you kill mpd ring: "mpdcleanup -a"?
Be sure that you are using 4.0 environment: "which mpirun"
Start your application: mpirun -r ssh -n 2 ./my_app

Let me know if the issue still exists.

Regards!
Dmitry

登陆并发表评论。