debugger freezing Visual Studio

debugger freezing Visual Studio

Dear Fortran Friends!

For a couple of years I am experiencing the same problem with the debugger in Developer Studio (Digital/Compaq Visual Studio) and Visual Studio 2003 and 2005 (Intel Visual Fortran v8, v9):

When stepping through a Fortran app in the debugger, sometimes VS "hangs" and the task manager shows me that VSis consuming almost 100% of CPU time, but VS doesn't respond anymore to my actions. Sometimes VS reports an error that it cannot return from an "internal operation".
I had a customer who told me that he experienced the same and that he could step further in his app after waiting for more than 10 minutes. I never had that much patience. So I always killed VS and started anew.

However today,within the last hour I had to kill and re-start VS more than 10 times, and now I am fed up.

Does anyone has some help for me (I am still using VS2005 w/SP1 and IVF 9.1.3375.2005)?

Does the problem still exist with IVF v10.0 or IVF v10.1?

Does it help to change to VS2008?

By the way, a couple of customers are reportingthe same VS/debug behaviour, I wonder whether this has ever been discussed here.

Jrg Kuthe
www.qtsoftware.de

46 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

I've never encountered a problem like that myself and don't recall hearing before of a customer seeing it. I have seen issues caused by misbehaving virus or other program-monitoring software. Sometimes I suggest booting Wimdows into "Safe Mode" and seeing if you can reproduce the problem.

I doubt that this is a problem tied to the compiler version.

Steve - Intel Developer Support

What was the code doing when it hung up? I think I remember having a problem of this sort if I tried to single-step through code containing a large array operation. Something like:

A = 0.0

where A is a good sized 2-d array.

In my case, the cure was to avoid stepping through the code. Instead I'd use breakpoints, or "run to cursor".

I know that stepping over a statement with an array operation can keep the processor / debugger quite busy. But the bug I experience happens randomly.
Unfortunately, I have not theslightestidea what could be the reason for this debugger fault.

But again, it appears to me that I have to repeat what I have said:

I have been working with Digital, Compaq and Intel Visual Fortran for about a decade now.
And I have used a couple of various PCs running Win95, Win98, NT and XP.
I am working on customers' sites too. They have their own PCs, their own virus scanners etc. and their own CVF/IVF licences.
My companyhas been a Digital Fortran and a Compaq Fortran reseller andnow is an Intelsoftware reseller for quite a while. Because of this I hear from customers complaining about the debugger. They encounter the same problem: the Visual studio debuggertends to "hang up" and VS stops responding. The last error message we see is, that VSis busy and cannot return from an "internal operation".

Steve, if you have never encountered that problem you are lucky. I can reproduce this behaviour on any machine I am running VS2003/5 and IVF (or CVF) on by just starting a debugging session. Sometimes it takes a couple of minutes until the debugger "hangs up", but it happens. It might be that this isproblem occurs only on PCs equipped with the German Windows version, but I can hardly believe this.

So, I hope you believe me know that there is a problem with the debugger.

It alsomight help that other users that experience the same problem second me.

Iver never had debugging problems with VS2008 and IVF10.1 so far. My Windows is a german XP andVS2008 is the english version.

Ive only had a non responding VS6 CVF6.6 system when I used the mouse scroll from time to time. That was very annoying.

Markus

I experience the freezing problem with CVF sometimes (German version of VS and Windows). I am not sure if the use of the mouse wheel is influencing that behavior, but it could be possible. Some years ago I got the advice from Compaq (or still DEC) to cure the problem by exiting VS and deleting the .opt file in the project folder. IVF has no .opt file, but the fact I was looking for it lets me assume that I had the freezing problem in IVF as well.

The equivalent of the .opt in VS2002 and later is the .sou file. It is a hidden file so you may need to reveal it.

Steve - Intel Developer Support

There was a brief mention of something similar by myself and Jim Dempsey back in January
see : "Mysterious run time error with IVF 9.0"
http://software.intel.com/en-us/forums//topic/56797

It seems to be an intermittentproblem with Visual Studio(devenv)

Les

Hi Jrg,

did you find a solution for your problem? Yesterday I got a new machine and now VS2008 with IVF10.1 stops responding while debugging. Very annoying!

Markus

Hello Markus,

thank you asking.
No, I still have the problem that the debugger in VS (2005, english version) hangs up sometimes. I have switched to v10.1.021 meanhwile (32-Bit, WinXP 2SE), but the problem did not vanish. Also, I still don't see any regularity in the cirumstances when this crash happens and have no idea what could be the reason.

Joerg Kuthe
www.qtsoftware.de

This sounds to me as a typical ctfmon.exe problem. Search this forum for ctfmon.exe and then Google it. Maybe your problem will be solved.

Sabalan

Hello,

I do have the same experience .
It happens for me on:
- CVF 6.6b
- IVF 9.0,9.1,10 and 10.1 in combination with VS 2003 and VS2005 (both German)
based on Win XP Prof German.

Frank

I agree with Sabalan that the "Language Bar" (ctfmon.exe) is very likely to blame. It has this effect on many applications. Disabling the "Language Bar" feature usually resolves such problems.

Steve - Intel Developer Support

Steve,

I am afraid that it is not enough to disable the language bar and you are still going to seectfmon.exe running in the background in the task manager . Ctfmon.exe has to do with advanced text services and should be deactivated through Control Panel. You disable the language bar by deactivating the "advanced text services" (ctfmon.exe) but you do not deactivate ctfmon.exe by right-clicking on the language bar and disabling it.

Those who have the problem described in this thread: See e.g. here for a short descriptionabout whatctfmon.exe doesand how to disable it.

Sabalan

Thank you all for your replies. I have followed Sabalan's advice, got rid of the language bar and kicked ctfmon.exe out of the system about a week ago. At first I believed that I got rid of my "debugger problem" and was happy. But now after a couple of days of programming and debugging, unfortunately I have to say that the problem still exists. At least with VS2005. My impression is that the debuggerdoes not "freeze"so often as it did in the past.
However, I have to state thatwithout ctfmon.exethe CVF debugger (I am stillusing CVF 6.6.a) runs much more stable. Until today I haven't hada single crash and that is in fact a real improvement. Thanks a lot!

Jrg Kuthe
www.qtsoftware.de

I removed the cftmon.exe but while I still have a freezing debugger. Its very annoying when you want to debug a situation that needs time to reproduce and than *bang* youre dead. It seems, that when youve had one crash, the next one will follow very soon. It took about 2-3 hours before it first appears and then nearly every time.

I think that it is IVF related, because I havent got any freezing debugger while debugging a C# project in VS2008. I have to say, that I havent debugged C# very often, but still 0 freeze on the count list, while IVF is still growing :-/

I use Windows XP ProfessionalGerman with Service Pack 2, VS2008 english and IVF 10.1.024 IA-32.

Markus

The next time this happens (and, unfortunately,it sounds like you won't have to wait long :-), look at the system with the task manager. Is Visual Studio (devenv.exe) comatose (i.e., not using any cpu time) or is it perhaps cpu bound?It could appear to be "frozen" in either case.

devenv.exe uses 50% cpu time (I use Core2 Duo E6550 2.33GHz). I get a notifier icon from VS that it is delayed and that I should wait. Because waiting an hour was not enough I think that there is no other solution then killing the devenv process

I just started to work. Lets see, how much it takes to the next freeze :-)

Thanks for that information. The fact that Visual Studio is cpu-bound rather than blocked could be important.

Updating to VS2008 SP1 doesnt solve the debugger freezing problem...

I'm aware thatthe MacLinux set use itbut is IDB any better than the VS debugger or does it have its own flaws?I don't recall ever having read any posts here on how it measures up but I curious.

Gerry

IDB will be no longer supplied for Windows as of the next release, and typically if there is a Fortran-related issue in the VS debugger, it also affects IDB (but not always). We have not seen other reports of the VS debugger freezing.

Jrg, have you tried starting Windows in "Safe Mode" and seeing if the problem can be reproduced?

Steve - Intel Developer Support

Dear Lionel,
thank you for asking.
Yes, today I run the debugger in VS2005SP1 (and IVF 10.1.21) on a system started in "safe mode" (no networking etc.) - and got stuck after about 5 minutes. I am happy to return to regular mode, since it is really no fun to work in 640x480...
Jrg

Any news on the debugger freezing situation?

My problem still exists... :-(

Markus

We have not been able to reproduce this symptom.

Steve - Intel Developer Support

Maybe it has something to do with the german version of Windows? Since Jrg and I use Windows XP german...

Is there anything we could try to help you solving this problem?

Maybe it has something to do with the german version of Windows? Since Jrg and I use Windows XP german...

Is there anything we could try to help you solving this problem?

I am using also the german version of Windows XP and i have the same problems.

I have a additional problem which in our view is correlated to the german version of Win XP. If we work with huge files and we are open and close a huge number of files the program stops somewhere in the middle. No comment just stops. This 'works' with IVF 9 to 10.1. But the programs working properly with CVF.

Frank

File a support request with Intel Premier Support and be sure to specify that you are using the German version of Windows XP.

Steve - Intel Developer Support

Quoting - OnkelHotte@work
Maybe it has something to do with the german version of Windows? Since Jrg and I use Windows XP german...

Is there anything we could try to help you solving this problem?

You can reproduce this effect if you put your mouse cursor on an Umlaut () in an comment or double click on a word with an Umlaut. To avoid freezing, replace those Umlaute.

By the way, I filed a support request with Intel Premier Support. It can be reproduced by Roland who forwarded the information to the developers.

This issus appears in VS2008 and DVF 6.0/6.1 too.

(I hope nobody noticed my unprofessionel loginId. I changed it)

Quoting - rwg
You can reproduce this effect if you put your mouse cursor on an Umlaut () in an comment or double click on a word with an Umlaut. To avoid freezing, replace those Umlaute.

Damn, youre right! I placed my mouse cursor over an Umlaut and the debugger froze immediately.

But that is a IVF specific error, while debugging a C# project the debugger does not freeze when I move the mouse over an Umlaut.

Markus

Quoting - onkelhotte

Damn, youre right! I placed my mouse cursor over an Umlaut and the debugger froze immediately.

But that is a IVF specific error, while debugging a C# project the debugger does not freeze when I move the mouse over an Umlaut.

Markus

Must be something to do with the "tooltiip" display. Now that we can reproduce this, we can fix it.

Steve - Intel Developer Support

Quoting - Steve Lionel (Intel)

Must be something to do with the "tooltiip" display. Now that we can reproduce this, we can fix it.

Thats great. I have a lot of Umlaute in my graphical and text output and I cant change them all... So I have to be cautious while debugging. "Dont touch that Umlaut or Ill freeze!" :-)

Markus

I'm experiencing similar problems (VS hungs in debugging mode) using accented vowels in my comments ( !,...). I will try removing the comments of the source.

Luis

----
Luis

Quoting - Steve Lionel (Intel)

Must be something to do with the "tooltiip" display. Now that we can reproduce this, we can fix it.

A solution to this problem has been implemented and will be included in the next updates of both the 10.1 and 11.0 Intel Visual Fortran compilers. Each update is scheduled to be available in February, 2009.

If you can't wait that long, create a Premier Support issue and reference defect report DPD200049878.

Any news on that topic since the arrival of 11.1? I haven't installed v11.1 yet.
Thank you.

Regards,

Jrg Kuthe
www.qtsoftware.de

The problem is fixed in the current version, 11.1.038.

Steve - Intel Developer Support

Steve,

This may not be related, but it may have a small chance of being related.

I seem to recall a situation where an IVF user had installed the demo then upgraded to licensed product. For some reason the license manager was thinking that the software was still demo, would "phone home", find out it was release version, then continue. Although this is an IVF "startup" issue, it could potentially get entangled with DEVENV and the debugger. Could you dig up the instructions to turn off the IVF demo phone home (for licensed users).

Jim

www.quickthreadprogramming.com

Quoting - jimdempseyatthecove

Steve,

This may not be related, but it may have a small chance of being related.

I seem to recall a situation where an IVF user had installed the demo then upgraded to licensed product. For some reason the license manager was thinking that the software was still demo, would "phone home", find out it was release version, then continue. Although this is an IVF "startup" issue, it could potentially get entangled with DEVENV and the debugger. Could you dig up the instructions to turn off the IVF demo phone home (for licensed users).

Jim

Nevermind the above

The umlaut posts were "missing" when I wrote this.

Jim

www.quickthreadprogramming.com

A couple of months have passed by since I raised this topic, but this problem still exists. In the meantime I have tried v11.1 with VS2008 but it didn't help. To get rid of ctfmon.exe didn't help either.
Today I had this problem a couple of times again and this time I recorded a debug session showing this obscure behaviour. The ..swf video takes about 7 min. and the file is about 21MB in size. Since I am mostly working with VS2005 SP1 and IVF v10.1.021 the problem is recorded using that version. Does it make sense to send it to http://premier.intel.com? Please let me know. Thank you.

Regards,

Joerg Kuthe
www.qtsoftware.de

You can certainly submit this to Premier Support, but it would probably be better accepted if you were to show it with 11.1.

Steve - Intel Developer Support

Just an update on this.

Now I am working on Windows 7 (64-Bit, Ultimate) for almost a year now. At most I use VS2008 & IVF 11.1.070 [IA-32] and sometimes VS2010 & IVF 12.1.1.258 [IA-32], rarely the 64-Bit variants.
The problems with the debugger are gone and I must confess the IDE or the debugger very rarely crash.
Since some of the problems I encountered on my previous development systems seemed to relate to some Microsoft Office stuff (ctfmon), I did not install any of the MS office tools (I am using OpenOffice).
So, working with this dev. system is very pleasant now.

Kind regards,

Joerg Kuthe
www.qtsoftware.com

I have a strange problem. I am using Intel(R) Visual Fortran Composer XE 2011 Update 8 (12.1.3520.201)  with Microsoft Visual Studio 2010.

when I click on 'start without debugging (ctrl+F5)' it is good and it runs without any error and gives results as expected. But when I 'start debugging (F5)', it freezes VS for some minutes and then resumes back. I dont know why this is happening. I am using win7 professional english.

It started very recently, even I didnot change anything in the code. I even have restarted the system. Still the proplem persists. 

Any help would be highly appreciated.

Thank in advance.

Regards,

Vinod 

Vinod, I am not aware of this as a general issue. It would be a useful experiment to reboot your PC into "Safe Mode" (press F8 during the initial Windows boot screen) and see if the problem is still there.

Steve - Intel Developer Support

I have seen this sort of symptom [it was a while back now] when the debugger goes looking for symbols for a DLL (which might be a third party DLL all but completely unrelated to the application being debugged) in "strange" network places (for example - network addresses that might be valid for the developer of the third party DLL, but are completely irrelevant for everyone else on the planet).  Perhaps this is completely off the mark, but to see if it might be relevant, watch the messages that appear in the Output window as the debugger is loading the process.  You can also inspect the symbol status for each module (DLL or EXE) being debugged using the modules window (once the debugger is up and running), and control symbol loading properties for each module.

发表评论

登录添加评论。还不是成员?立即加入