Performance problem

Performance problem

Hi,

I ran Inspector xe 2013 on Ubuntu 12.04.

I used two programs from PARSEC benchmark suite and it is so slow as the following shows

*****************************************************************

program   original time(sec)       Inspector time(sec)     slowdown  

facesim    5.99                              2634                             439

ferret        6.63                              2376                             358         

*****************************************************************

I know it is supposed to be slow. But it is over 300 times slower. (the tool says it is up to x160 slower)

Does it look normal? Do you think I have some installation problem or something.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

On shell, I got errors like the following. But Inpector xe runs fine. What do you think is the problem?

** (inspxe-gui:6414): CRITICAL **: os_bar_hide: assertion `OS_IS_BAR (bar)' failed

(inspxe-gui:6414): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

** (inspxe-gui:6414): CRITICAL **: os_bar_set_parent: assertion `OS_IS_BAR (bar)' failed

** (inspxe-gui:6414): CRITICAL **: os_bar_hide: assertion `OS_IS_BAR (bar)' failed

(inspxe-gui:6414): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

** (inspxe-gui:6414): CRITICAL **: os_bar_set_parent: assertion `OS_IS_BAR (bar)' failed

** (inspxe-gui:6414): CRITICAL **: os_bar_hide: assertion `OS_IS_BAR (bar)' failed

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Last question: Do you have some kinds of white paper or any research paper about how Inspector xe works?

(Not the tutorial)

Thank you.

4 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Could you tell me what analysis type (memory or threading) and what level of analysis you were using when you saw these slowdowns? I'd like to have one of the developers look into this. Thanks,

I used threading. I disabled deadlock detection since I am interested in data race detection.
I attached a screenshot of the configuration I used.

附件: 

附件尺寸
下载 xe-conf.jpg113.89 KB

I notice that you did turn on cross stack thread access, which can slow down the tool. Your runtimes do seem overly long, but I can't think of a way that a misinstall could cause an issue like that.

Could you try with a normal run at ti3 (Locate Deadlocks and Data Races) instead of with the custom analysis type I see in your attachment?

发表评论

登录添加评论。还不是成员?立即加入