Installation error with Intel GPA 2012 R4

Installation error with Intel GPA 2012 R4

Hi,

I am using the latest (2012 R4) GPA. I am trying to use system analyzer. I run the the GPA monitor on the target machine (Intel HD 300) and try to open system analyzer on my machine running Windows 7.

During installation of Intel GPA on my machine, I get the following error: "The installer failed to enable GPA autorun." But after this, I can launch Monitor, Platform and Frame analyzer. But everytime I try to open the system analyzer on my machine, it gives an error: "The application was unable to start correctly (0xc000007b)."

I reinstaled it many time, but still getting the same error.

Could you help me finding the solution to this error? Is there a repository where I can try the older versions of GPA?

 

Thanks

Mehrad
12 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hello

Sorry that you are having this issue with Intel GPA. This is not one that I have seen before.

A couple of questions for you:

  • could you please right-click on the Intel GPA Monitor icon in the notification tray and copy the "About..." information here?
  • did you install using an Admin account, and did you reboot after installing and/or attempts at reinstalling?
  • do you have either the "auto-detect launched applications" or the "launch Intel GPA Monitor on startup" preference enabled?
  • do you have any anti-virus or firewall s/w installed?
  • does the problem occur with the standalone version of the Intel GPA System Analyzer, or the networked version, or both?
  • does the problem occur with all applications that you are attempting to analyze, or only some applications? in other words, can you successfully use Intel GPA System Analyzer to analyze the Intel GPA sample program, but your specific program doesn't work?
  • does the problem only occur on one machine, or does it occur on multiple systems?

Also, searching the web for this error code, I found that one cause may be that your OS is missing some key components and/or some OS files may be damaged. In other words, this may an issue not related to Intel GPA. Some potential fixes for this issue that I've seen when searching the web for this error:

  • check your disk for errors (right-click the disk, then "properties", then "tools", then "error checking" / "check now" (and select "automatically fix file system errors") and then reboot and let the check occur
  • download the Visual C++ libraries from Microsoft (http://www.microsoft.com/en-us/download/details.aspx?id=5555)

So hopefully between answering the questions in the first section and trying some of the techniques in the second we can get you up and running quickly.

Regards,

Neal

Hi Neal,

Thanks for the quick responce.

•could you please right-click on the Intel GPA Monitor icon in the notification tray and copy the "About..." information here? "Attached"
•did you install using an Admin account, and did you reboot after installing and/or attempts at reinstalling? Yes, both reinstalled and used admin cmd to install it.
•do you have either the "auto-detect launched applications" or the "launch Intel GPA Monitor on startup" preference enabled? No, I start it manually on the target machine and I don't run it mine. Also GPA monitor does not launch on my machine (it does on the target). I attached the error xml data below.
•do you have any anti-virus or firewall s/w installed? Yes. But since the application does not get installed correctly, I think that would not be any issue.
•does the problem occur with the standalone version of the Intel GPA System Analyzer, or the networked version, or both? Both.
•does the problem occur with all applications that you are attempting to analyze, or only some applications? in other words, can you successfully use Intel GPA System Analyzer to analyze the Intel GPA sample program, but your specific program doesn't work? It does not even start so I can launch an app.
•does the problem only occur on one machine, or does it occur on multiple systems? Not on the target, on my machine.

附件: 

附件尺寸
下载 about.txt579 字节
下载 gpa-error.txt1.34 KB
Mehrad

Hello,

Thanks for the quick reply...

There are only three cases that I know of that have resulted in Intel GPA not being able to be installed:

  • anti-virus software prevents a full install
  • the OS on the system is corrupted, and a reinstall of the OS allows the Intel GPA install to proceed OK
  • you are attempting to install the product on an invalid OS (such as the "started" version of Windows) -- but your OS version looks OK

So disabling any anti-virus for the install is important, since the Intel GPA install process attempts to write registry keys (which some anti-virus software may block). So I would recommend the following sequence of events: reboot, disable AV s/w, remove Intel GPA via the Windows control panel, reboot, disable AV s/w, install Intel GPA -- and let me know if you still get the install error.

If you still have the install error, there is a possibility that your OS is corrupted. Please try the suggestions that I listed before, which include (1) check the disk for errors, and (2) re-install Visual C++ run-time (which may have accidentally been removed or corrupted). I would also ask that you reboot from your install disk and perform a "repair" to ensure that all OS files are valid, then attempt a re-install of Intel GPA via the process I showed in the previous paragraph.

Hopefully this helps.

Regards!

Neal

So I just tried turning off the AV and firewall. I did not solve the problem. I will need sometime to repair the OS.

Does GPA error XML file I attached above tell you anything?

Mehrad

Hello,

A couple of comments on your response:

  • When you said that you "turned off AV and firewall", was this when trying to remove/re-install Intel GPA, or trying to run Intel GPA System Analyzer, or both? Can you also include a screenshot showing the install error message to be sure that I have the exact wording?
  • As to your question about the XML file, since Intel GPA did not install properly I'm not sure that this file contains information that we can use to debug the issue. The XML file's error code that we see in the file is a system error, which is probably due to Intel GPA not installing properly. In other words, the suggestion about checking for corrupted system files still applies.
  • For a completely different approach to solving this problem, I'm wondering whether you have a "hybrid" graphics system, which Intel GPA does not support. For these systems, there are multiple graphics devices enabled, but Intel GPA will only work if there is one and only one graphics device. To check this, open the "control panel" and select the "device manager", then look under "display adapters" and verify that there is only one active graphics device listed. If there are more than one, then disable one of these, reboot, then try the install again.

Hope this helps!

Regards,

Neal

Hello,

One more question... did you try to install Intel GPA and use the "repair" option? Just wondered whether this worked any differently than completely removing Intel GPA and trying to reinstall from scratch.

thanks!

Neal

1- I turned off AV and firewall, while installing and launching GPA monitor and system platform analyzer. Still getting the same error.
2- No it is not a hybrid system.
3- I tries installing and using repair option, didn't work either.

I am waiting for IT admin to do a repair on windows and see if that solves it.

Mehrad

Hello Mehrad,

Thanks for the additional checking... I was hoping that one of these suggestions might work without having to get your IT group involved.

We'll have to wait until your system gets checked out. Also, take a look at my other suggestion, which is to re-install the Visual C++ runtime libraries -- this may be what's missing or corrupted on your system (I searched the web for the error message that you provided, and this is one of the solutions that worked for some people).

Regards,

Neal

Hello again,

Two more things:

  • Are you using the .msi file to install Intel GPA directly, or are you running setup.exe?
  • One of our internal people has seen a similar error on Windows 8. One of your files showed Windows 8 -- what build are you using?

Thanks!

Neal

I used setup.exe
I tried the .msi too, no success.
I have this issue on Windows 7, actually it's working fine for me on Windows 8.

Mehrad

Hello,

We've not been able to duplicate this issue. Do you have any more info about this, such as the results from the OS repair?

Thanks,

Neal

发表评论

登录添加评论。还不是成员?立即加入