Composer XE 2013/Visual Studio Issues

Composer XE 2013/Visual Studio Issues

I have recently updated to Fortran Composer XE 2013 and running in MSVC 2010 and noticed some changes to the source code editor,

1) The Colours of the parentheses '()' and percent '%' "operators" no longer have same colour as that defined by the Fortran Operator setting. I can't find where the colour option is for these.

2) The Fortran Intrinsic colour is not always applied to the abs function.

3) When typing in the editor while a long compilation is running the order of the letters within the text gets screwed up and there are annoying pauses while you are typing. At first I thought it was me getting dyslexic in my old age!

Any suggestions for workrounds woulod br appreciated

Thanks,

PS Glad to see the selection of block of text for commenting out has be fixed and the following line is no longer selected.

3 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Can you show a screen shot of the abs problem? Parentheses and percent are not operators - I'll see if I can figure out if there's a problem here. The issue of garbled text during editing I will also try to reproduce.

Steve - Intel Developer Support

Hi Steve,

The colouring of the abs function seems to be dependent on the OS version. The problem occurs on my desktop which is x64 XP but is ok on Laptop which runs Windows 7 (also 64-bit). I have also noticed that in other files within the project the abs function is given the correct colour on the desktop. I can live with this but I'd prefer to get the parentheses, %, :: symbols to be coloured differently to the general code as they were in previous versions.

发表评论

登录添加评论。还不是成员?立即加入