intel composer 2013 final problem

intel composer 2013 final problem

To create your support account, please visit the Subscription Services web site
https://registrationcenter.intel.com/RegCenter/registerexpress.aspx?clie...
F-TVT2J9G8

To get started using Intel(R) Composer XE 2013 Update 1 located in
/opt/intel/composer_xe_2013.1.117:
- Set the environment variables for a terminal window using one of the following
  (replace "intel64" with "ia32" if you are using a 32-bit platform).
     For csh/tcsh:
        $ source install-dir/bin/compilervars.csh intel64
     For bash:
        $ source install-dir/bin/compilervars.sh intel64
     To invoke the installed compilers:
        For C++: icpc
        For C: icc
  To get help, append the -help option or precede with the man command.
- To view a table of getting started documents:
  install-dir/Documentation/en_US/get_started_lc.htm
  install-dir/Documentation/ja_JP/get_started_lc.htm

Movies and additional training are available on our website at
www.intel.com/software/products.
--------------------------------------------------------------------------------
q. Quit [default]
--------------------------------------------------------------------------------
Please type a selection or press "Enter" to accept default choice [q]:

bynkln@ubuntu:~$ icc
No command 'icc' found, but there are 25 similar ones
icc: command not found
bynkln@ubuntu:~$ sudo icc
[sudo] password for bynkln:
sudo: icc: command not found
bynkln@ubuntu:~$ source install-dir/bin/compilervars.csh intel64
bash: install-dir/bin/compilervars.csh: No such file or directory
bynkln@ubuntu:~$ ^C
bynkln@ubuntu:~$ q
q: command not found
bynkln@ubuntu:~$ source install-dir/sh/compilervars.bin intel64
bash: install-dir/sh/compilervars.bin: No such file or directory
bynkln@ubuntu:~$ source/opt/intel/bin/compilervars.sh
bash: source/opt/intel/bin/compilervars.sh: No such file or directory
bynkln@ubuntu:~$

can you help very quicly... what should i do to aweake icpc and icc?

4 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hi,
I guess you are not providing the space between "source" and "opt". Usually the default installation directory for "root" installation would be "/opt/intel/ /bin/". So you should check if this is the same directory applicable for you or you have changed the installation dir. SO in order to set the compiler icc or icpc use:-

source /opt/intel//bin/compilervars.sh intel64

Please feel free to let me know if you still have any issue with setting the compiler.

Regards,
Sukruth H V

source /opt/intel/bin/compilervars.csh intel64 would work, if the compiler is installed in /opt/intel/. Note the spaces between "source", the path to the shell script, and the "intel64" option.

thank you very much for quick answer result is:

bynkln@ubuntu:~$ source /opt/intel/bin/iccvars.sh intel64
bynkln@ubuntu:~$ source /opt/intel/bin/compilervars.sh intel64

bynkln@ubuntu:~$ icc --version
icc (ICC) 13.0.1 20121010
Copyright (C) 1985-2012 Intel Corporation. All rights reserved.

bynkln@ubuntu:~$ icpc -version
icpc: command line warning #10006: ignoring unknown option '-version'
icpc: command line error: no files specified; for help type "icpc -help"

bynkln@ubuntu:~$ source /opt/intel/composer_xe_2013.1.117/bin/iccvars.sh intel64
bynkln@ubuntu:~$ source /opt/intel/composer_xe_2013.1.117/bin/compilervars.sh intel64

bynkln@ubuntu:~$ icc --version
icc (ICC) 13.0.1 20121010
Copyright (C) 1985-2012 Intel Corporation. All rights reserved.

bynkln@ubuntu:~$ icpc --version
icpc (ICC) 13.0.1 20121010
Copyright (C) 1985-2012 Intel Corporation. All rights reserved.

worked for me!!

发表评论

登录添加评论。还不是成员?立即加入