OpenCL program crashes in processor graphics (P4000)

OpenCL program crashes in processor graphics (P4000)

Build log claims:

   fc1 build 1 succeded.

   fc1 build 2 succeeded.

Error: Internal Error.

The same program works fine on the CPU; it only fails in the GPU. Any pointers on where to start? Thanks much (I am using OpenCL 2012 on a Windows 7 Pro with Visual Studio 2010 Express). I cannot install 2013, it fails for both the 32 bit and 64 bit versions)

9 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hi!

Could you please attach a reproducer for this issue?

Regarding the 2013 installer failure - could you please also provide the details (have you removed 2012 version before that or not, at which step and what exactly the error message is)?

Thanks,
Yuri

Regarding the 2013 installer failure: I've tried removing 2012, reinstalling Win7 and leaving the 2012 on. The results are the same, it goes through to asking "Do you wish to install these components", then to "Intel SDK for OpenCL application"-> I agree to EULA, leave the default Components, choose Integrate with Microsoft Visual Studio 2010 software (I am using VS Express) and when I hit install, the progress meter moves up towards Copying Files and then it quickly rolls back (too fast for me to see) and then brings up a screen, "Intel SDK for OpenCL Applications 2013 Beta setup Wiward Ended Prematurely because of an error. ..." message. There are no helpful messages on what the error actually was. I am using WIn 7 Pro.

Update: Once I installed Visual Studio 2010 Ultimate, I was able to install OpenCL 2013 beta (looks like the installer was automatically trying to remove the old CPU only RunTime package and failing/crashing)

I suspect that this code has a syntax or some sort of an error. It core dumps before it gets there. (Its a .cl file, the uploader only allows .c though)

Update: this code fails with the same error with 2012 and 2013 (beta)

附件: 

附件尺寸
下载 fail.c14.65 KB

Hi Surendar!

I'm glad to hear you solved the installation issue. Actually it is reproducible on our side (with only VS 2010 Express installed). A workaround that can be used (if you ever need to work in such setup) - launch the installer, clear 'Remove temporarily extracted files' checkbox. After the extraction cancel the installation and install vc redistributable files - they can be found in extracted files. And then launch the installer again.

As for the kernel compilation issue - I have been able to reproduce it as well. I will pass the information to the relevant team for the investigation.
One comment that I have right now - there are a lot of #ifdefs (that were inherited from c version obviously), but since none of them would make sense in OpenCL code I'd suggest some cleanup.

Thanks,
Yuri

Hi,

An update on kernel compilation issue.
It has been fixed and should be available in the next driver release.

Thanks,
Yuri

Thanks Yuri. Any time frame on when I can get access to the new driver? Thanks again

Arnon Peleg (Intel)的头像

Hi,

We will use this forum to notify when the new driver is released. Stay tuned.

Aenon

Hi,

Sorry for the delay. An update for the drivers version. Latest available drivers (15.​31.​9.​3165) contain the fix for this issue.

Thanks,
Yuri

登陆并发表评论。