Trouble installing/using GPA 12.5 with networked fileshares

Trouble installing/using GPA 12.5 with networked fileshares

Hi,

I have another topic open, but I am running into a completely different issue so I am starting a new topic.

I am installing GPA on my development PC (Windows 7 64 bit, MS security essentials as virus scanner) and am running a few issues that I think are related. I am running with CUA turned on.

During setup, the installer complains that it can not connect to my z: drive. The Z drive is a network share that I have linked to "My Documents". It seems it is trying to access the z: drive when running as admin. Mapping the drive manually from a command prompt in administrator mode resolves this.

I can launch the GPA and see the HUD, but when I do a capture for a frame, the data is saved to a folder on the aforementioned z drive. I would like to make this a different folder, but I see no way to do this.

When saving the data is successful, I can not open the captured data in the frame analyzer. I got an error that the file format is invalid.

I have reinstalled a number of times, where I have tried various ways to stop GPA using my Z drive, as I suspect that is the root cause of the problem. This failed. I reverted some windows settings to use z: as my documents folder, but that did not help.

Depending on how I setup the z drive during install, I get my application to freeze when capturing frames, the gpa monitor crashing on startup, or I get output that is not accepted by the frame analyzer.

Is there a reccomended procedure for installing the GPA on a PC in a windows domain?

Or how can I stop it from using a networked drive?

Thanks in advance,

Jan

 

 

5 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项
Neal Pierman (Intel)的头像

Hello,

Your email says that you have linked "My Documents" to the Z: drive. This is will be a problem since Intel GPA uses hard-coded directories for installation, log files, temporary work files, and capture files (C:\Users\%USERNAME%\Documents\GPA_2012_R5\).

I believe that the only way to get this to work is to use the C: drive for "documents" with Intel GPA. You'll either have to reset your defaults for your user directory to use the C: drive, or if your main account must use the Z: drive for documents, then create another user that "lives" on the C: drive for all your Intel GPA work.

In parallel, I'll check with the development team to get more details on this to see if there are any workarounds.

Regards,

Neal

Neal Pierman (Intel)的头像

Hi,

I did some more checking and this is a limitation that is not easy to work around. Also, you will have less system overhead (and therefore more accurate metrics) when using local storage rather than a remote fileshare.

So I've submitted a ticket to have this limitation documented.

Sorry for the inconvenience that this may cause.

Regards,

Neal

The trouble is, that I have reverted my redirection of "My Documents" to the z drive, and the software still won't install. The installer continues to complain unless I redirect z: to some folder somewhere.

If I do work around that, depending on which folder I mount, the GPA won't save snapshots, or the snapshot's aren't readable.

What API call or system variable does the software/installer use to determine where to save to?
Also, I am running with UAC turned on. Is GPA compatible with that?

Neal Pierman (Intel)的头像

Hello,

Intel GPA requires that 'My Documents' reside on the C: drive, both for the installation process and when running the program. The development team has told me this is a limitation of the product. So you cannot redirect 'My Documents' to another fileshare, and there are no environment variables or registry keys you can set to change this behavior.

For example, Intel GPA saves capture files to
C:\Users\%USERNAME%\Documents\GPA_2012_R5\

Also, enabling UAC does not have any impact on this issue.

So you have two options:

  • Start from scratch by creating a new user on your machine with 'My Documents' on the C: drive, then install the product.
  • Uninstall Intel GPA, then reset your system to ensure 'My Documents' is located on the C: drive (along with all registry keys and other system files that refer to your home directory), then reinstall the product and try again.

The advantage of the first solution is that this is a known good method for getting Intel GPA installed and working properly.

Hope this helps, and sorry that you've run into this limitation.

Regards,

Neal

登陆并发表评论。