Problems with Windows8 and Intel GPA 2012 R5

Problems with Windows8 and Intel GPA 2012 R5

Hi,

I have installed Windows 8 and GPA 2012 R5 and the "Auto-detect launched applications" and "Launch Intel GPA monitor on startup" options do not work anymore

I launch my program from Visual Studio and so the "Auto-detect launched applications" option is very useful so that I don't have to attach to program each time I want to debug both with Visual Studio and GPA. Between the two problems, this is the most annoying.

For the problem with the "Launch Intel GPA monitor on startup", I tried to launch GPA monitor as administrator, but GPA still complains about "The Launch Intel GPA monitor on startup requires administrative privileges".

Thanks,

Benoît. 

16 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

 Hello,

Sorry to not see this earlier -- it appears that the "auto-notify" feature of the forums is broken.

Can you right-click on Intel GPA in the notification area and copy the "About..." info here? Also, what version of VS are you using?

Thanks!

Neal

Hello Benoît,

Another question for you: is your account an admin account, or a "normal" account and you're trying to startup the Intel GPA Monitor as administrator?

Thanks!

Neal

Hello Neal,

I have completely the same problem like Benoît. has.

Evgen.

With respect to the "Auto-detect launched applications" issue, please try the latest GPA release, 2013 R3: http://software.intel.com/en-us/vcsource/tools/intel-gpa

I'll take a look at the Auto launch issue you reported and file a defect as necessary.

I've confirmed the issue you reported with the Launch Intel GPA Monitor on startup and reported a defect.

I have installed latest build, and again  "Auto-detect launched applications" doesn't work.

Can you enable Auto detect again and go into the GPA folder (c:\program files\intel\gpa\2013 R3\) and run gpasample.exe and let me know if the GPA Heads Up Display (HUD) comes up?  In addition, can you provide the workload you are trying to analyze?

I just tried to run gpasample.exe with  "Auto-detect launched applications" and it still doesn't work for me. We have a directx based game, and I just wanna analyse performance of some of shaders made by me. And, unfoturantly I can not run our game from "Analyze Application".

Evgen,

Can you check in your BIOS (place in the BIOS varies greatly depending onthe BIOS vendor) and see if Secure Boot is enabled?  If so, disable it.  This feature, on some platforms, causes auto-injection to occasionally fail, most notably on Haswell-based platforms (irrespective of the GPU brand).  Additionally you can make sure UAC is off just to make sure and post a copy of your GPA Monitor -> About dialog text.  This will help us track down what's going on.

 

-Jeff

This is data from About.. window:

Windows 8, 64-bit DEP enabled
Num Processors: 8
Memory: 12223MB
System BIOS: Dell Inc. A00 (03/25/2013)
Driver 0:
     Device: NVIDIA GeForce GTX 650 Ti
     Provider: NVIDIA
     Date: 9-12-2013
     Version: 9.18.13.2723
     VendorId: 10de
     ProductId: 11c6
     Stepping: a1
     No support for GPA Instrumentation
GPA install directory: C:\Program Files\Intel\GPA\2013 R3\
GPA version: 13.3.207307
Current user is in Administrators group: YES
Current GPA 2013 R3 (13.3.207307)
"Auto-detect launched applications" is On

"Auto-detect launched applications" started to work only in one case: Secure Boot Disabled + UAC Disabled.
I did test combinations like: Secure Boot Enabled + UAC Disabled, Secure Boot Disabled + UAC Enabled and this combinations doesn't work.

Secure Boot is the primary cause of auto-detect failures as it interferes with loading GPA into the process under analysis.  I'll file a bug so we can take a look at this.  In the meantime, if UAC disabled + Secure Boot disabled seems to work for you while we investigate the problem.

 

Regards,

Jeff

Hi,

Just to say I'm using 2013 R3 now and DX11 and DX11.1 apps are correctly detected, but I have other issue with perf markers that I'm going de describe in another thread.

Benoit. 

Hi,

I'll check on the status of "secure boot" w/ GPA.

Regards,

Neal

Hello,

No specific information yet about a definitive fix for the "secure boot" conflict with Intel GPA, but I did find that there's a way within the Windows* OS to see whether or not you have this option enabled or not.

To check this out, open a cmd window in Windows 8/8.1, then type msinfo32, and on the front screen about two-thirds of the way down there will be an entry for Secure Boot State, which will show you whether this option is enabled or not. If enabled, you'll then need to go into your BIOS and disable this (and of course each hardware vendor has a different way of chaning the Secure Boot option in the BIOS, so I can't give you a definitive answer on the steps to follow to do this).

Regards,

Neal

登陆并发表评论。