Unable to start program "C:\...."

Unable to start program "C:\...."

Hi,

Within our organisation we have a problem with the Intel Visual Fortran Compiler. When a user tries to compile a program in Debug-mode (F5), the following error occurs:

Unable to start program "C:\<path to project>"

We are using Microsoft Visual Studio 2010 Professional 10.0.30319.1 and Intel(R) Visual Fortran Composer XE 2011 Update 7 Integration for Microsoft Visual Studio* 2010, 12.1.3518.2010

Does anyone know how to solve this problem?

9 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

F5 starts the program under the debugger - it does not compile the program. You haven't built the executable yet, which is what leads to this error. Use F7 to start the build, then use F5 to start debugging. Don't forget to set a breakpoint first.

Steve - Intel Developer Support

There is a setting in Visual Studio that controls this behavior. Tools > Options > Projects and Solutions > Build and Run. Change "On Run, when projects are out of date" to either "Always build" or "Prompt to build".

Steve - Intel Developer Support

I am the IT guy that tries to solve the problem for the employee, so sorry if I say something that is not correct :).

I followed you steps, I first build the exe and then tried to use the debugger. Visual Studio immidiately shows the error message as stated in my first post. So the problem is not solved by this. Do you have some other thoughts?

Did the program successfully build? Does the EXE file named in the error message exist? Please attach a ZIP of the buildlog.htm file from the Debug subfolder so I can see what happened.  Please also include a screenshot of the error message.

Steve - Intel Developer Support

I included the screenshot with the buildlog in the attachment.

附件: 

附件尺寸
下载 buildlog-screenshot.zip233.02 KB

Hmm - that is very strange. Does the same error occur if you use CTRL-F5 to start without debugging? Can you run the program by double-clicking on it in the folder? (The console window will disappear when the program exits, but you shouldn't see an error.)

What if you create the project in a different folder, say, C:\test ?

Steve - Intel Developer Support

Hi Steve,

We found the solution for this problem. The problem was a script that was executed during deployment of a PC. This script included a command that added some environmental variables (PATH), but in this command there was made a typo which caused the problem. As soon as we corrected the variable, VS debugs without any problem.

Thanks for you help!

Glad to hear it!

Steve - Intel Developer Support

发表评论

登录添加评论。还不是成员?立即加入