"Analyze Application" worked once for Win Store apps, doesn't work anymore...??

"Analyze Application" worked once for Win Store apps, doesn't work anymore...??

Hi,

I downloaded and ran GPA's Analyze Application option and it works every time for the sample app.  On the first try, I was able to get it to work for Windows Store apps as well.  However, now when I run it on any Windows Store app, it always fails with: "Intel GPA Monitor failed to launch the application: Failed to launch Windows 8 Store application"  I didn't change my system at all in between the success and failures.  Tried restarting, etc. but no change.  What could be going on?  Is the Windows 8 Store monitoring known to be buggy?

4 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hello,

Sorry that you've run into this issue.

I don't believe that there are any open issues similar to what you've described, so let me get some more information from you.

First of all, please include a copy of your system configuration by right-clicking the Intel GPA monitor in the notification area and selecting "About...".

A few questions for you:

  • Are you using "auto-detect" mode to attach to the Windows Store App, or are you attempting to attach via the Intel GPA Monitor "analyze application" option? I think you mentioned that you were using "analyze application", but I wanted to be sure.
  • If using the "analyze application" option, have you also tried the client/target version of Intel GPA System Analyzer, and does this have the same issue? Note that you should be able to run the client/target version with the client and target both being the same system.
  • Also, have you tried other Windows Store Apps, or does it fail on just one of them (and which one?).
  • Could you also include a copy of MonitorLog.txt (it should be in C:\Users\<user>\Documents\GPA_2012_R5)?
  • Also, there should be a log file created when you attempted to connect to the application; the file is located here: C:\Users\<user>\Documents\GPA_2012_R5\Logs
  • I don't believe that Intel GPA actually "crashed" in your situation, but if it did it will have created an XML crash file about your system state; include this if appropriate.

Thanks!

Neal

Hello,

In parallel, I've been checking with the development team, and one thing they are wanting you to check in the Task Scheduler whether there is a task called "MetroAppManager launch". If so, please kill the process, reboot, then see if this clears the problem.

I may also be able to get you a special version of Intel GPA with some additional logging information that may let us know why this problem occurs -- is this possible?

Regards,

Neal

Hello,

One thing we've noticed with some systems is that using the "Secure Boot" mode of the BIOS interferes with Intel GPA's operation. I suggest that you disable "secure boot" mode to see if this helps.

Regards,

Neal

ps-> we're still trying to understand why and how this BIOS setting interferes with Intel GPA -- we'll be posting more info as soon as it's available

发表评论

登录添加评论。还不是成员?立即加入