High CPU usage when open a IVF solution with MSVS 2010

High CPU usage when open a IVF solution with MSVS 2010

I am using MSVS 2010 + Cluster Studio 13 (updated last week). When I open my solution (some c projects and some fortran projects), the CPU usage went up and never came down. The trouble maker could be the parser.

I have a project contains 200+ .f90 files and 100+ _inc.f90 (header) files. The parser went smothly when the project first load. It said that "Parse file xxxxx.f90". But later it slowed down with increase of CPU usage.

Then in the end the CPU usage stayed around 13% without doing anything. (see attachment)

My computer has windows 7 64bit installed. i7 + 8G ram. 

Does anyone have a similar problem? Is there a way to fix it?

14 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

I attached a solution in a zip file. Please take a look and check whether it will cause a CPU usage.

Thanks!

附件: 

附件尺寸
下载 cpu-test.zip1.34 MB

There certainly seems to be a problem here.  We'll look into it. As a workaround, open VS2010 separately, select Tools > Options > Text Editor > Fortran > Advanced and set Disable Database to True. You'll lose the advanced editing features but your project will load.

Steve - Intel Developer Support

Yes, that works. Disable database option speed it up.

I do not think that  ~13% load on CPU is very high.For obtaining better and more accurate results I would recommend to run Xperf tool(before running Xperf please close Process Explorer because it calls Kernel Logger).

Quote:

iliyapolak wrote:

I do not think that  ~13% load on CPU is very high.For obtaining better and more accurate results I would recommend to run Xperf tool(before running Xperf please close Process Explorer because it calls Kernel Logger).

I mean 13% CPU usage without doing any typing/debugging/compiling. Plus there was a balloon told you "MSVS is busy" once in a while.

Quote:

FortCpp wrote:

Quote:

iliyapolakwrote:

I do not think that  ~13% load on CPU is very high.For obtaining better and more accurate results I would recommend to run Xperf tool(before running Xperf please close Process Explorer because it calls Kernel Logger).

I mean 13% CPU usage without doing any typing/debugging/compiling. Plus there was a balloon told you "MSVS is busy" once in a while.

Ok now I understand it properly.Can you reproduce it under Xperf?

iliyapolak,

Do you mean Windows Performance Toolkit? I have it installed. But it doesn't do anything. Everything is blank (See attachment).

I attached a solution under my original post. You can try it out by yourself.

附件: 

附件尺寸
下载 perf.jpg140.81 KB

>>>I attached a solution under my original post. You can try it out by yourself>>>

Unfortunately I do not know fortran.

>>>Do you mean Windows Performance Toolkit? I have it installed. But it doesn't do anything. Everything is blank (See attachment).>>>

Yes.How did you run xperf?What command did you issue?Have closed Process Explorer before using xperf?

Can you run this command: xperf.exe -on -stackwalk  devenv.exe

Because you are on 64-bit machine in order for the stacks to not be paged out there is an option to disable paging.

Reg.exe add "HKLM\System\CurrentControlSet\Control\Session Manager\Memory Management" -v DisablePagingExecutive -d 0x1 -t REG_DWORD -f

 

This is a bug in our version of IntelliSense in VS. For me, it causes VS10 to exit without any error message. VS12 just slowly chugs along. It isn't supposed to do this.

I have escalated it to the developers, and they're usually pretty good at getting a fix into an update.

Steve - Intel Developer Support

The developers tell me they have fixed several problems this source brings out and that the fix is expected to be included in Update 3.

Steve - Intel Developer Support

Great! I am looking forward to the update 3! Thanks.

发表评论

登录添加评论。还不是成员?立即加入