Error in Intel VTune Amplifier XE 2013

Error in Intel VTune Amplifier XE 2013

Hi All,

I have build a parallel program and it works well. But when I run VTune hotspots Analysis, I got the following error

OMP: Error #136: Cannot create thread.
OMP: System error #1455: The paging file is too small for this operation to complete.
OMP: Error #178: Function GetExitCodeThread() failed:
OMP: System error #6: The handle is invalid.

OS: WIN7 X64 Pro

Compiler: Intel Parallel Studio XE2013 (Fortran)

CPU: Intel xeon E5

Memory: 16GB

I have checked automatically manage paging file size for all drives and the current allocated paging file is 16GB. Running my test only cost about 200MB, there should be enough space for both paging file and physical memory. Anything wrong with my setting?

Thanks and regards,

Daniel

29 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

>>...I have checked automatically manage paging file size for all drives and the current allocated paging file is 16GB. Running
>>my test only cost about 200MB, there should be enough space for both paging file and physical memory. Anything wrong
>>with my setting?

Try to use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM.

Also, I reported a similar problem about 2 months ago and I don't think that Intel software engineers considered it seriously. Also, similar problems were reported in the past by many software developers.

Could you create a new thread with the description of the problem on Intel Visual Fortran compiler forum?

Can you post full log file?

>>...Can you post full log file?

It is not clear what log file do you want to see and I'm not sure that Daniel has any log files ( text of errors provided in the initial post of the thread self-descriptive ).

Maybe your can try - (change sample interval from 1 to 10, don't collect stack info, short collection time : reduce extra-cost from VTune Amplifier XE)

"amplxe-cl -collect-with runss -knob sampling-interval=10 -knob cpu-samples-mode=nostack -duration 30 -- application.exe"

Is there same problem when using lightweight-hotspots?

Is it possible that you can attached test case that I can run on Windows* 7 on my side? It should be very helpful dig-out root-cause.

引文:

Sergey Kostrov 写道:

>>...I have checked automatically manage paging file size for all drives and the current allocated paging file is 16GB. Running
>>my test only cost about 200MB, there should be enough space for both paging file and physical memory. Anything wrong
>>with my setting?

Try to use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM.

Also, I reported a similar problem about 2 months ago and I don't think that Intel software engineers considered it seriously. Also, similar problems were reported in the past by many software developers.

Could you create a new thread with the description of the problem on Intel Visual Fortran compiler forum?

Hi Sergey,

Thanks for your quick response. I will try your suggestion later and get it back. Currently I can not do it as my computer is now running other task that I don't want to restart the system as the change of VM. The error log file is as follows:

OMP: Error #136: Cannot create thread.
OMP: System error #1455: The paging file is too small for this operation to complete.
OMP: Error #178: Function GetExitCodeThread() failed:
OMP: System error #6: The handle is invalid.

Thanks again,

Daniel

Hi Peter,

The sample interval for my previous test is 10. I have also tried to use "without stacks", the error is the same, as follows:

OMP: Error #136: Cannot create thread.
OMP: System error #1455: The paging file is too small for this operation to complete.
OMP: Error #178: Function GetExitCodeThread() failed:
OMP: System error #6: The handle is invalid.

Thanks,

Daniel

引文:

Peter Wang (Intel) 写道:

Maybe your can try - (change sample interval from 1 to 10, don't collect stack info, short collection time : reduce extra-cost from VTune Amplifier XE)

"amplxe-cl -collect-with runss -knob sampling-interval=10 -knob cpu-samples-mode=nostack -duration 30 -- application.exe"

Is there same problem when using lightweight-hotspots?

Is it possible that you can attached test case that I can run on Windows* 7 on my side? It should be very helpful dig-out root-cause.

Is there same problem when using lightweight-hotspots?

Strange error. Adi Levin's blog gives an short explanation about the CreatThread failure and this is related to 32-bit system with huge amount of threads or large memory consumption which is not your case.

Hi Sergey,

It cannot work when use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM.The test crashes with the following output:

The database has been cleared, elapsed time is 0.257 seconds.
Raw data has been loaded to the database, elapsed time is 0.142 seconds.
Data transformations have been finished, elapsed time is 0.000 seconds.
Warning: Cannot locate symbols for file `C:/Windows/system32/kernel32.dll'.
Warning: Cannot locate symbols for file `C:/Windows/SYSTEM32/ntdll.dll'.
Warning: Cannot locate symbols for file `C:/Windows/system32/KERNELBASE.dll'.
Warning: Cannot locate symbols for file `C:/Program Files (x86)/Intel/VTune Amplifier XE 2013/bin64/tpsstool.dll'.
Symbol resolution has been finished, elapsed time is 3.012 seconds.
Deferred data transformations have been finished, elapsed time is 0.031 seconds.
Precomputing frequently used data has been finished, elapsed time is 0.052 seconds.
Data model parameters have been set, elapsed time is 0.048 seconds.
Redundant overtime data has been discarded, elapsed time is 0.008 seconds.
Raw collector data has been discarded, elapsed time is 0.000 seconds.
Finalizing the result took 4.113 seconds.
Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'

Thanks,

Daniel

引文:

Sergey Kostrov 写道:

>>...I have checked automatically manage paging file size for all drives and the current allocated paging file is 16GB. Running
>>my test only cost about 200MB, there should be enough space for both paging file and physical memory. Anything wrong
>>with my setting?

Try to use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM.

Also, I reported a similar problem about 2 months ago and I don't think that Intel software engineers considered it seriously. Also, similar problems were reported in the past by many software developers.

Could you create a new thread with the description of the problem on Intel Visual Fortran compiler forum?

Hi danielsue,

there are available more advanced troubleshooting methods(like running VTune under debugger or putting a breakpoints on thread creation and memory allocation routines),but I think those methods should be employed by VTune developers to fix the problem.

Hi iliyapolak,

I ran the VTune under debugger mode and got the above-mentioned errors. I guess the something is wrong in the setting or there is some bug in the tool. The testing cases range from a very small one (only 121 non-zero elements in matrix) to a very large one (1 billion non-zero elements in matrix), but they all stopped with the same error. Exactly there cases run well without VTune.

Thanks,

Daniel

引文:

iliyapolak 写道:

Hi danielsue,

there are available more advanced troubleshooting methods(like running VTune under debugger or putting a breakpoints on thread creation and memory allocation routines),but I think those methods should be employed by VTune developers to fix the problem.

>>>I ran the VTune under debugger mode and got the above-mentioned errors>>>

Did you run VTune under windbg? It is not clear from your post.

Yes, I ran VTune under debug mode in Visual Studio.Net. I also tried to run it in release mode, it produce the same error.

>>...It cannot work when use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM...

I'd like to confirm that you've tried to change it.

These four errors:

>>...
>>Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
>>...

are indication that something is wrong with internal SQLite database, or with SQL queries, which used by VTune. Did yiu try to install the most recent VTune Update?

The VTune in my computer was not the latest, but it was updated two weeks ago. The most recent VTune, as can be seen from the intel software manager, was published on May-16-13. I will try to update it to see how it goes.

引文:

Sergey Kostrov 写道:

>>...It cannot work when use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM...

I'd like to confirm that you've tried to change it.

These four errors:

>>...
>>Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
>>...

are indication that something is wrong with internal SQLite database, or with SQL queries, which used by VTune. Did yiu try to install the most recent VTune Update?

I still don't know if there is problem of using lightweight-hotspots instead of hotspots, I posted last time.

Another consideration is to try VTune standalone (not in Visual Studio), it may save resource...

Was it possible that you ran 32bit application under 64bit OS? If it is the case, there is 2GB memory limitation. 

After updating VTune to the latest version, the program still failed and I got the following information:

The database has been cleared, elapsed time is 0.294 seconds.
Raw data has been loaded to the database, elapsed time is 0.172 seconds.
Data transformations have been finished, elapsed time is 0.000 seconds.
Warning: Cannot locate symbols for file `C:/Windows/system32/kernel32.dll'.
Warning: Cannot locate symbols for file `C:/Windows/SYSTEM32/ntdll.dll'.
Warning: Cannot locate symbols for file `C:/Windows/system32/KERNELBASE.dll'.
Warning: Cannot locate symbols for file `C:/Program Files (x86)/Intel/VTune Amplifier XE 2013/bin64/tpsstool.dll'.
Symbol resolution has been finished, elapsed time is 3.111 seconds.
Deferred data transformations have been finished, elapsed time is 0.039 seconds.
Precomputing frequently used data has been finished, elapsed time is 0.059 seconds.
Data model parameters have been set, elapsed time is 0.047 seconds.
Redundant overtime data has been discarded, elapsed time is 0.008 seconds.
Raw collector data has been discarded, elapsed time is 0.000 seconds.
Finalizing the result took 4.303 seconds.

引文:

Sergey Kostrov 写道:

>>...It cannot work when use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM...

I'd like to confirm that you've tried to change it.

These four errors:

>>...
>>Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
>>Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
>>...

are indication that something is wrong with internal SQLite database, or with SQL queries, which used by VTune. Did yiu try to install the most recent VTune Update?

>>>Warning: Cannot locate symbols for file `C:/Windows/system32/kernel32.dll'.>>>

You can point VS debugger to MS debug symbols download server,but it will not solve the problem.Maybe if Intel devs made VTune symbols(all of them) public then it can improve an understanding of function calls.

>>>Yes, I ran VTune under debug mode in Visual Studio.Net. I also tried to run it in release mode, it produce the same error.>>>

VS debug mode will not be helpful in locating the problem.Windbg could be more helpful,but as it was told in other discussion related to crash of fee.dll module such a task should be done by Intel developers who have the ultimate knowledge of the misbehaving software.

>>>>...It cannot work when use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM...
>>
>>I'd like to confirm that you've tried to change it.

Daniel, could you provide some details on what happened when you've changed VM settings to use 'Custom Size'? Did you try it?

Yes, I tried it.

(1) When use "System managed size" VM, the error information are as follows:

OMP: Error #136: Cannot create thread.
OMP: System error #1455: The paging file is too small for this operation to complete.
OMP: Error #178: Function GetExitCodeThread() failed:
OMP: System error #6: The handle is invalid.

(2) When use "Custom Size" VM, the error information are as follows:

Warning: Cannot locate symbols for file `C:/Windows/system32/kernel32.dll'.
Warning: Cannot locate symbols for file `C:/Windows/SYSTEM32/ntdll.dll'.
Warning: Cannot locate symbols for file `C:/Windows/system32/KERNELBASE.dll'.
Warning: Cannot locate symbols for file `C:/Program Files (x86)/Intel/VTune Amplifier XE 2013/bin64/tpsstool.dll'.
Symbol resolution has been finished, elapsed time is 3.012 seconds.
Deferred data transformations have been finished, elapsed time is 0.031 seconds.
Precomputing frequently used data has been finished, elapsed time is 0.052 seconds.
Data model parameters have been set, elapsed time is 0.048 seconds.
Redundant overtime data has been discarded, elapsed time is 0.008 seconds.
Raw collector data has been discarded, elapsed time is 0.000 seconds.
Finalizing the result took 4.113 seconds.
Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'
Error: Unsupported item 'helpKeyword' for query 'vectorQuery(id='')[]'
Error: Unsupported item 'helpKeywordCalcPolicy' for query 'vectorQuery(id='')[]'

(3) After updating the VTune to the latest version ,the error information are as follows:

Warning: Cannot locate symbols for file `C:/Windows/system32/kernel32.dll'.
Warning: Cannot locate symbols for file `C:/Windows/SYSTEM32/ntdll.dll'.
Warning: Cannot locate symbols for file `C:/Windows/system32/KERNELBASE.dll'.
Warning: Cannot locate symbols for file `C:/Program Files (x86)/Intel/VTune Amplifier XE 2013/bin64/tpsstool.dll'

引文:

Sergey Kostrov 写道:

>>>>...It cannot work when use 'Custom Size' Virtual Memory ( VM ) instead of 'System managed size' VM...
>>
>>I'd like to confirm that you've tried to change it.

Daniel, could you provide some details on what happened when you've changed VM settings to use 'Custom Size'? Did you try it?

You could try to set a smaller size for OMP_STACKSIZE environment variable at runtime as follows:
...
int iRetCode = _putenv( "OMP_STACKSIZE=32K" );
if( iRetCode == 0 )
printf( "OMP_STACKSIZE=%s\n"), getenv( "OMP_STACKSIZE" );
else
printf( "Error: Failed to Set Environment Variable OMP_STACKSIZE\n" );
...

>.>>Warning: Cannot locate symbols for file `C:/Windows/system32/kernel32.dll'.
Warning: Cannot locate symbols for file `C:/Windows/SYSTEM32/ntdll.dll'.
Warning: Cannot locate symbols for file `C:/Windows/system32/KERNELBASE.dll'.
Warning: Cannot locate symbols for file `C:/Program Files (x86)/Intel/VTune Amplifier XE 2013/bin64/tpsstool.dll'>>>

This you can ignore.

>>(3) After updating the VTune to the latest version, the error information are as follows:
>>
>>Warning: Cannot locate symbols for file `C:/Windows/system32/kernel32.dll'.
>>Warning: Cannot locate symbols for file `C:/Windows/SYSTEM32/ntdll.dll'.
>>Warning: Cannot locate symbols for file `C:/Windows/system32/KERNELBASE.dll'.
>>Warning: Cannot locate symbols for file `C:/Program Files (x86)/Intel/VTune Amplifier XE 2013/bin64/tpsstool.dll'

These messages are just Warnings, Not Errors. These Release DLLs do not have any Debug information and there is nothing wrong here ( it's by design ).

Yes I told him.

Hi Sergey,

Your suggestion works.

I set the stack size to a large value before as I have to do some serious work. After reducing the stack size, I can run VTune normally.

I use VS2010 and set the stack size through property page, not runtime. Is it possible to set stack size at runtime in Fortran?

Thanks and regards,

Daniel

引文:

Sergey Kostrov 写道:

You could try to set a smaller size for OMP_STACKSIZE environment variable at runtime as follows:
...
int iRetCode = _putenv( "OMP_STACKSIZE=32K" );
if( iRetCode == 0 )
printf( "OMP_STACKSIZE=%s\n"), getenv( "OMP_STACKSIZE" );
else
printf( "Error: Failed to Set Environment Variable OMP_STACKSIZE\n" );
...

Great:) sometimes the simplest solution is the best one.

>>...I set the stack size to a large value before as I have to do some serious work. After reducing the stack size, I can
>>run VTune normally...

Thanks for the update.

>>...I use VS2010 and set the stack size through property page, not runtime.

These values ( Stack Reserve and Stack Commit ) are for the application in whole and they're not used by OpenMP when it creates new threads for processing.

>>...Is it possible to set stack size at runtime in Fortran?

I think Yes if it has a function that sets Environment Variable, that is similar to CRT function _putenv.

发表评论

登录添加评论。还不是成员?立即加入