OpenGL FBOs on Intel HD 4000

OpenGL FBOs on Intel HD 4000

Hi to all,

I apology in advance if this sounds as a very "beginner question"

I am developing a free OpenGL painting application called SpeedyPainter (http://speedypainter.altervista.org/)

I use FBO for rendering to texture, but it seems that hardware equipped with inter HD graphics cards, even the HD 4000 has problems with this extension. It seems that the application simply fails to start on that hardware. I have not a direct experience with this issue since i have not such hardware at my disposal, but, from reading a lot of feedbacks from my application users, it seems that this problem happens very often with integrated graphics adapters.

I followed the very useful tutorial about FBOs by Songho that i found here: http://www.songho.ca/opengl/gl_fbo.html. Does that code actually works on intel HD 4000 hardware?

I am very interested in making my application compatible also on that hardware, since this way my software will run properly also on ASUS VivoTab Smart, and on Microsoft Surface pro, so every help will be very appreciated :)

One thing that makes me uncertain, and that may be the cause of all those problems, is that I mix immediate mode and new OpenGL features, like FBOs, and glBlendFuncSeparate, may this can be the cause o

My test configuration has the following graphics card
ATI Mobility Radeon HD 5650
whit 
GL_VERSION: 3.2.9756 Compatibility Profile/Debug Context
GLSL_VERSION: 1.50
and everything works very well on this (quite old) hardware..

Thank you in advance!

Kind regards,
Andrea

1 条帖子 / 0 全新
如需更全面地了解编译器优化,请参阅优化注意事项