ld: library not found for -lSystemStubs

ld: library not found for -lSystemStubs

I just did a clean install of XCode 4.3 and ifort.  

The ifort installer said that it could not find the XCode*.app (presumably because Apple has moved XCode out of Developer/Applications folder), but otherwise installed successfully.  

Now, when I do a command-line ifort compile, I get the following error: 

ld: library not found for -lSystemStubs

Any thoughts?

8 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Did you install the optional "Command Line Tools" with Xcode.  If not, start Xcode.  From the 'Xcode' Menu -> Preferences.  with the Preferences dialog open, click Downloads tab.  Select Comman Line Tools and click Install.

Also, the compiler versions and Xcode versions should be selected to be compatible.  What version of compiler are you using?  Check it's Release Notes document (on IRC or from the product documentation).  I am suspicious that you have an old compiler version, since the installer in the recent years has prompted the user to locate Xcode.  This because as you say Xcode moved to the Applications folder.  So if it didn't ask you, I suspect you have a compiler version that is older and would not be compatible with Xcode 4.3.

Check the Release Notes for your compiler to find the Mac OS X and Xcode versions supported.  Again, the Intel Fortran compiler is quite particular about what specific combinations are supported.  If you go outside those supported versions of OS and Xcode it probably will NOT work.

ron

I did install the "Command Line Tools".

I am using an old compiler, version 11.0.066, however, I've used it for years.  It worked great up until a month ago when I wiped my hard drive and did a clean re-install.  

Note that I'm not using really using Xcode (i.e. all I care about is compiling and running Fortran code from the command line either manually or via a Makefile).

That old compiler doesn't support the version of Xcode (or probably OS X) you're using:

  • Mac OS* X 10.4.11 or 10.5.5
  • Mac OS* X Developer Tools including Xcode* 2.5 or 3.1.1

You may have to hand-edit the ifortvars.sh file to properly locate everything in the new Xcode.

Steve

Steve,

Any chance you could give me a push in the right direction with modifying ifortvars.sh?

I opened /opt/intel/Compiler/11.0/066/bin/ifortvars.sh, but can find no reference to Xcode or its libs.

Thanks,

-Nick

Sorry, I'm not a Mac user. Maybe Ron can help when he sees this. On Linux it would be something related to LIBRARY_PATH (and maybe LD_LIBRARY_PATH, used for shared objects.) I think Mac is the same, but Apple likes to go their own way....  Can you find where that library is located and use -L to specify the path?

Steve

I have just installed the latest version of Xcode (5.1) and also "Command Line Tools", I have bought the license for "Composer XE 2013" and I have downloaded and installed "m_fcompxe_2013_sp1.2.139.dmg" which, I think, is the latest version. I still receive the same error "ld: library not found for -lSystemStubs" when I want to compile fortran codes.

Thanks

Mehdi

The latest Composer XE version is that which you indicated; however, the Composer XE 2013 SP1 does not yet support Xcode 5.1. The coming Update 3 currently planned for later this month will.

I do not know for certain whether the error you suffered is related to non-support of Xcode 5.1. If you are unable to wait until the Update release later this month, then you could consider downgrading your Xcode to the versions supported (see the Release Notes), or consider trying the work around discussed in this thread that enabled use of Xcode 5.1 with the Intel C++ (14.0) compiler from CXE 2013 SP1 Update 2.

登陆并发表评论。