Disable TBB on CPU fallback

Disable TBB on CPU fallback

Alexander Herz的头像

Hi,

I have a slightly obscure problem :) For testing purposes we're running opencl inside a linux VM, so the actual gfx hardware is not accessable. We're using the CPU fallback from intel's opencl impl instead. Apparently, this impl is using TBB to get better performance but our environment does not allow for third parties to create any threads. We don't need any performance, just that it works at all. Is there a way (maybe by setting an environment variable) to disable the multi-threading inside intel's CPU based opencl driver?

Thx, Alex

7 帖子 / 0 new
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项
Raghu Muthyalampalli (Intel)的头像

I believe that's not possible. You may be able to play with global and local sizes to restrict the number of threads but the runtime still depends on tbb. I will fwd your question to see if there are workarounds.

Raghu

Raghu Muthyalampalli (Intel)的头像

Ok. Looks like there is no way to disable TBB.

Yuri Kulakov (Intel)的头像

Hi Alexander,

Is it possible to adjust VM settings so it uses only 1 core (without HT)? Probably this will prevent TBB from creating new threads.

Thanks,
Yuri

Maxim Shevtsov (Intel)的头像
Alexander Herz的头像

Great, immidate exec seems to fix my problem.

I assume the standard TBB ENV vars also work here?

Regards,

Alex

Raghu Muthyalampalli (Intel)的头像

Thanks Max. I wasn't aware of the extension. Moreover I misunderstood the question as "completely disabling tbb".

登陆并发表评论。