Can not build ipp-samples.7.1.1.013

Can not build ipp-samples.7.1.1.013

Hi everyone, i try to build code samples 7.1.1.013 from the guide

http://software.intel.com/en-us/articles/building-intel-ipp-71-samples#comment-1751314

 I tried with lots of commands even example commands but it says invalid configuration everytime . What is the problem?

38 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hi,

Could you try one of the command provided as examples at the end of article:

    perl build.pl --cmake=audio-video-codecs,ia32,vc2010,s,st,release
    perl build.pl --cmake=uic,intel64,make,s,mt,debug --build
   perl build.pl --cmake=uic,intel64,make,d,mt,debug --build --clean

What's happening then?

Regards,
Sergey 

Regards, Sergey

Yes it says

ERROR: invalid configuration

I downloaded activePerl 5.16.3 and i run the command from windows powershell 

...
- Make sure all environment variables are set by running the ippvars or compilervars script.
...

Did you do that step?

It can be the issue with directory name. The script doesn't work if some of sample directory/subdirectory names contain a space. Could you check this?

Regards,
Sergey 

Regards, Sergey

@Sergey Khlystov 

I checked nothing has changed

@Sergey Kostrov

Can you explain what you mean with " all environment variables are set by running the ippvars or compilervars script"

For regular samples (excluding uic/picnic) no other, than IPPROOT, environment variables required. If the script doesn't find proper IPP configuration, the diagnostic message is defferent, i.e.
        Intel(R) IPP was not found (required)!

Yes, I see the problem under Windows Powershell. While we're investigating this, please use Windows "cmd" window for samples build.

Regards,
Sergey 

Regards, Sergey

Found workaround :). The commands like:

     perl build.pl "--cmake=uic,intel64,vc2010,s,mt,debug" "--build"

(i.e. with double quotes) work in powershell. Looks, like powershell parses the command line before Perl.

Regards,
Sergey 

Regards, Sergey

I have a new problem :)

Now says Intel IPP was not found <required>!

I added IPPROOT = "C:\Program Files (x86)\Intel\Composer XE 2013 SP1.083\ipp" to system variables , log off - log in , run command again it didn't fixed :) Is there anyting else that ı have to add to system variables or anywhere else?

The shell script ippvarsem64t.sh in the tools/env directory sets your lib, include, and path environment variables for Intel® IPP. 

I can not find "ippvarsem64t.sh" such a file

>>...Can you explain what you mean with " all environment variables are set by running the ippvars or
>>compilervars script"...

This is the statement from the Guide you've mentioned in the 1st post and take a look at it again.

引文:

hande b. 写道:

I added IPPROOT = "C:\Program Files (x86)\Intel\Composer XE 2013 SP1.083\ipp" to system variables

Please use directory name without double quotes

set  IPPROOT = C:\Program Files (x86)\Intel\Composer XE 2013 SP1.083\ipp

Regards,
Sergey 

Regards, Sergey

It supposed that when setting up intel primitives the environmental variables setted automatically.

@Sergey Khlystov you misuderstood me i used quotes for emphasize the IPPROOT value :) I setted it from advanced system settings not from console .

I found ippvars_ia32.bat file for setting variables and run it, but console is opened and closed immediately

The command files like ippvars_ia32.bat are to be submitted from open command line window. They update the environment of current cmd session. Look at my log:

C:\Users\skhlysto>dir "%IPPROOT%"
Volume in drive C is OSDisk
Volume Serial Number is 243E-FF80

Directory of C:\Users\skhlysto

File Not Found

C:\Users\skhlysto>"c:\Program Files (x86)\Intel\Composer XE 2013\ipp\bin\ippvars.bat" ia32

C:\Users\skhlysto>dir "%IPPROOT%"
Volume in drive C is OSDisk
Volume Serial Number is 243E-FF80

Directory of c:\Program Files (x86)\Intel\Composer XE 2013\ipp

07/11/2013 15:06 <DIR> .
07/11/2013 15:06 <DIR> ..
07/11/2013 15:07 <DIR> bin
07/11/2013 15:06 <DIR> demo
07/11/2013 15:06 <DIR> include
07/11/2013 15:06 <DIR> interfaces
07/11/2013 15:06 <DIR> lib
07/11/2013 15:06 <DIR> tools
0 File(s) 0 bytes
8 Dir(s) 21,207,990,272 bytes free

C:\Users\skhlysto>

After that "perl build.pl" should work. Just change the location of ipp\bin\ippvars.bat to yours. All of this is described in IPP docs.

Regards,
Sergey 

 

Regards, Sergey

Hi , the problem is not fixed still .

I run ippvars.bat ia32 from ipp/bin directory, 

compilervars.bat ia32 from Composer XE\bin

compilervars.bat ia32 from Composer XE 2013 SP1.083\bin

İ am inserting screenshots

附件: 

附件尺寸
下载 untitled.png5.75 KB
下载 untitled2.png6.82 KB
下载 untitled3.png3.21 KB

Hi,

I am on vacation, thus there will be no expedite answers. Did you do "dir %IPPROOT%"? What is it showing? The rules of searching for IPP in the script are simple. It looks for ipp.h (or, ippcore.h I don't remember) in %IPPROOT%\include and it looks for library ippcorel,lib in %IPPROOT%\lib\ia32. It can be seen from Cmake script FindIPP. I have no working sandox and cannot verify .I asked out other guys to help.

Regards,
Sergey 

Regards, Sergey

Hello, 

  • I've just tried to setup IPPROOT environment variable via compilervars.cmd and it works. 
  • Also I have tried the same compiler environment shell-script with PowerShell andit doesn't work, %IPPROOT% variable is empty

You have attached only the logs of environment setup. What about build error in examples? Can you also attach log? 

Hi Hande,

Which sample do you like to run or what command you'd like to run to build the sample?  I recalled there are many build issues in the forum.  So i had attached two built MSVC2010 project in

http://software.intel.com/en-us/forums/topic/339934

You can see the mscv 2010 solution under __cmake\audio-video-codecs.ia32.vc2010.s.st.

Best Regards,

Ying

 

I am trying to build speech-codecs on OS X. My goal is to include G.729 codec in pjsip to use in my iPhone app. It looks like the path is wrong and I don't know how to set it. I search through many docs and still no clue.

http://trac.pjsip.org/repos/wiki/Intel_IPP_Codecs#MacOSXInstructions << can't find readme.htm so I'm stuck
http://software.intel.com/en-us/articles/intel-ipp-71-samples-build/ << no information, one of intel guy's comment links to this forum, and still no information here.

Help please. This is the error.

Hlung-Oozou:builder thongchai$ perl build.pl --cmake=speech-codecs,ia32,xcode,s,mt,debug --build
CMake Error: The source directory "/Users/thongchai/Documents/Projects/Fingi/Fingi iOS resources/sip/ipp-samples.7.1.1.013/__cmake/speech-codecs.ia32.xcode.s.mt/resources/sip/ipp-samples.7.1.1.013/sources/speech-codecs" does not exist.
Specify --help for usage, or press the help button on the CMake GUI.
Not searching for unused variables given on the command line.
Unknown argument iOS
Unknown argument resources/sip/ipp-samples.7.1.1.013/builder/../__cmake/speech-codecs.ia32.xcode.s.mt
Usage: cmake --build <dir> [options] [-- [native-options]]
Options:
<dir> = Project binary directory to be built.
--target <tgt> = Build <tgt> instead of default targets.
--config <cfg> = For multi-configuration tools, choose <cfg>.
--clean-first = Build target 'clean' first, then build.
(To clean only, use --target 'clean'.)
--use-stderr = Don't merge stdout/stderr.
-- = Pass remaining options to the native tool.

[ speech-codecs.ia32.xcode.s.mt.debug State: FAIL ]

cont.

I also already run ippvars or compilervars script, as suggested in http://software.intel.com/en-us/articles/intel-ipp-71-samples-build/.

Using the Intel® IPP 7.1 Sample Build System

A few initial steps are required:

  • In Windows*, open a command shell window. In Linux*/OS X* open a terminal.
  • Make sure all environment variables are set by running the ippvars or compilervars script.

These are the exact commands I run them.
/opt/intel/composer_xe_2013_sp1.0.001/bin/compilervars.sh ia32
/opt/intel/composer_xe_2013_sp1.0.001/ipp/bin/ippvars.sh

But I still got the same error mentioned. Any ideas?

Hello,

Do you use PowerShell?
Please upload full log from command shell, including IPP examples build.cmd and compilervars.sh

I am NOT using PowerShell. I am on OS X!!! I already posted the log and explained my problem and what OS am in in my previous answer. Please look at that.

引文:

Anton Sibilev (Intel) 写道:

Hello,

Do you use PowerShell?
Please upload full log from command shell, including IPP examples build.cmd and compilervars.sh

Try to use path without spaces

"/Users/thongchai/Documents/Projects/Fingi/Fingi iOS resources/sip/ipp-samples.7.1.1.013/__cmake/speech-codecs.ia32.xcode.s.mt/resources/sip/ipp-samples.7.1.1.013/sources/speech-codecs"

Unknown argument iOS
Unknown argument resources/sip/ipp-samples.7.1.1.013/builder/../__cmake/speech-codecs.ia32.xcode.s.mt

Thanks, the space was the problem. Now I get a new error. Intel(R) IPP was not found (required)!

I already run /opt/intel/composer_xe_2013_sp1.0.001/ipp/bin/ippvars.sh intel64, to set the environment variables.

I also tried setting IPPROOT and DYLD_LIBRARY_PATH in .bash_profile. But it still doesn't find Intel IPP.

export IPPROOT=/opt/intel/composer_xe_2013_sp1.0.001/ipp
export DYLD_LIBRARY_PATH=/opt/intel/composer_xe_2013_sp1.0.001/ipp/../compiler/lib:/opt/intel/composer_xe_2013_sp1.0.001/ipp/lib

Here is the erorr. I also tried to echo the environment variables at the end so you should see that they have a value but problem still occur. Any idea?

Hlung-Oozou:builder thongchai$ perl build.pl --cmake=speech-codecs,ia32,xcode,s,mt,debug --build --clean
Not searching for unused variables given on the command line.
-- The C compiler identification is Clang 4.2.0
-- The CXX compiler identification is Clang 4.2.0
-- Check for working C compiler using: Xcode
-- Check for working C compiler using: Xcode -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler using: Xcode
-- Check for working CXX compiler using: Xcode -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /Users/thongchai/Documents/Projects/Fingi/Fingi-iOS-resources/sip/ipp-samples.7.1.1.013/builder/FindIPP.cmake:92 (message):
Intel(R) IPP was not found (required)!
Call Stack (most recent call first):
CMakeLists.txt:6 (include)

-- Configuring incomplete, errors occurred!
2013-09-20 18:52:27.276 xcodebuild[86899:1207] XCode4_beginning_of_line initializing...
2013-09-20 18:52:27.277 xcodebuild[86899:1207] XCode4_beginning_of_line failed. :(
2013-09-20 18:52:27.314 xcodebuild[86899:1207] XcodeColors: load (v10.1)
2013-09-20 18:52:27.315 xcodebuild[86899:1207] XcodeColors: pluginDidLoad:
xcodebuild: error: 'speech-codecs.xcodeproj' does not exist.

[ speech-codecs.ia32.xcode.s.mt.debug State: FAIL ]

Hlung-Oozou:builder thongchai$ echo $IPPROOT
/opt/intel/composer_xe_2013_sp1.0.001/ipp
Hlung-Oozou:builder thongchai$ echo $DYLD_LIBRARY_PATH
/opt/intel/composer_xe_2013_sp1.0.001/ipp/../compiler/lib:/opt/intel/composer_xe_2013_sp1.0.001/ipp/lib

The problem is that you are trying to build IPP samples for 7.1.1 with IPP 8.0 (Composer XE 2013 bundle)

Here is quote from IPP 8.0 Release Notes - Intel® IPP library "_l" and "_t" suffixes removed.
That's why cmake search can't find IPP. File builder/FindIPP.cmake should be updated, as workaround.
Can you please try to comment few lines? I've just tried and was able to build speech-codecs with single-threaded libraries..

.......
# set( LIBS_IPP_SUF _l )
set( IPP_MT false )
set( OWN_MT false )
elseif( __THREADING MATCHES mt )
# set( LIBS_IPP_SUF _t )
......
#if(NOT IPP_INCLUDE MATCHES NOTFOUND)
# if(NOT IPP_LIBRARY MATCHES NOTFOUND)
set( IPP_FOUND TRUE )
include_directories( ${IPP_INCLUDE} )
link_directories( $ENV{IPPROOT}/lib/${LIBS_ARCH} )
link_directories( $ENV{IPPROOT}/../compiler/lib/${LIBS_ARCH} )
# endif( )
#endif( )
......
if(NOT DEFINED IPP_FOUND)
# message( FATAL_ERROR "Intel(R) IPP was not found (required)!")
else ( )
.......

ok, I will try that. But I found there's legacy examples for 8.0 here http://software.intel.com/en-us/articles/code-samples-for-intel-integrat... Can I just use that one?

Sure, you can use 8.0 legacy samples(speech-codecs are included), this case will be even better. Thank you.

thank you this was exactly the problem 

引文:

Anton Sibilev (Intel) 写道:

The problem is that you are trying to build IPP samples for 7.1.1 with IPP 8.0 (Composer XE 2013 bundle)

Here is quote from IPP 8.0 Release Notes - Intel® IPP library "_l" and "_t" suffixes removed.
That's why cmake search can't find IPP. File builder/FindIPP.cmake should be updated, as workaround.
Can you please try to comment few lines? I've just tried and was able to build speech-codecs with single-threaded libraries..

.......
# set( LIBS_IPP_SUF _l )
set( IPP_MT false )
set( OWN_MT false )
elseif( __THREADING MATCHES mt )
# set( LIBS_IPP_SUF _t )
......
#if(NOT IPP_INCLUDE MATCHES NOTFOUND)
# if(NOT IPP_LIBRARY MATCHES NOTFOUND)
set( IPP_FOUND TRUE )
include_directories( ${IPP_INCLUDE} )
link_directories( $ENV{IPPROOT}/lib/${LIBS_ARCH} )
link_directories( $ENV{IPPROOT}/../compiler/lib/${LIBS_ARCH} )
# endif( )
#endif( )
......
if(NOT DEFINED IPP_FOUND)
# message( FATAL_ERROR "Intel(R) IPP was not found (required)!")
else ( )
.......

I can confirm that this fixes the issue.  After messing around for over a day trying to build these samples, this finally allowed me to build them without error. 

Hello,

I try to install IPP Samples 8.0.0.005 into IPP composer xe 2013.

However, I have a similar error when trying to build them on my linux machine. When I

~/Downloads/ipp-samples.8.0.0.005/builder/sudo bash build.sh --sample=speech-codecs --arch=intel64 --ws=make --conf=release --build --clean

I get this Error:

CMake Error at .../builder/FindIPP.cmake:60 (message:)
Intel(R) IPP was not found (required)!

I have set all the environment variables to the correct location beforehand, by hand and by the compilervars script.

The weird thing is, when I execute the command without sudo, the script will find IPP and the libraries and shows the paths but it gives a permission denied error for CMake. How can I get around this?

Please help me out here Intel. Thank you in advance.

Hi Timo,

You can see in "FindIPP.cmake" file that looking for IPP in example's CMake scripts is:

set(INTERNAL_IPP_INC $ENV{IPPROOT}/include)
set(INTERNAL_IPP_LIB $ENV{IPPROOT}/lib/${INTERNAL_ARCH})

and

find_path   (INTERNAL_IPP_INC_CORE ippcore.h  PATHS ${INTERNAL_IPP_INC})
find_library(INTERNAL_IPP_LIB_CORE ippcore${INTERNAL_IPP_LIB_SUF} PATHS ${INTERNAL_IPP_LIB})

That means, that CMake trying to find "ippcore.h" in $IPPROOT/include and "libippcore.a" in $IPPROOT/lib/intel64 directories. Please, make sure, that those files are there.

Regards, Sergey

引文:

Sergey Khlystov (Intel) 写道:

Hi Timo,

You can see in "FindIPP.cmake" file that looking for IPP in example's CMake scripts is:

set(INTERNAL_IPP_INC $ENV{IPPROOT}/include)

set(INTERNAL_IPP_LIB $ENV{IPPROOT}/lib/${INTERNAL_ARCH})

and

find_path   (INTERNAL_IPP_INC_CORE ippcore.h  PATHS ${INTERNAL_IPP_INC})

find_library(INTERNAL_IPP_LIB_CORE ippcore${INTERNAL_IPP_LIB_SUF} PATHS ${INTERNAL_IPP_LIB})

That means, that CMake trying to find "ippcore.h" in $IPPROOT/include and "libippcore.a" in $IPPROOT/lib/intel64 directories. Please, make sure, that those files are there.

Thank you for your swift reply, Sergey.

My IPPROOT variable is this: /opt/intel/composer_xe_2013_sp1.3.174/ipp

The ippcore.h file is here: /opt/intel/composer_xe_2013_sp1.3.174/ipp/include/ippcore.h

There is no libippcore.a file in /opt/intel/composer_xe_2013_sp1.3.174/ipp/lib/intel64 however, there is a libippcore.so and libippcore.so.8.1 file in that folder.

Can the latter be the issue here, as this is not a .a file?

 

Alright, it turns out that the environment variables were not there anymore when running the command with sudo. That is why the configuration for the codecs were successful when running without sudo but the cmake command gave a permission denied error. The environment variable linking to the right IPPROOT path was missing when invoking the build command with the superuser.

In case someone has the same problem, here is my solution that solved the problem and got me building the IPP-samples8 working:

  • sudo visudo #opens up the /etc/sudoers.tmp file with nano
  • add this line to the file, in order to keep environment variables for sudo: Defaults env_keep+="IPPROOT IPROOT LD_LIBRARY_PATH" #I think IPPROOT is sufficient, but I added the others aswell, just in case it is needed
  • save the file with ctrl+0 and exit with ctrl+x
  • cd ~/Downloads/ipp-samples.8.0.0.005/builder
  • sudo ./build.sh --sample=speech-codecs --arch=intel64 --ws=make --conf=release --build --clean #adjust to your needs. You can see options by invoking ./build.sh without parameters
  • the script should build the speech codecs sample files and give back a "State: OK" at the end. That's it

I finally got it to work. Thank you all, as this forum helped me dive further into the matter.

Glad to hearing that.

By the way, why do you need sudo? What's exotic in your environment that prevents from running build script as an ordinary user?

I am asking this to update the building documentation if necessary.

Regards, Sergey

引文:

Sergey Khlystov (Intel) 写道:

By the way, why do you need sudo? What's exotic in your environment that prevents from running build script as an ordinary user?

 

Actually, I don't know. Since I started with linux a few weeks ago, whenever I get into permission denied errors, I use sudo. I think it is not really necessary and I just used it because I was used to use sudo. I know that's not the right way and I should get familiar with unix permissions :)

Use "chown" and "chgrp" commands to modify owner and group of the files/directories you are working with. All others - Intel Composer files, IPP files - should have "o+r" and "o+x" access rights enough to work with them using ordinary user rights.

Regards, Sergey

登陆并发表评论。