Intel PHI Card - "Unable to load mic driver"

Intel PHI Card - "Unable to load mic driver"

Hi,

I have been trying to get the PHI card to work on my system. I am able to succesfully install the driver using command "yum install --nogpgcheck --noplugins --disablerepo=* *.rpm". However, once i try to initialize the default settings, using "micctrl --initdefaults", I get back:

"FATAL: Module mic not found.

Unable to load MIC driver. The 'micctrl' command, when called with no MIC card name list requires the MIC driver to be loaded in order to numerate the card list.

If you are performing remote configuration provide the MIC  The MIC card name list."

I am not installing remotely and I have already tried using CentOS and Windows 7 64-bit, both OS's install fine with no issues. I already enabled "over 4G decoding in BIOS", so this is not because of not enabling large BAR.

Can someone please advise?

Thank you,

Kevin

附件尺寸
下载 mic.jpg2.63 MB
6 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Hi Kevin,

Can you please confirm that the MIC module and the OS have the same kernel version?

What are the outputs for:

uname -a

find /lib/modules -name "mic.ko"

 

Thanks,

Leo.

 

 

Because you are using CentOS rather than one of the RHEL or SuSE distributions listed in the readme-en.txt file, you may well find a mismatch between the kernel version for the OS and the mic kernel module, as Leo suspects. You will want to rebuild your kernel module. If you are using the MPSS 2.1 release for Linux, you can find the directions in the readme-en.txt file, section 9.1. 

And as far as Windows is concerned, did you use the MPSS 3.1 release for Windows?

uname -a returns:

Linux test 2.6.32-279.14.1.e16.x86_64 #1 SMP Tue Nov 6 11:21:14 CST 2012 x86_64 x86_64 x86_64 GNU/Linux

find /lib/modules -name "mic.ko" returns:

/lib/modules/2.6.32-279.e16.x86_64/extra/mic.ko

I tried recompiling the host driver as well using the directions from section 9.1 of the readme. However, when i try using the "rpmbuild" command, I get back "bash: rpmbuild: command not found".

Please advise. Thank you.

Zitat:

Gilbert Y. schrieb:
when i try using the "rpmbuild" command, I get back "bash: rpmbuild: command not found".

You have to install rpm-build utilities

yum install rpm-build

发表评论

登录添加评论。还不是成员?立即加入